Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-18-09, 11:17 AM   #1
Ericj1186
Registered User
 
Join Date: May 2009
Posts: 9
Default Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ubuntu

All right, I have two GeForce 250 GTS's. In Windows, they are in SLi mode, so while installing Ubuntu, I took off the bridge to disable SLi mode.

I load up Ubuntu, and it suggests this proprietary driver titled Nvidia Accelerated Graphics Driver (revision 180). I activate and install that, then I reboot. On rebooting, I cannot access the GUI, and I am stuck in the terminal running on tty1. If I uninstall the driver and reboot, I can get to the GUI without issue.

While in the terminal, I check various things, and I get a lot of messages saying my X server is not available, xinit will not load (with error codes).

Also, I have tried Ubuntu 8.04 to the same results.

I don't have a log because I uninstall the driver to get back to GUI, but I can get one if that would help. Also, I checked the stickies/searches, and I couldn't find an issue like mine. I think this may be in line with my issue, but I wanted some feedback before trying it: http://ubuntuforums.org/showthread.php?t=945557

Can anyone help me out?
Ericj1186 is offline   Reply With Quote
Old 05-18-09, 08:47 PM   #2
Ericj1186
Registered User
 
Join Date: May 2009
Posts: 9
Default Re: Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ub

Bumping - Does anyone have any suggestions? I am pretty desperate.
Ericj1186 is offline   Reply With Quote
Old 05-19-09, 04:47 AM   #3
a7v
Registered User
 
Join Date: Jun 2005
Posts: 67
Default Re: Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ub

Why did you disable SLI? SLI does work in Linux.
Well, it could be a number of things that went wrong.
Looking at a couple of the logs might help.
You should run a `nvidia-bugreport.sh`, please see this post http://www.nvnews.net/vbulletin/showthread.php?t=46678

Edit: The official driver support for the GTS 250 didn't appear until version 180.51. Which version did ubuntu install? An earlier driver could work anyway but I never had one of those cards so I can't say for sure. My 9800 GT card did work before the nvidia drivers were updated to recognize it fully.
__________________
Computer stuff I've owned at one time or another:
CPUs: K6-3 400, Duron 600, Thunderbird 1400, Barton 2500, Duron 1800, A-64 3700+, C2D E7200
Motherboards: Shuttle Via MVP, Asus A7V, Asus A7V133, Asus N8X-VM400, Abit NF7, Abit UL8, Asus P5Q Pro
Graphics Cards: TNT2, GF 2 MX, GF 2 Pro, GF4 MX, GF FX 5500, GF 6600, GF 7600 GT, GF 9800GT
a7v is offline   Reply With Quote
Old 05-19-09, 07:38 AM   #4
Ericj1186
Registered User
 
Join Date: May 2009
Posts: 9
Default Re: Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ub

One guide I read said that if SLi is enabled before installing Ubunbtu, it will cause a black screen, which is what my issue was, so I figured that would help. Regardless, my SLi bridge is enabled.

I will run that log, and post it once I get home and have access to the computer.

I believe the version was just 180, but I also installed 180.51 from the Nvidia site with the same results.

Thanks for the suggestions.
Ericj1186 is offline   Reply With Quote
Old 05-24-09, 02:47 PM   #5
AndersBP
Registered User
 
Join Date: May 2009
Posts: 2
Default Re: Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ub

Your problem might be that X doesn't know which of the boards it need to load the screen driver onto.

try following in a console:

1. cd /sbin
2. lspci | grep -i vga ,,, this will show you the pci bus slot number on your cards
3. nano /etc/X11/xorg.conf ,,,
4. find Section "Device" and insert a line
Busid "PCI:05:0:0" ,,,,instead of 5, you need to use the number given by the lspci command

this should allow you to start X again,,,

cheers

Anders
AndersBP is offline   Reply With Quote
Old 05-24-09, 08:58 PM   #6
Ericj1186
Registered User
 
Join Date: May 2009
Posts: 9
Default Re: Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ub

I will try that one first. I am reinstalling Ubuntu 64-Bit because, for whatever reason, my previous disk was 32-Bit, and I ended up messing up my sound when I tried to do 5.1 surround sound.

Sorry for taking so long to reply. I will respond with the bug report if the last idea posted does not work. Thanks!
Ericj1186 is offline   Reply With Quote
Old 05-24-09, 11:52 PM   #7
Ericj1186
Registered User
 
Join Date: May 2009
Posts: 9
Default Re: Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ub

All right, I did everything you said. My cards are on ports 4 and 5, so I chose port 4.

When I edited xorg.conf, it wouldn't let me save my settings and said "Permission Denied."

Any ideas on what to do?
Ericj1186 is offline   Reply With Quote
Old 05-25-09, 02:39 AM   #8
Qwerted
Registered User
 
Join Date: Mar 2009
Location: Russia
Posts: 19
Default Re: Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ub

Quote:
Originally Posted by Ericj1186 View Post
When I edited xorg.conf, it wouldn't let me save my settings and said "Permission Denied."
Any ideas on what to do?
you need root privileges to do it. Use sudo
__________________
Nvidia 8300 mGPU (Asus M3N78 PRO)
Debian lenny, 2.6.29.2
Qwerted is offline   Reply With Quote

Old 06-01-09, 09:23 PM   #9
Ericj1186
Registered User
 
Join Date: May 2009
Posts: 9
Default Re: Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ub

Sorry it has taken me so long to reply, I have been a bit busy.

I did the new command with the sudo, saved the file, did startx, and when I did that my screen went black. No text or anything, but it is the black screen where it is still powered up (versus the black screen that is just black when off). The system is running, but I can see nothing. Any ideas?

Thanks so much.
Ericj1186 is offline   Reply With Quote
Old 06-11-09, 06:26 PM   #10
Ericj1186
Registered User
 
Join Date: May 2009
Posts: 9
Default Re: Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ub

So, I tried Alt + Ctrl + F1 (nor any Fn) which didn't work. I got to recovery mode, and I didn't see a console option, but I did do fixX, followed by boot normal, which allowed me to get back to my original road block - the text based console prompting me with logging in as before. I believe the fixX said it was going to rewrite over my xconfig file. Should I re-edit that to the other card or what?
Ericj1186 is offline   Reply With Quote
Old 06-18-09, 09:33 PM   #11
Ericj1186
Registered User
 
Join Date: May 2009
Posts: 9
Default Re: Booting to terminal after installing NV Accelerated Graphics Driver (v. 180) + Ub

Any new advice or suggestions? I am still stuck.

Thanks
Ericj1186 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thoughts from console owners on NVIDIA's GEFORCE GRID MikeC Console World 11 05-27-12 08:43 AM

All times are GMT -5. The time now is 11:17 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.