Go Back   nV News Forums > Graphics Card Forums > NVIDIA Windows Graphics Drivers

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-30-02, 05:33 PM   #1
sisi
Registered User
 
Join Date: Aug 2002
Posts: 2
Lightbulb QIII engines & Dets 40.41 "darkness" fix...

Hello everybody!

I've been browsing this forum for eons... but I never felt like registering and posting something. Today, however, I managed to fix the "darkening issue" with the latest Detonators (40.41) and games based on QIII engine (well, I at least hope I managed to fix it - it worked for me, but it might not work for somebody else). I thought that this may be interesting to many others who experience "very dark" gameplay with QIII, JKII, etc...

The fix (that worked for me) is setting QIII internal engine variable "r_ignorehwgamma" to "1" (mine was "0" originally).

You can do this either through the "in-game" console by typing:
/r_ignorehwgamma "1"
/vid_restart

or by rewriting the configuration file by adding the following line to it:
seta r_ignorehwgamma "1"

(QIII config file is [QIII Dir]\baseq3\q3config.cfg, JKII config file is
[JKII Dir]\GameData\Base\jk2config.cfg)

This worked great for me in JKII, and should work fine also with other QIII engines...

So, how do you like it? Does it work for you? Opinions?

Have fun,
Sisi.
sisi is offline   Reply With Quote
Old 08-30-02, 06:09 PM   #2
styles-T
-========-
 
styles-T's Avatar
 
Join Date: Jul 2002
Location: Smallville
Posts: 492
Default

Right..It does work..But then it locks the gamma slider ingame - No?

I remember fiddeling with this setting once before..
styles-T is offline   Reply With Quote
Old 08-30-02, 07:57 PM   #3
Kruno
TypeDef's assistant
 
Join Date: Jul 2002
Location: Australia
Posts: 1,641
Send a message via ICQ to Kruno Send a message via AIM to Kruno
Default

I solved it by downloading my monitor drivers and changing refreshrates to as high as possible and tada. RTCW never looked better
__________________
"Never before has any voice dared to utter the words of that tongue in Imladris, Mr. Anderson" - Elrond LOTR
Kruno is offline   Reply With Quote
Old 08-31-02, 07:34 AM   #4
sisi
Registered User
 
Join Date: Aug 2002
Posts: 2
Default

I also found out, that fiddling with the attribute "r_overBrightBits" does wonders... mine was originally set at "1", changed it to "0", upped the gamma using "in-game" controls and everything is looking fine...

I like this "fix" more, than the one messing with "r_ignorehwgamma"... as you pointed out, this also disables the "in-game" gamma control.
sisi is offline   Reply With Quote
Old 09-01-02, 02:34 AM   #5
Nv40
Agent-Fx
 
Nv40's Avatar
 
Join Date: Aug 2002
Location: everywhere
Posts: 2,216
Default

indeed


i hope to see a fix in the next 40.xx drivers ,
it was working perfectly with old drivers ,
and the above fix locks the gamma slider ..


update : nope it dont works , with the above settings
Quake3 textures colors in the maps looks dead , not sharp
and vivid like before ...

Last edited by Nv40; 09-01-02 at 02:39 AM.
Nv40 is offline   Reply With Quote
Old 09-01-02, 04:42 AM   #6
CraigGen
Registered User
 
Join Date: Aug 2002
Location: UK
Posts: 48
Default

The "r_ignorehwgamma" is an old trick that was first used in Win2k, but is still effective in XP.

Try this if it's too dark.

Use "r_ignorehwgamma 1" setting and start a map that contains dark areas, then pause it by pressing tilde, and press alt+Enter to goto a window.
Move the window slightly off screen but enough to make sure you can still see the game.
Goto your Geforce Color Correction panel and play about with the settings until you start to see Quake3 just how you like it.
I find upping the Vibrance to the 3rd notch, dropping the brightness a wee bit, up the contrast a bit, and up the gamma to about 1.40 depending on how you have your own monitor's brightness set.
Save it the setting as Quake3 or similar, go back to Quake3 and Alt+Enter to go back to full screen, and try again.
This normally gets me a better picture than using it's own brightness slider.
__________________
Athlon 1.6 Ghz o/c to 1.9 150 bus
Epox 8kha+
512Mb Micron DDR PC2100
MSI GF4 Ti 4600
SBLive Platinum + Livedrive
Liteon 48x CDRW
Pioneer Slot DVD 106s
CraigGen is offline   Reply With Quote
Old 09-03-02, 04:55 AM   #7
AngelGraves13
Registered User
 
Join Date: Aug 2002
Posts: 2,383
Default

hell I tried all of those........after a while I just said screw it and didn't bother doing it anymore. just put up the birghtness on the monitor........putting the gamma up makes it washed out anyways.
AngelGraves13 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
New 40.41 refresh rate fix ???? Smokey NVIDIA Windows Graphics Drivers 8 08-30-02 01:32 PM

All times are GMT -5. The time now is 09:19 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.