Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-19-09, 01:10 PM   #1
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default HDMI audio on my laptop

Hello,

I'd like to get HDMI audio working, but even after lengthy googling sessions I didn't get anywhere.

I have a HP Compaq 8710p with a Quadro NVS 320M and a "82801H (ICH8 Family) HD Audio Controller" sound card. I haven't gotten anywhere and don't know which way to go from here...

Code:
 $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Thanks!
LubosD is offline   Reply With Quote
Old 05-20-09, 03:29 AM   #2
queen6
Registered User
 
Join Date: Dec 2007
Posts: 64
Default Re: HDMI audio on my laptop

Can you email (1) me "lspci -vnn | grep Audio -A12" output and "zcat /proc/config.gz"?
EDIT: also add output of "cat /etc/asound.state"

I had the same problem with Asus G1S (GF8600m GT + Intel HDA) and had write a patch to kernel alsa driver to get it sorted. For your laptop we should be looking at something like:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0



Thanks
Rob

1) email me on dagger AT gentoo.org
queen6 is offline   Reply With Quote
Old 05-20-09, 05:59 AM   #3
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: HDMI audio on my laptop

Code:
# lspci -vnn | grep Audio -A12
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)
        Subsystem: Hewlett-Packard Company Device [103c:30c3]
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at e8024000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Mask- 64bit+ Count=1/1 Enable-
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03) (prog-if 00 [Normal decode])
queen6: Also sending to your e-mail, thanks!
Attached Files
File Type: gz config.gz (14.6 KB, 104 views)
File Type: txt asound.state.txt (2.1 KB, 111 views)
LubosD is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
IOGEAR 3D Complete+ 4-Port HDMI Switcher with 2D/3D Video Processor News Archived News Items 0 06-28-12 05:40 PM
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 03:55 AM
No HDMI audio on 302.07 fldc NVIDIA Linux 5 06-01-12 04:46 PM
Blu-ray 3D Movie Playback With PC on a 3D HDTV Using HDMI 1.4 News Archived News Items 0 05-16-12 03:30 AM
HDMI audio ELD weirdness RockHound NVIDIA Linux 0 05-11-12 03:45 AM

All times are GMT -5. The time now is 05:40 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.