Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-16-09, 03:43 PM   #1
radoeka
Registered User
 
Join Date: Apr 2009
Posts: 3
Question Bugreport: glitches / artifacts with 180.x (now 180.44) + kde4 when windows are moved

[I have sent the information below to the email address that is displayed when running nvidia-bug-report.sh, that was almost a week ago. Sofar no response]

Hopefully this is the right place to get support for the problem I see with my graphical system of which nvidia is the main part.

I see artifacts / glitches when a window moves from the back to front (top) or the other way around. When I move the window on top a little bit, the artifact / glitch disappears. The artifact also disappears if a mouse comes close to the artifact. In the attachments you can see the problem that I have.

I assume that all information about the video system is in the nvidia-bug-report logfile. some relevant information:
GeForce 7600GT, AGP 8x, driver 180.44

I'm using it in combination with kde-4.2.2. However, I saw the problem also with earlier kde releases (4.1.x). I have used nvidia-drivers 180.22 and later and on all those releases the problem exists.

glxgears reports around 2000 FPS, which looks good to me. At least the card works fine (except for the artifacts / glitches).

The InitialPixmapPlacement value = 1, but changing this to 2 does not seem to help. The cache is on and its size is PixmapCacheRoundSizeKB.
Attached Thumbnails
Click image for larger version

Name:	background-artifacts-1.gif
Views:	217
Size:	93.4 KB
ID:	36490  Click image for larger version

Name:	square-around-cursor.gif
Views:	177
Size:	43.7 KB
ID:	36491  Click image for larger version

Name:	gimp_with_artifacts.gif
Views:	156
Size:	26.9 KB
ID:	36492  
Attached Files
File Type: gz nvidia-bug-report.log.gz (17.5 KB, 82 views)
radoeka is offline   Reply With Quote
Old 04-16-09, 04:50 PM   #2
walmartshopper
Registered User
 
Join Date: Dec 2008
Posts: 23
Default Re: Bugreport: glitches / artifacts with 180.x (now 180.44) + kde4 when windows are m

I have this problem with an 8800GT. It happened with KDE 4.2.1, 4.2.2, and all 180.* or 185.* series drivers. The "dim screen for administrator mode" desktop effect really seems to trigger it... I get artifacts all over the screen if I use kdesu. I see it a little bit in yakuake too.

I'm running Slackware-current with kernel 2.6.29.1.
walmartshopper is offline   Reply With Quote
Old 04-16-09, 05:17 PM   #3
radoeka
Registered User
 
Join Date: Apr 2009
Posts: 3
Default Re: Bugreport: glitches / artifacts with 180.x (now 180.44) + kde4 when windows are m

Quote:
Originally Posted by walmartshopper View Post
The "dim screen for administrator mode" desktop effect really seems to trigger it...
Where can this setting be found in kde system settings?
radoeka is offline   Reply With Quote
Old 04-21-09, 10:40 AM   #4
lindquist
Registered User
 
Join Date: Feb 2006
Posts: 4
Default Re: Bugreport: glitches / artifacts with 180.x (now 180.44) + kde4 when windows are m

I'm seeing this problem as well on my setup.

Kde 4.2.2 + nvidia 180.44 @ GeForce 8500 GT 512MB

Arch Linux 32bit kernel 2.6.29
lindquist is offline   Reply With Quote
Old 04-22-09, 09:06 AM   #5
lindquist
Registered User
 
Join Date: Feb 2006
Posts: 4
Default Re: Bugreport: glitches / artifacts with 180.x (now 180.44) + kde4 when windows are m

I've moved to Arch Linux 64bit and the problem has gone away, this is possibly only a problem with the 32bit nvidia driver.
lindquist is offline   Reply With Quote
Old 05-22-09, 05:42 PM   #6
radoeka
Registered User
 
Join Date: Apr 2009
Posts: 3
Unhappy Re: Bugreport: glitches / artifacts with 180.x (now 180.44) + kde4 when windows are m

Last week I upgraded to nvidia-180.51, but the problem is still there

Nvidia, please provide a fix for this, as a desktop with such lines is disturbing to work with!
radoeka is offline   Reply With Quote
Old 06-07-09, 02:19 PM   #7
gigadude
Registered User
 
Join Date: Dec 2002
Posts: 2
Default Re: Bugreport: glitches / artifacts with 180.x (now 180.44) + kde4 when windows are m

I get this problem too with the last several drivers I've tried:

Qt: 4.5.0
KDE: 4.2.2 (KDE 4.2.2)
OpenGL renderer string: GeForce GTX 280M/PCI/SSE2
OpenGL version string: 3.0.0 NVIDIA 185.18.14
Mandriva Linux 2.6.29.3-desktop-1mnb #1 SMP x86_64 Intel(R) Core(TM)2 Quad CPU Q9000 @ 2.00GHz

185.18.14 seems to be better but I've still seen it a few times.
gigadude is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why Windows 8 could be the next Vista News Archived News Items 0 06-15-12 11:30 AM
Like XP or Vista: how will businesses treat Windows 8? News Archived News Items 0 06-06-12 10:10 AM
NVIDIA Brings 18 Years of Experience to Windows 8 News Archived News Items 0 06-03-12 07:20 AM

All times are GMT -5. The time now is 01:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.