Go Back   nV News Forums > Linux Support Forums > NVIDIA Solaris

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-12-09, 04:10 PM   #1
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default xorg.conf doesn't appear to be read

I'm running Solaris SXCE 114. I noticed after I log in if I start the application "nvidia-settings" my whole desktop will blank for about one second then reappear. After it reappears I noticed that the whole display was brighter with more contrast, similar to adjusting the gamma. Also, my mouse cursor was "shadowed". I remember setting the mouse some time ago and forgot about it. So I looked, and there is no /etc/X11/xorg.conf file. No problem, I'll use the "nvidia-setting" utility to save a new xorg.conf file.

After this task was completed, I verified that the file was saved. I rebooted my computer, it behaves as if nothing was changed. I started the application "nvidia-settings" application again, and my whole desktop will blank for about one second then reappear. After it reappears I noticed that the whole display was brighter with more contrast, again and also, my mouse cursor was now again "shadowed".

How come Nvidia/Xorg doesn't appear to read the /etc/X11/xorg.conf file?
paulgress is offline   Reply With Quote
Old 06-13-09, 10:00 AM   #2
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: xorg.conf doesn't appear to be read

To answer my own post. Doing research I found that Nvidia will not automatically start its own saved extension available from "nvidia-settings". There are a few ways to achieve this. One way is to add the command "nvidia-settings -l" into the ".xinitrc" file. My computer has multiple links and files so I opted not to use this method. What I decided to do was add that command into my "/home/.profile" file. The "-l" option for "nvidia-settings" just means read and load the ".nvidia-settings-rc" saved using the "nvidia-settings" utility. This worked for me.

One last method, it appears Nvidia/Xorg does read the "xorg.conf" file, its just when saved from the "nvidia-settings" utility, it doesn't add any extensions. You have to add them manually.

Example:

For the cursor shadow to work I had to add following line into /etc/X11/xorg.conf file

Option "CursorShadow" "true"

Also, the "nvidia-settings -l" method above will also get the cursor shadow working.

My take on this, the "nvidia-settings" utility should have a check box to ask if you would like these setting to automatically start at boot by adding its own entry to /home/.profile file or globally by adding it to .xinitrc file.
paulgress is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:21 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.