Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-15-03, 12:05 PM   #1
preacher
Registered User
 
Join Date: Jun 2003
Posts: 7
Send a message via ICQ to preacher
Default Garbled screen in X immediately after nvidia logo - RESOLVED! (too high resolution)

Hi all, I have a problem that I've been unable to solve myself.

I've recently compiled myself a Linux system after the instructions found at www.linuxfromscratch.org (so I'm not using any distribution.

However, when I try to run my x11 using the latest nvidia driver (1.0-4363) the screen gets garbled directly after the Nvidia logo.

I did some research and found that a few other people had had issues with garbled screens but that it in their case X hanged totally. I can still move and (barely) make out a cursor, or press Ctrl-Alt-Backspace to exit, but I can't see my Gnome 2.2 starting.

Using the normal nv driver instead of nvidia works just fine.

I have compiled in MTRR, AGP (for my chipset) and DRI support (generally, no module) in the kernel.

I'm using the latest version of xfree, 4.3.0.

Is there anyone who might know what this error could be about?

Some additional info:

[preacher@corinthian ~]$ cat /proc/driver/nvidia/cards/0
Model: GeForce2 MX/MX 400
IRQ: 11
Video BIOS: ??.??.??.??.??
Card Type: AGP

All this is running on an Athlon 1400.

I uploaded a log and my config file.
Attached Files
File Type: log xfree86.0.log (25.9 KB, 102 views)

Last edited by preacher; 06-18-03 at 01:35 PM.
preacher is offline   Reply With Quote
Old 06-15-03, 12:10 PM   #2
preacher
Registered User
 
Join Date: Jun 2003
Posts: 7
Send a message via ICQ to preacher
Default

And here is the config.
Attached Files
File Type: log xf86config-4.log (2.8 KB, 106 views)
preacher is offline   Reply With Quote
Old 06-15-03, 02:37 PM   #3
ste
Registered User
 
Join Date: May 2003
Posts: 7
Default

You aren't by any chance using a flat panel and a DVI cable?
/ste
ste is offline   Reply With Quote
Old 06-15-03, 03:10 PM   #4
preacher
Registered User
 
Join Date: Jun 2003
Posts: 7
Send a message via ICQ to preacher
Default

Sorry no, normal VGA cable and a 21" CRT.
preacher is offline   Reply With Quote
Old 06-16-03, 09:08 AM   #5
Emoktanar
Registered User
 
Join Date: Jun 2003
Posts: 12
Default READ

REMOVE DRI-RENDERING FROM KERNEL,,
READ OTHER POSTS PLEASE.. THIS IS SOLVED.
'INFERNATORS POST'
Emoktanar is offline   Reply With Quote
Old 06-16-03, 09:36 AM   #6
preacher
Registered User
 
Join Date: Jun 2003
Posts: 7
Send a message via ICQ to preacher
Thumbs up

Boy do I feel silly now

I'll try this as soon as I get home, but it sounds that this may indeed be the error.

I tried searching (A LOT ) but didn't find anything about disabling DRI. Probably something so trivial that everyone is supposed to know about it.

Again, thanks!
preacher is offline   Reply With Quote
Old 06-16-03, 09:41 AM   #7
Emoktanar
Registered User
 
Join Date: Jun 2003
Posts: 12
Default sound byte

Also if you have an nforce motherboard nvidia just released a new driver set for nforce motherboards that finally allows to use agpgart which has been way better performance for me ..
Emoktanar is offline   Reply With Quote
Old 06-16-03, 01:18 PM   #8
preacher
Registered User
 
Join Date: Jun 2003
Posts: 7
Send a message via ICQ to preacher
Angry

Sorry, but it still won't work

I disabled DRI in my kernel but the same problem remains. I tried running X as root too so I know it's not a permissions issue.

Please, does anyone have any ideas?

Emoktanar: Sorry no, don't have an nforce mb.
preacher is offline   Reply With Quote

Old 06-16-03, 02:59 PM   #9
Emoktanar
Registered User
 
Join Date: Jun 2003
Posts: 12
Default last suggestion

Try removing agpgart from the kernel along with dri-rendering,
and put
Option "NvAGP" "4"
in device section under graphics,, and double check xf86config file.

check BIOS; and update if needed.
Emoktanar is offline   Reply With Quote
Old 06-17-03, 11:34 AM   #10
preacher
Registered User
 
Join Date: Jun 2003
Posts: 7
Send a message via ICQ to preacher
Default

Nope, it still won't work.

I removed agp gart all together from kernel, and DRI was already gone.

Reran the installer and the same error occurs, regardless if i set Option "NvAGP" to "4" or "0".

This is really starting to bug me now...
preacher is offline   Reply With Quote
Old 06-18-03, 01:38 PM   #11
preacher
Registered User
 
Join Date: Jun 2003
Posts: 7
Send a message via ICQ to preacher
Default

Now it works!

I lowered my resolution from 1600x1200 to 1280x1024 and no longer get the garbled screen. Strange, I thought I tried doing that but apparently not.

However, the question remains why the nv-driver can display in 1600x1200 and the nvidia-driver can not. Any ideas?
preacher is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
blinking nvidia logo... mit NVIDIA Linux 7 09-30-02 05:05 PM

All times are GMT -5. The time now is 07:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.