Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-15-03, 12:41 PM   #1
dem123
Registered User
 
Join Date: Jun 2003
Posts: 1
Unhappy Cannot initialize TV-Out

Hello everybody,

here's yet another TV-Out problem, my system specs:
Debian Sid (2.4.20 SMP kernel) running on a Dual Athlon 1800 (1 GB RAM) with Hercules Geforce 3 Ti 500.
XFree version is 4.2.1, Nvidia drivers are 3123 (newer drivers won't run with the SMP kernel).

X starts up properly, but when I try to start another X-Server to switch to TV-Out mode, X crashes completely (black screen on both, monitor an TV), only a reset reactivates the PC.

This is the script I'm running as console su in the first xserver:

#!/bin/sh
X -screen TV :1 -ac & sleep 2; DISPLAY=:1 xine $1 -f && kill `ps aux | awk '/X\
-screen/ {print $2}' `

I can get a display on the TV, when I unplug the monitor cable from the graphic card and the TV is the only connected device (I can see Linux booting on the TV, but I cannot start X).

This is my XF86Config:

### BEGIN DEBCONF SECTION
# XF86Config-4 (XFree86 server configuration file) generated by dexconf, the
# Debian X Configuration tool, using values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# If you want your changes to this file preserved by dexconf, only make changes
# before the "### BEGIN DEBCONF SECTION" line above, and/or after the
# "### END DEBCONF SECTION" line below.
#
# To change things within the debconf section, run the command:
# dpkg-reconfigure xserver-xfree86
# as root. Also see "How do I add custom sections to a dexconf-generated
# XF86Config or XF86Config-4 file?" in /usr/share/doc/xfree86-common/FAQ.gz.

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/Type1"
#FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/misc"
#FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "de"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "EmulateButtons" "false"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
Option "NoLogo" "true"
EndSection

Section "Device"
Identifier "TV-Out Video Card"
Driver "nvidia"
Screen 0
Option "NoLogo" "true"
Option "TVOutFormat" "COMPOSITE"
Option "TVStandard" "PAL-B"
Option "ConnectedMonitor" "TV"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-107
VertRefresh 50-85
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Generic TV"
HorizSync 30-50
VertRefresh 60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "TV"
Device "TV-Out Video Card"
Monitor "Generic TV"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "800x600"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
#Screen "TV"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
#InputDevice "Generic Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

### END DEBCONF SECTION

I've attached the log of the second X server. Any help is most dearly appreciated...
Attached Files
File Type: log xfree86.1.log (16.4 KB, 117 views)
dem123 is offline   Reply With Quote
Old 06-17-03, 06:12 PM   #2
gamez
Registered User
 
Join Date: Jun 2003
Posts: 1
Post

Hi,

I encountered exactly the same problems on my Box (Debian/unstable, 2.4.20, Athlon 1800+ singleprocessor, MSI GeForce2 Ti) using driver versions 4349 (the version preferred by the debian nvidia-kernel and nvidia-glx packages in the unstable dist. and also 4363. I made it run again using the tarball of version 4191.

I tried to start the xserver from console using the command 'xinit -e gmplayer -- :1 -screen TV_Screen' where TV_Screen is the identifier of the screen given in XF86Config. In my tests, I used exactly the same XF86Config (attached) for all versions.

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "extmod"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "Device"
Identifier "NVidia GForce2Ti"
Driver "nvidia"
Option "NoLogo"
EndSection

Section "Monitor"
Identifier "Ilyama VisionMasterPro450"
HorizSync 31-115
VertRefresh 50-160
Option "DPMS"
EndSection

Section "Monitor"
Identifier "TV"
HorizSync 30-50
VertRefresh 60
# Option "DPMS"
EndSection

Section "Screen"
Identifier "Custom_Screen"
Device "NVidia GForce2Ti"
Monitor "Ilyama VisionMasterPro450"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "TV_Screen"
Device "NVidia GForce2Ti"
Monitor "TV"
Option "TVStandard" "PAL-B"
#force usage TV-out, even if graphic card does not detect TV
Option "ConnectedMonitor" "TV"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Custom Layout"
Screen "Custom_Screen"
Screen "TV_Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection
gamez is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
failing to initialize NV driver PsyShook NVIDIA Linux 10 09-19-02 12:41 PM
Red Hat 7.3, tarred 2960 download, NVdriver failed to initialize SparceMatrix NVIDIA Linux 7 09-10-02 12:02 AM
Bohooo HELP, new Nforce 1.13 Audio Utilities won INITIALIZE nanyangview CPUs, Motherboards And Memory 1 09-04-02 07:40 PM

All times are GMT -5. The time now is 03:54 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.