Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-26-09, 10:02 AM   #1
hhg42
Registered User
 
Join Date: Mar 2009
Posts: 31
Default must recompile module every restart

Every time I restart my computer I have to recompile the nvidia module to get X running

New install of 64 bit Kubuntu Hardy
8400GS card, PNY brand, 256meg
Asus mb, Athon 64 X2 5000+ processor
8gig memory

Works fine on previous installs, old install on another drive works fine.

If you have seen this one before please tell me about it.
hhg42 is offline   Reply With Quote
Old 06-26-09, 11:29 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: must recompile module every restart

That sounds like a typical problem on Hardy when the Ubuntu driver packages are installed. Make sure you followed the steps in the sticky post about disabling or removing those packages.
AaronP is offline   Reply With Quote
Old 06-26-09, 12:23 PM   #3
hhg42
Registered User
 
Join Date: Mar 2009
Posts: 31
Default Re: must recompile module every restart FIXED

i didn't actually need to recompile the module, reloading it with /etc/init.d/nvidia-kernel reload worked as well. i experimented more.

now its fixed

here's the deal:

i have installed hardy several times and i am getting familiar with what needs to be done and when. i installed the nvidia driver after doing everything else to economize on keystrokes.

after installing the nvidia driver i accepted the default refresh rate (automatic). this works ok with a freshly loaded nvidia module, but not when X is restarted. setting the the refresh rate to a better looking (lower) value was restartable.

the problem of X not restarting with the vertical rate set to automatic (85) remains, but now it does not cause me to hang on restarts
hhg42 is offline   Reply With Quote
Old 06-26-09, 02:44 PM   #4
hhg42
Registered User
 
Join Date: Mar 2009
Posts: 31
Default Re: must recompile module every restart

I apologize Aaron, you are right and i am wrong.

It was exactly as Aaron said. I had gotten so comfortable installing Kubuntu 8.04 that i did not notice that i had forgotten to put DISABLED_MODULES="nv nvidia_new" into
/etc/default/linux-restricted-modules-common

/me hangs head in shame.

and the previous post about running /etc/init.d/nvidia-kernel reload was even more braindeadness

/me turns red
hhg42 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.