Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-29-09, 11:52 AM   #1
EvilGuru
Registered User
 
Join Date: May 2007
Posts: 28
Default Poor Performance with KDE4

Hi all,

I have a GTX275 GPU with the 185.18.14 drivers which drives two 1600x1200 screens in a TwinView configuration

However, when desktop effects are enabled with KWin I am unable to watch any sort of videos or play any games. As soon as I do this (e.g., using MythTV to watch SDTV in a window using OpenGL/XVideo) the FPS (according to kwin) drops from ~59 to 45 which is not enough.

The card should be more than fast enough to handle compositing and I was expecting it to be able to handle large OpenGL contexts etc without a drop in performance.

Breaking out the big guns, glxgears I am lucky to get (according to kwin) 30 FPS. Although the FPS readout in glxgears claims it to be in the mid 50s.

Is it the nvidia drivers or kwin that is awry?

Regards, Freddie.
EvilGuru is offline   Reply With Quote
Old 06-29-09, 07:37 PM   #2
thefirstm
Registered User
 
Join Date: Feb 2009
Posts: 226
Default Re: Poor Performance with KDE4

When you are running GLXGears, is that under Kwin or not? I have experienced some performance issues with Kwin compositing (that being why I don't use it). Most notably, firing up a 3D application, like GLXGears, drops the whole system to 30fps.
thefirstm is offline   Reply With Quote
Old 06-30-09, 04:28 AM   #3
EvilGuru
Registered User
 
Join Date: May 2007
Posts: 28
Default Re: Poor Performance with KDE4

Quote:
Originally Posted by thefirstm View Post
When you are running GLXGears, is that under Kwin or not? I have experienced some performance issues with Kwin compositing (that being why I don't use it). Most notably, firing up a 3D application, like GLXGears, drops the whole system to 30fps.
Yep, the bad glxgears FPS is with kwin. With Mythtv I can get ~45 (it also uses GL/XVideo).

I was talking to some people on #kde and they claim that the issue is to do with the nvidia drivers — although had no idea where.

Regards, Freddie.

Edit: https://wiki.ubuntu.com/X/Troublesho...as%20low%20FPS See 4) here. Interestingly I tried compiz and found it to always give me 30 FPS w/vsync even though I set the refresh rate at 60 FPS. Could this be a driver issue, as wo/vsync I could get 60 FPS flat.
EvilGuru is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:42 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.