Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Thread Tools
Old 01-13-09, 10:42 AM   #1
Registered User
Join Date: Mar 2005
Posts: 81
Default amd64 - 4GB RAM - what Iommu setting should I use?


athlon X2 4600
motherboard : gigabyte GA-M55S-S3
2 X 2GB ram
nvidia 8500 PCI-E
Distro - ubuntu/opensuse amd64

I have recently upgraded my desktop from 1GB ram to 4GB.

Previous i was getting Aperture beyond 4GB messages, I now get

In dmesg it shows:-

Checking aperture...
No AGP bridge found
Node 0: aperture @ 20000000 size 32 MB
Aperture pointing to e820 RAM. Ignoring.
Your BIOS doesn't leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM
Mapping aperture over 65536 KB of RAM @ 20000000
PCI: MCFG area at f0000000 reserved in E820
The memory used is not available - i.e i lose 64 MB.

I do not get this in 32bit linux using PAE - i can see all my memory.

After reading around forums I tried iommu=memaper=3 - I noticed that Aperture was set to 256MB with this option - and I lost the 256MB..

What should I set my aperture to ? My gfx card is geforce 8500 256mb PCI-E

Any sugestions ?
interzoneuk is offline   Reply With Quote
Old 01-26-09, 12:03 AM   #2
Registered User
Dizzle7677's Avatar
Join Date: May 2008
Location: Relativity
Posts: 194
Default Re: amd64 - 4GB RAM - what Iommu setting should I use?

I believe it's one of those things that can safely be ignored. You don't have an AGP bus.
Elephants can fly but they have no reason to.
Phenom II X3 720 @ 3.5Ghz | Asus M4A785-M | 2 Gig Crucial DDR2 @ 960 Mhz | GeForce GT 440 1024 MB | Linux 3.6.1 / Ubuntu 12.04 / W.I.N.E v1.5.14
Dizzle7677 is offline   Reply With Quote
Old 01-27-09, 02:52 PM   #3
Registered User
Join Date: Jul 2006
Location: Wejherowo, Poland
Posts: 2
Default Re: amd64 - 4GB RAM - what Iommu setting should I use?

Try with iommu=force
arachnist is offline   Reply With Quote
Old 03-10-09, 06:54 AM   #4
Registered User
Join Date: Jan 2005
Posts: 135
Default Re: amd64 - 4GB RAM - what Iommu setting should I use?

It's not a kernel option. They mean enable the IOMMU option in the system(GBT) BIOS and the enabling will use 64MB.
Chances are high with GBT that there is no such option.
So you just have to ignore the message. There is no way to get 4096MB available. It does not matter cuz if you actually need 4096MB then having 4GB is not enough anyway.

As contrast, MS Win systems can report 4096 but MS Win* reserves almost a GB for itself and you get the rest. Linux will use 64MB; ... if the IOMMU is not used, somewhat more.
I have 3968 out of 4096; 128MB used. I did some calculations a few years back and the number was correct. IIRC, I 'found' where all but about 2 or 4MB were used. ...that was close enuf for me. I have a GBT 2cewh and it does not have the IOMMU option in the Phoenix BIOS. (GBT and Phoenix suk...). Tomorrow, ihope, I'll have the SuperMicro running and it does have the IOMMU option. 64MB ...woo, woo.

The technical explanation is lengthy and a little difficult but it boils down to, as simply as I can, some memory is needed for OS to manage all those devices that are on the mainboard.

IF it is possible, and you do NOT have AGP, set the IOMMU GART for 64MB. That is what Linux needs ...
Then, out of the 4096 there will be 4033MB available and at boot you will get messages something like:

kernel: DMAR: parse DMAR table failure.
kernel: PCI-DMA: Disabling AGP.
kernel: PCI-DMA: aperture base @ b4000000 size 65536 KB
kernel: init_memory_mapping
kernel: last_map_addr: b8000000 end: b8000000
kernel: PCI-DMA: using GART IOMMU.
kernel: PCI-DMA: Reserving 64MB of IOMMU area in the AGP aperture
(use something like " less /var/log/messages |grep DMAR -A 6 " to retreive, depending on distro)

free will report similar to:
#> free -m
total used free shared buffers cached
4033 814 3218 0 3 379

Of course your used, free, shared, buffers & cached will probably differ.
I was able to do the above because I dumped the Gigabyte board and ** Phoenix BIOS for a Supermicro and AMI BIOS & OH, what a difference it has made!( GBT s u k s... )
When two people meet and exchange gifts, each has one object.
When two people meet and exchange ideas, each has two ideas.
... Open Source. Just do it.

System: BFG GTX260^2 graphics but has ** TERRIBLE BLINKING OS **
SuperMicro H8DCi+AMI BIOS;dual Opt'285;8GB;LSI 320-2x w/ 6xU320 Fuji' MAXs in RAID 10; 4xSATAII on LSI 3041E for backup. Multi-boot Mandriva Linux, openSUSE, WinXPx64 & Win2k-AS; Creative Audigy2-Digital audio.
Gigabyte GA-2CEWH & NVRAID are GONE ... Finally!!

Last edited by fhj52; 03-21-09 at 01:43 AM. Reason: +info
fhj52 is offline   Reply With Quote
Old 08-03-09, 05:18 AM   #5
Registered User
Join Date: Aug 2009
Posts: 1
Thumbs down Re: amd64 - 4GB RAM - what Iommu setting should I use?

Hey everybody

I have a kind of the same problem...
I can't get into my ubuntu anymore. when I try it gives me this message:

Booting 'ubuntu 9.04, kemel 2.6.27-14-genetic
Filesystem type is ntfs, partiticin type 0x07
The current working directory (i.e., the relative path) is ubuntu disks
(Linux - bz image,setup = 0x3000, size 0x238 fe0)
Linux- inirrel @ 0x7f767000, 0x888a70 bytes)
0.004000) Aparture beyond 4 fib. ignoring.
(0.004000) Your Bios doesn't leave a aperture memory hole
(0.004000) Please enable the iommu option in the Bios setups
(0.004000) This costs you 64 mb of ram
Loading, please wait...
Alert!/host/ubuntu/disks/root.disk does not exist. Propping to a shell

Busybox v1.10.2 (ubuntu 1:1.10.2-2 ubuntu 7) built in a shell (ash)
Enter 'help' for a list of built commands.


The problem is that I don't have the iommu option in my Bios!
Does any of you have an idea for what I can do?
sehested is offline   Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -5. The time now is 01:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.