Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-29-09, 10:00 PM   #1
Tonacatecuhtli
Registered User
 
Join Date: Dec 2007
Posts: 15
Default 190.25 intermittent freezes

EDIT:
This issue seems to be caused by the UseEvents option in xorg.conf. Disabling it seems to fix the problem.

EDIT:
This post refers to 190.18, the problem persists with 190.25 and 190.32. More information on that later in the thread.



Since I've switched to 190.18 I've been getting occasional freezes where the screen does not update and I cannot interact with the X server. These quick (usually about 5 second, sometimes up to 15) freezes don't seem to have much of a pattern but once the

NVRM: Xid (0003:00): 65, CMDre 00000000 00000808 012c0000 00000004 00000084
NVRM: Xid (0004:00): 65, CMDre 00000000 00000808 010012c0 00000004 00000084

messages appear in dmesg they will occur on average about once every 40ish seconds. Though, sometimes up to 5 minutes will pass with everything working fine, sometimes there're nigh consecutive freezes.

I'm relatively sure these are caused by the nvidia drive due to the dmesg messages and since SSH sessions work fine during the freezes.

I've attached a nvidia-bug-report.log.gz and would appreciate any tips on workarounds or whatnot. It's probably worth noting, although the information is also in the script's bug log, that I have two cards running in SLi and use a composited desktop.
Attached Files
File Type: gz nvidia-bug-report.log.gz (27.7 KB, 132 views)

Last edited by Tonacatecuhtli; 09-09-09 at 02:29 PM. Reason: UseEvents info
Tonacatecuhtli is offline   Reply With Quote
Old 07-29-09, 10:46 PM   #2
kvaster
Registered User
 
Join Date: Oct 2008
Posts: 44
Default Re: 190.18 intermittent freezes

The same effect I can see on Quadro NVS140M on my Thinkpad R61
kvaster is offline   Reply With Quote
Old 07-30-09, 02:27 PM   #3
mdoerner
Registered User
 
mdoerner's Avatar
 
Join Date: Sep 2008
Posts: 62
Default Re: 190.18 intermittent freezes

Same here. Are you running a CUDA application as well?

Mike Doerner
mdoerner is offline   Reply With Quote
Old 07-30-09, 04:57 PM   #4
kvaster
Registered User
 
Join Date: Oct 2008
Posts: 44
Default Re: 190.18 intermittent freezes

I'm running simple X server.
kvaster is offline   Reply With Quote
Old 07-31-09, 02:57 AM   #5
Tonacatecuhtli
Registered User
 
Join Date: Dec 2007
Posts: 15
Default Re: 190.18 intermittent freezes

I've also had the issue occur both with and without a CUDA app running.

Have you other people who are getting the same issue noticed any particular similarities between our set ups, or messages in the logs?
Tonacatecuhtli is offline   Reply With Quote
Old 07-31-09, 06:37 AM   #6
mdoerner
Registered User
 
mdoerner's Avatar
 
Join Date: Sep 2008
Posts: 62
Default Re: 190.18 intermittent freezes

This is still a problem in the 185.18.31 release, but to a lesser degree. The 190.18 release has more of these screen freeze problems.

Mike Doerner

PS I'm running SUSE 11.2 Milestone 4 and running GPUGrid in the background for CUDA, presently 185.18.31, which seems the most stable at present.
mdoerner is offline   Reply With Quote
Old 07-31-09, 09:59 AM   #7
sittingpenguin
Registered User
 
sittingpenguin's Avatar
 
Join Date: May 2008
Location: Julia Augusta Taurinorum
Posts: 42
Default Re: 190.18 intermittent freezes

This 185.18.31 is kinda mysterious... It is not listed if you access the driver page directly or among the official releases in the sticky of this forum; but if you enter its address in the adress bar of your browser, modifying that of .29, it shows up, with the same release highlights of 185.18.29. WTH!?
sittingpenguin is offline   Reply With Quote
Old 08-01-09, 03:50 AM   #8
Wayne A. Ptaff
Registered User
 
Join Date: Aug 2009
Posts: 3
Default Re: 190.18 intermittent freezes

Same problem with nvidia-driver-190.18, on x86, with xorg-server-1.5.3. Didn't have that multisecond latency problem with 180.60.

LatencyTop reports 4 secs of "Schduler: waiting for cpu" when that happens, and that delay isn't attributed to one particular app; might be Amarok or mplayer or even filesystem kernel threads (so problem doesn't appear to be in user-space).

Switching back and forth between fullscreen and windowed mode on a playing movie seems to trigger the problem most of the times, but not always; if not, problem occurs on an irregular basis.
Wayne A. Ptaff is offline   Reply With Quote

Old 08-06-09, 10:53 AM   #9
sambo57u
Registered User
 
Join Date: Jan 2006
Posts: 52
Default Re: 190.18 intermittent freezes

Also having these annoying freezes with 190.18 on Lenovo T61 (NVS140M).
sambo57u is offline   Reply With Quote
Old 08-07-09, 02:55 AM   #10
kshade
Registered User
 
Join Date: Mar 2004
Location: D(49)
Posts: 6
Default Re: 190.18 intermittent freezes

Quote:
Originally Posted by Wayne A. Ptaff View Post
LatencyTop reports 4 secs of "Schduler: waiting for cpu" when that happens, and that delay isn't attributed to one particular app; might be Amarok or mplayer or even filesystem kernel threads (so problem doesn't appear to be in user-space).
Same problem here. It only happens when the GPU needs to do some work, be it glxgears, compiz or ut2004.
kshade is offline   Reply With Quote
Old 08-08-09, 06:11 PM   #11
sambo57u
Registered User
 
Join Date: Jan 2006
Posts: 52
Default Re: 190.18 intermittent freezes

Is this limited to mobile GPU's? I have two identically configured
systems, a laptop with NVS140m, and a desktop with NVS295.
Desktop does not have any freezing issue but the laptop does.
Could it me powermizer related. It ic very annoying to say the
least.

However, before rushing to judgement I would like to know what
kernel/wireless driver people having this problem are using.
sambo57u is offline   Reply With Quote
Old 08-09-09, 09:28 AM   #12
Wayne A. Ptaff
Registered User
 
Join Date: Aug 2009
Posts: 3
Default Re: 190.18 intermittent freezes

Card which has the problem here is:

VGA compatible controller: nVidia Corporation GeForce 8600GT (rev a1) (prog-if 00 [VGA controller])
Subsystem: Micro-Star International Co., Ltd. Device 0882
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0
Interrupt: pin A routed to IRQ 16
Region 0: Memory at d4000000 (32-bit, non-prefetchable) [size=16M]
Region 1: Memory at b0000000 (64-bit, prefetchable) [size=256M]
Region 3: Memory at d2000000 (64-bit, non-prefetchable) [size=32M]
Region 5: I/O ports at 8c00 [size=128]
[virtual] Expansion ROM at d5be0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: nvidia
Kernel modules: nvidia
Wayne A. Ptaff is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.