Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-30-09, 11:45 AM   #1
Sog
Registered User
 
Join Date: Jan 2009
Posts: 3
Default 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

Hi,

I have some random Xorg segfaults with the 185.18.14 and 185.18.29 drivers. It happens once or twice a day, I was always using heavy apps like eclipse or firefox.
180.60 and previous versions are fine.

From Xorg.0.log:
Code:
GetModeLine - scrn: 0 clock: 68900
GetModeLine - hdsp: 1280 hbeg: 1301 hend: 1333 httl: 1408
              vdsp: 800 vbeg: 804 vend: 808 vttl: 816 flags: 10
GetModeLine - scrn: 0 clock: 68900
GetModeLine - hdsp: 1280 hbeg: 1301 hend: 1333 httl: 1408
              vdsp: 800 vbeg: 804 vend: 808 vttl: 816 flags: 10

Backtrace:
0: X(xorg_backtrace+0x28) [0x4c4a44]
1: X(xf86SigHandler+0x65) [0x4756f9]
2: /lib/libc.so.6 [0x3c1d032290]
3: /usr/lib64/xorg/modules/drivers//nvidia_drv.so(_nv001642X+0x26) [0x7fc0efed5636]
4: /usr/lib64/xorg/modules/drivers//nvidia_drv.so(_nv001411X+0x64) [0x7fc0efee9c04]
5: /usr/lib64/xorg/modules/drivers//nvidia_drv.so [0x7fc0f0103a44]
6: /usr/lib64/xorg/modules/drivers//nvidia_drv.so [0x7fc0f011cec8]
7: /usr/lib64/xorg/modules/drivers//nvidia_drv.so [0x7fc0f0120e30]
8: X(ProcCreatePixmap+0x103) [0x4410c1]
9: X(PanoramiXCreatePixmap+0xe6) [0x4de24a]
10: X(Dispatch+0x2d5) [0x444cbe]
11: X(main+0x50c) [0x4307f0]
12: /lib/libc.so.6(__libc_start_main+0xe6) [0x3c1d01e5c6]
13: X [0x42fc19]

Fatal server error:
Caught signal 11.  Server aborting
More infos:
Gentoo x86_64, 2.6.29
GeForce Go 7600
NVIDIA 185.18.29 installed from the Gentoo package.
It's a xinerama setup with 2 screens.
Using xorg-server 1.5.3
KDE 3.5
Thanks
Attached Files
File Type: gz nvidia-bug-report.log.gz (38.6 KB, 133 views)
Sog is offline   Reply With Quote
Old 07-31-09, 04:03 AM   #2
vkrevs
Registered User
 
Join Date: May 2005
Posts: 7
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

Same here on openSUSE 11.1 for X86_64 and driver installed from NVIDIA-Linux-x86_64-185.18.29-pkg2.run (X.Org X Server 1.5.2, GeForce 7600 GS, KDE 4.2.4). X crashes 2-3 times a day. Typically Firefox 3.5.1 with about 12 tabs is open at the time of the crash.

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x65) [0x489be5]
1: /lib64/libc.so.6 [0x7ff28feea6e0]
2: /usr/lib64/xorg/modules//drivers/nvidia_drv.so(_nv001642X+0x26) [0x7ff28cd79636]
3: /usr/lib64/xorg/modules//drivers/nvidia_drv.so(_nv001411X+0x64) [0x7ff28cd8dc04]
4: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff28cfa7a44]
5: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff28cfc0ec8]
6: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff28cfc4e30]
7: /usr/bin/Xorg(ProcCreatePixmap+0x15a) [0x447cfa]
8: /usr/bin/Xorg(Dispatch+0x364) [0x44c4d4]
9: /usr/bin/Xorg(main+0x45d) [0x43269d]
10: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7ff28fed6586]
11: /usr/bin/Xorg [0x431a79]

Fatal server error:
Caught signal 11. Server aborting
Attached Files
File Type: gz nvidia-bug-report.log.gz (29.7 KB, 81 views)
vkrevs is offline   Reply With Quote
Old 08-03-09, 05:43 AM   #3
vkrevs
Registered User
 
Join Date: May 2005
Posts: 7
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

And the latest beta version - NVIDIA-Linux-x86_64-185.19-pkg2.run - also crashes when opening a new tab in Firefox.

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x65) [0x489be5]
1: /lib64/libc.so.6 [0x7ff4ed3a76e0]
2: /usr/lib64/xorg/modules//drivers/nvidia_drv.so(_nv001642X+0x26) [0x7ff4ea236676]
3: /usr/lib64/xorg/modules//drivers/nvidia_drv.so(_nv001411X+0x64) [0x7ff4ea24ac24]
4: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff4ea464ad4]
5: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff4ea47df98]
6: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff4ea48237a]
7: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff4ea482ba4]
8: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff4ea483649]
9: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff4ea43f258]
10: /usr/bin/Xorg [0x523da9]
11: /usr/bin/Xorg [0x4fbcb1]
12: /usr/bin/Xorg(BlockHandler+0x50) [0x44ff10]
13: /usr/bin/Xorg(WaitForSomething+0x152) [0x4e9682]
14: /usr/bin/Xorg(Dispatch+0x7f) [0x44c1ef]
15: /usr/bin/Xorg(main+0x45d) [0x43269d]
16: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7ff4ed393586]
17: /usr/bin/Xorg [0x431a79]

Fatal server error:
Caught signal 11. Server aborting
vkrevs is offline   Reply With Quote
Old 08-15-09, 04:36 AM   #4
ataraxis
Registered User
 
Join Date: Mar 2008
Posts: 7
Angry Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

Any news on this?
I am affected as well.
OpenSuse 64bit with 185.18.14 (no crash log available)
and
Arch 64bit with 190.18 beta drivers

Quote:
Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4ee436]
1: /usr/bin/X(xf86SigHandler+0x6f) [0x47b3df]
2: /lib/libc.so.6 [0x7f8c51697f90]
3: /usr/lib/xorg/modules/drivers//nvidia_drv.so(_nv001710X+0x26) [0x7f8c4e485126]
4: /usr/lib/xorg/modules/drivers//nvidia_drv.so(_nv001462X+0x64) [0x7f8c4e49f334]
5: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f8c4e4c2528]
6: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f8c4e6fe7fd]
7: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f8c4e701949]
8: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f8c4e701f62]
9: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f8c4e70251f]
10: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f8c4e6d12c8]
11: /usr/bin/X [0x533145]
12: /usr/bin/X [0x4fdc26]
13: /usr/bin/X(BlockHandler+0x50) [0x451610]
14: /usr/bin/X(WaitForSomething+0x141) [0x4ec011]
15: /usr/bin/X(Dispatch+0x92) [0x44d372]
16: /usr/bin/X(main+0x3b5) [0x433a55]
17: /lib/libc.so.6(__libc_start_main+0xfd) [0x7f8c516849ed]
18: /usr/bin/X [0x432ed9]

Fatal server error:
Caught signal 11. Server aborting


Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
Attached Files
File Type: gz nvidia-bug-report.log.gz (37.5 KB, 83 views)

Last edited by ataraxis; 08-15-09 at 04:38 AM. Reason: added nvidia-bug-report.log.gz
ataraxis is offline   Reply With Quote
Old 08-15-09, 01:47 PM   #5
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

That's very odd. Does the problem reproduce if you run "nvidia-settings -a PixmapCache=0"? Also, it would be very helpful if someone could come up with some more reliable reproduction steps.
AaronP is offline   Reply With Quote
Old 08-16-09, 06:46 AM   #6
ataraxis
Registered User
 
Join Date: Mar 2008
Posts: 7
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

Hi Aaron,

thanks for your help, I appreciate it.
I have not found a way to reproduce it. It happens mostly when clicking somewhere (switching to a different window most oftenly).
This time it happened when i wanted to switch to my mplayer window, so far it happened to my when switching to eclipse, firefox, oo writer and skype (but those are the apps i use most often anyway).

I disabled the Pixmap Cache via nvidia-settings as you described and it still happened (nvidia 190.18, xorg-server 1.6.3, nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1), KDE 4.3) :
Quote:
Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4ee496]
1: /usr/bin/X(xf86SigHandler+0x6f) [0x47b43f]
2: /lib/libc.so.6 [0x7f90d5f7af90]
3: /usr/lib/xorg/modules/drivers//nvidia_drv.so(_nv001710X+0x26) [0x7f90d2d68126]
4: /usr/lib/xorg/modules/drivers//nvidia_drv.so(_nv001462X+0x64) [0x7f90d2d82334]
5: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f90d2da5528]
6: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f90d2fe17fd]
7: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f90d2fe4949]
8: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f90d2fe4f62]
9: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f90d2fe551f]
10: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f90d2fb42c8]
11: /usr/bin/X [0x5331b5]
12: /usr/bin/X [0x4fdc86]
13: /usr/bin/X(BlockHandler+0x50) [0x451610]
14: /usr/bin/X(WaitForSomething+0x141) [0x4ec071]
15: /usr/bin/X(Dispatch+0x92) [0x44d372]
16: /usr/bin/X(main+0x3b5) [0x433a55]
17: /lib/libc.so.6(__libc_start_main+0xfd) [0x7f90d5f679ed]
18: /usr/bin/X [0x432ed9]

Fatal server error:
Caught signal 11. Server aborting
I have used the 180.60 driver yesterday and no crash happened.
Please tell me if you need me to provide any additional information.

Best Regards,
Ataraxis
Attached Files
File Type: gz nvidia-bug-report.log.gz (38.6 KB, 86 views)
ataraxis is offline   Reply With Quote
Old 08-19-09, 03:11 AM   #7
vylu
Registered User
 
Join Date: Aug 2009
Posts: 5
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

Hello,

I'm not sure if it is the same problem, but I also have random X crashes when using X.org 1.6.3 with both 185.18.14 and 190.18 versions (no crashes with X.org 1.4.2). My system is 64bit debian testing/unstable with nvidia quadro nvs140m. I'm using kde4.3.

Here is info from Xorg.log

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4edff6]
1: /usr/bin/X(xf86SigHandler+0x39) [0x4834f9]
2: /lib/libc.so.6 [0x314f631db0]
3: /usr/lib/xorg/modules/drivers//nvidia_drv.so(_nv001516X+0x2) [0x7f9b708502d2]
4: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f9b708533ab]
5: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f9b70a871e3]
6: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f9b70a88b13]
7: /usr/bin/X [0x5343f1]
8: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f9b70a766cb]
9: /usr/bin/X [0x52e535]
10: /usr/bin/X(Dispatch+0x364) [0x44d344]
11: /usr/bin/X(main+0x3aa) [0x43329a]
12: /lib/libc.so.6(__libc_start_main+0xe6) [0x314f61e5c6]
13: /usr/bin/X [0x432739]

Fatal server error:
Caught signal 11. Server aborting

Unfortunately, still haven't found how to reproduce this crash.
Attached Files
File Type: gz nvidia-bug-report.log.gz (43.9 KB, 81 views)

Last edited by vylu; 08-19-09 at 03:13 AM. Reason: added info about kde version..
vylu is offline   Reply With Quote
Old 08-21-09, 08:19 AM   #8
vkrevs
Registered User
 
Join Date: May 2005
Posts: 7
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

This seems to happen when a new tab is opened in Firefox, usually by clicking on a link in an already open tab. I run KDE 4.3.x, and the crash occurs within an hour of starting KDE, launching Firefox, and opening 10 tabs in it.
vkrevs is offline   Reply With Quote

Old 08-29-09, 07:14 AM   #9
ataraxis
Registered User
 
Join Date: Mar 2008
Posts: 7
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

also crashes with 190.25
ataraxis is offline   Reply With Quote
Old 08-29-09, 08:39 AM   #10
goofy03
Registered User
 
Join Date: May 2005
Posts: 3
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

185.18.36
7600 Go
Sidux

If i open too many windows under KDE*4.3 with effect on I get black window bug (again). If someone have solution too ?
goofy03 is offline   Reply With Quote
Old 08-29-09, 08:49 AM   #11
ataraxis
Registered User
 
Join Date: Mar 2008
Posts: 7
Question Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

Quote:
Originally Posted by goofy03 View Post
185.18.36
7600 Go
Sidux

If i open too many windows under KDE*4.3 with effect on I get black window bug (again). If someone have solution too ?
How is this related to this thread?
ataraxis is offline   Reply With Quote
Old 08-29-09, 12:26 PM   #12
Sog
Registered User
 
Join Date: Jan 2009
Posts: 3
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

Quote:
Originally Posted by AaronP View Post
That's very odd. Does the problem reproduce if you run "nvidia-settings -a PixmapCache=0"? Also, it would be very helpful if someone could come up with some more reliable reproduction steps.
Hi,

Indeed, I disabled the pixmap cache two weeks ago and I couldn't reproduce the problem (with 185.18.31 which is also affected).

By the way, for the others who are also trying with PixmapCache=0, this settings seems to be reset after a suspend to disk/ram.
Sog is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:19 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.