Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-30-09, 02:12 PM   #13
birefringence
Registered User
 
Join Date: Jan 2009
Posts: 7
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

I also see this problem (totally randomly, usually when switching windows) on openSUSE 11.1 with KDE 4.3

Code:
Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x65) [0x489be5]
1: /lib64/libc.so.6 [0x7ff96cd226e0]
2: /usr/lib64/xorg/modules//drivers/nvidia_drv.so(_nv001753X+0x26) [0x7ff969a207f6]
3: /usr/lib64/xorg/modules//drivers/nvidia_drv.so(_nv001499X+0x64) [0x7ff969a3ea54]
4: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff969a61f38]
5: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff969c40a88]
6: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff969c44e5e]
7: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff969c4563e]
8: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff969c460f9]
9: /usr/lib64/xorg/modules//drivers/nvidia_drv.so [0x7ff969c0daf8]
10: /usr/bin/Xorg [0x523da9]
11: /usr/bin/Xorg [0x4fbcb1]
12: /usr/bin/Xorg(BlockHandler+0x50) [0x44ff10]
13: /usr/bin/Xorg(WaitForSomething+0x152) [0x4e9682]
14: /usr/bin/Xorg(Dispatch+0x7f) [0x44c1ef]
15: /usr/bin/Xorg(main+0x45d) [0x43269d]
16: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7ff96cd0e586]
17: /usr/bin/Xorg [0x431a79]

Fatal server error:
Caught signal 11.  Server aborting
I will now also try to set the PixmapCache=0 ...
Attached Files
File Type: gz nvidia-bug-report.log.gz (40.7 KB, 75 views)
birefringence is offline   Reply With Quote
Old 09-11-09, 12:12 PM   #14
birefringence
Registered User
 
Join Date: Jan 2009
Posts: 7
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

I can confirm, that the crashes are gone with PixmapCache=0.

Will this be fixed in a future version of the driver, so that it will be possible to enable the pixmap cache again?
birefringence is offline   Reply With Quote
Old 09-12-09, 03:41 AM   #15
elmargol
Registered User
 
Join Date: Oct 2008
Posts: 8
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

Same problem here
elmargol is offline   Reply With Quote
Old 09-15-09, 09:02 AM   #16
vylu
Registered User
 
Join Date: Aug 2009
Posts: 5
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

on my system setting PixmapCache=0 makes no affect. X server still crashes randomly.
vylu is offline   Reply With Quote
Old 09-15-09, 09:07 AM   #17
elmargol
Registered User
 
Join Date: Oct 2008
Posts: 8
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

PixmapCache=0 does not help here
elmargol is offline   Reply With Quote
Old 10-17-09, 05:16 PM   #18
vylu
Registered User
 
Join Date: Aug 2009
Posts: 5
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

Still crashes with 190.40:

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4ee026]
1: /usr/bin/X(xf86SigHandler+0x39) [0x4836c9]
2: /lib/libc.so.6 [0x3f1f231db0]
3: /usr/lib/xorg/modules/drivers//nvidia_drv.so(_nv001562X+0x2) [0x7f058c28a612]
4: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f058c28d96b]
5: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f058c4c7c73]
6: /usr/lib/xorg/modules/drivers//nvidia_drv.so [0x7f058c4c975e]
7: /usr/bin/X [0x5345d1]
8: /usr/bin/X [0x52e715]
9: /usr/bin/X(Dispatch+0x374) [0x44d454]
10: /usr/bin/X(main+0x3aa) [0x43337a]
11: /lib/libc.so.6(__libc_start_main+0xe6) [0x3f1f21e5c6]
12: /usr/bin/X [0x432819]
vylu is offline   Reply With Quote
Old 10-18-09, 01:02 AM   #19
elmargol
Registered User
 
Join Date: Oct 2008
Posts: 8
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

switched back to 173.14.20 no crashes for 2 weeks now
elmargol is offline   Reply With Quote
Old 10-27-09, 05:32 PM   #20
Sog
Registered User
 
Join Date: Jan 2009
Posts: 3
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

The crash I reported in the first post is fixed since 190.40 (random segfault with PixmapCache=1), and this release looks great so far !

Most of the other backtraces in this thread are different. Probably another bug ?
Sog is offline   Reply With Quote

Old 10-29-09, 03:12 AM   #21
ataraxis
Registered User
 
Join Date: Mar 2008
Posts: 7
Default Re: 185.18.29 - X server 1.5.3 segfault - GeForce Go 7600

I can confirm, the pixmap related crash is fixed here as well.
Finally a usable driver again, I'm happy.
ataraxis is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:06 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.