Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-31-09, 10:21 PM   #1
jmbox
Registered User
 
Join Date: Jul 2009
Posts: 9
Default vdpau hw too slow?

I have been trying to work out what I need to do to get my server to play HD movies smoothly.

latest svn mplayer with -vo vdpau -vc ffh264 seems to give me the best picture, but there are still occasional pauses. Using -vc ffh264vdpau just makes it slower and more choppy.

./mplayer -zoom -autosync 30 -demuxer lavf -aid 3 -ao alsa -ac ffac3,a52, -vo vdpau -vc ffh264 -framedrop -fs -noautosub -lavdopts threads=2:fast:skiploopfilter=all -sws 0 B.evo

Do I need to upgrade my hardware or will software tweaks be sufficient? Please help!

Here's the qvdpautest output:
AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
19:03 NVIDIA(0): NVIDIA GPU GeForce 8200 (C77) at PCI:2:0:0 (GPU-0)

VDPAU API version : 0
VDPAU implementation : NVIDIA VDPAU Driver Shared Library 190.18 Wed Jul 22 16:37:05 PDT 2009

SURFACE GET BITS: 595.734 M/s
SURFACE PUT BITS: 857.377 M/s

MPEG DECODING (1920x1080): 44 frames/s
MPEG DECODING (1280x720): 104 frames/s
H264 DECODING (1920x1080): 33 frames/s
H264 DECODING (1280x720): 54 frames/s
VC1 DECODING (1440x1080): 44 frames/s

MIXER WEAVE (1920x1080): 228 frames/s
MIXER BOB (1920x1080): 332 fields/s
MIXER TEMPORAL (1920x1080): 64 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 89 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 21 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 23 fields/s

MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 84 fields/s
Attached Files
File Type: log Xorg.0.log (15.7 KB, 94 views)
File Type: txt xorg.conf.txt (3.3 KB, 146 views)
File Type: gz nvidia-bug-report.log.gz (40.8 KB, 101 views)
File Type: gz ffh264.log.gz (10.5 KB, 92 views)
File Type: gz ffh264vdpau.log.gz (35.4 KB, 99 views)

Last edited by jmbox; 08-20-09 at 06:37 PM.
jmbox is offline   Reply With Quote
Old 07-31-09, 10:54 PM   #2
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: vdpau hw too slow?

Can you please run nvidia-settings and look at the PowerMizer page when playing back video. Do you have multiple PowerMizer levels? Does the GPU go into a higher/highest PowerMizer level when playing video? Thanks.
Stephen Warren is offline   Reply With Quote
Old 07-31-09, 10:58 PM   #3
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: vdpau hw too slow?

A couple more things: I see you have lots of options in xorg.conf. It's plausible some of them are causing issues. Can you try the following simplified Screen section:

Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Viewport    0 0
        Virtual     1280 720
        Depth       24
    EndSubSection
EndSection
Also, what RAM do you have in your system? Since you have integrated graphics, using faster RAM will help. Similarly, using dual-channel instead of single-channel will help.
Stephen Warren is offline   Reply With Quote
Old 07-31-09, 11:34 PM   #4
jmbox
Registered User
 
Join Date: Jul 2009
Posts: 9
Default Re: vdpau hw too slow?

Quote:
Originally Posted by Stephen Warren View Post
A couple more things: I see you have lots of options in xorg.conf. It's plausible some of them are causing issues. Can you try the following simplified Screen section:

Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Viewport    0 0
        Virtual     1280 720
        Depth       24
    EndSubSection
EndSection
Also, what RAM do you have in your system? Since you have integrated graphics, using faster RAM will help. Similarly, using dual-channel instead of single-channel will help.
Using the above gives a slightly better performance, but still choppy, with ffh264vdpau, but ffh264 does not want to play at all.

G.SKILL 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400)

According to nvidia-settings, there only appears to be one performance level (0). However when playing the movie, the mode goes from Desktop to Maximum Performance. The clock speeds stay at 500/800 though.
jmbox is offline   Reply With Quote
Old 07-31-09, 11:42 PM   #5
jmbox
Registered User
 
Join Date: Jul 2009
Posts: 9
Default Re: vdpau hw too slow?

.

Last edited by jmbox; 07-31-09 at 11:43 PM. Reason: dupe
jmbox is offline   Reply With Quote
Old 08-03-09, 02:31 PM   #6
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: vdpau hw too slow?

When using -vc ffh264vdpau, does removing any of the following help: -zoom -autosync 30 -demuxer lavf -framedrop -noautosub -lavdopts threads=2:fast:skiploopfilter=all -sws 0
Stephen Warren is offline   Reply With Quote
Old 08-03-09, 10:28 PM   #7
jmbox
Registered User
 
Join Date: Jul 2009
Posts: 9
Default Re: vdpau hw too slow?

No it doesn't.

Removing autosync/framedrop causes the video to run smooth, but slow and loses sync with the audio. Also causes some audio corruption.

Demuxer is required for the EVO file.

Zoom not required for this particular file

sws/lavdopts shouldn't have an effect on hardware acceleration, and I don't notice any difference.
jmbox is offline   Reply With Quote
Old 08-10-09, 02:37 PM   #8
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: vdpau hw too slow?

I'm very sorry, but I don't really have any ideas about this. In the past, other people have complained that performance on the 8200 IGP was not good (mainly either XBMC or MythTV users I think). Unfortunately, I haven't been able to look into this.
Stephen Warren is offline   Reply With Quote

Old 08-19-09, 04:28 PM   #9
jmbox
Registered User
 
Join Date: Jul 2009
Posts: 9
Default Re: vdpau hw too slow?

Okay, so lets try a new graphics card, GTX 260 (216).. should be fast enough?

Code:
AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
27:06 NVIDIA(0): NVIDIA GPU GeForce GTX 260 (GT200) at PCI:2:0:0 (GPU-0)

VDPAU API version : 0
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  190.18  Wed Jul 22 16:37:05 PDT 2009

SURFACE GET BITS: 736.788 M/s
SURFACE PUT BITS: 1006.13 M/s

MPEG DECODING (1920x1080): 70 frames/s
MPEG DECODING (1280x720): 150 frames/s
H264 DECODING (1920x1080): 45 frames/s
H264 DECODING (1280x720): 97 frames/s
VC1 DECODING (1440x1080): 108 frames/s

MIXER WEAVE (1920x1080): 5017 frames/s
MIXER BOB (1920x1080): 7936 fields/s
MIXER TEMPORAL (1920x1080): 1919 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 2558 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 711 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 787 fields/s

MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 2235 fields/s
Better results, but still not there. With -framedrop, I'm dropping frames so it doesn't look smooth. Without it, I get audio problems.

Still received the dreaded:
Code:
           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.
Command line is: mplayer -autosync 30 -demuxer lavf -ao alsa -vo vdpau -vc ffh264vdpau,ffvc1vdpau,ffmpeg12vdpau, -fs
jmbox is offline   Reply With Quote
Old 08-19-09, 06:19 PM   #10
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: vdpau hw too slow?

Your vdpinfo results are similar to other people with somewhat similar HW, for example, see: http://www.nvnews.net/vbulletin/show...&postcount=126

Can you try removing the trailing comma from the -vc option; this will force MPlayer to only use one of the listed codecs, and prevent fallback to SW if those fail.

Otherwise, I'm not sure what the issue is. I think you'll only be able to tell by instrumenting MPlayer to see where it's spending its time.
Stephen Warren is offline   Reply With Quote
Old 08-19-09, 07:46 PM   #11
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: vdpau hw too slow?

Quote:
Originally Posted by jmbox View Post
Okay, so lets try a new graphics card, GTX 260 (216).. should be fast enough?
Note that H264 hardware decoding speed is (nearly) unaffected by the exact type of Geforce 8 or 9 card.
Quote:
Still received the dreaded:
Code:
           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************
Please do not cut MPlayer's output (if you need assistance)!
And if you do, please cut the useless part (such as the paragraph following "Your system is too SLOW").
Quote:
Command line is: mplayer -autosync 30 -demuxer lavf -ao alsa -vo vdpau -vc ffh264vdpau,ffvc1vdpau,ffmpeg12vdpau, -fs
vo vdpau is unneeded, I would not recommend autosync 30 and while demuxer lavf is needed for some samples, it makes others unplayable, so it is not a generally recommended option.

Carl Eugen

PS: You did try mc 2 (needed for all PAFF samples) and, to test where the problem lies, lavdopts skipframe=nonref (needed for high-bitrate samples)?
cehoyos is offline   Reply With Quote
Old 08-20-09, 09:33 AM   #12
jmbox
Registered User
 
Join Date: Jul 2009
Posts: 9
Default Re: vdpau hw too slow?

Thanks for your replies. My source is the EVO file copied from a HDDVD to a local harddrive, so very much a high-bitrate, but the skipframe=nonref did not help, and may have been slightly slower.

Using my previous command line, the initial on-screen logo appeared with out-of-sync audio, but the movie audio was in-sync and it starts dropping frames. Switching to mc 2 fixed the sync issue, but still have dropped frames.

demuxer lavf was necessary to play correctly. It fails to find the audio streams otherwise.

I have attached a new bug report log and also profiling output.

Code:
$ ./mplayer -demuxer lavf -ao alsa -vc ffvc1vdpau -aid 4 -mc 2 -lavdopts skipframe=nonref  SD.evo
MPlayer SVN-r29543-4.3.2 (C) 2000-2009 MPlayer Team

Playing SD.evo.
libavformat file format detected.
[lavf] Video stream found, -vid 0
[lavf] Audio stream found, -aid 1
[lavf] Audio stream found, -aid 2
[lavf] Audio stream found, -aid 3
[lavf] Audio stream found, -aid 4
[lavf] Audio stream found, -aid 5
VIDEO:  [WVC1]  1920x1080  0bpp  29.970 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Forced video codec: ffvc1vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] Trying pixfmt=0.
Unsupported PixelFormat -1
VDec: vo config request - 1920 x 1080 (preferred colorspace: VC1 VDPAU acceleration)
VDec: using VC1 VDPAU acceleration as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 VC1 VDPAU acceleration
[VD_FFMPEG] XVMC-accelerated MPEG-2.
[VD_FFMPEG] Trying pixfmt=0.
[VD_FFMPEG] XVMC-accelerated MPEG-2.
[VD_FFMPEG] XVMC-accelerated MPEG-2.
Selected video codec: [ffvc1vdpau] vfm: ffmpeg (FFmpeg WVC1 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 640.0 kbit/41.67% (ratio: 80000->192000)
Selected audio codec: [ffeac3] afm: ffmpeg (FFmpeg E-AC-3)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] XVMC-accelerated MPEG-2.
VDec: vo config request - 1920 x 1080 (preferred colorspace: VC1 VDPAU acceleration)
VDec: using VC1 VDPAU acceleration as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 VC1 VDPAU acceleration
A:   3.9 V:   2.1 A-V:  1.812 ct:  3.152   0/  0  6% 17%  0.9% 49 0

           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

A:  48.1 V:  48.1 A-V:  0.000 ct:  3.370   0/  0 32%  1%  7.4% 95 0
Exiting... (Quit)
Attached Files
File Type: gz nvidia-bug-report.log.gz (36.3 KB, 59 views)
File Type: gz mplayer.gprof.log.gz (32.8 KB, 72 views)
jmbox is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:37 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.