Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-20-09, 12:41 AM   #1
fulwood_jp
Registered User
 
Join Date: Jul 2009
Posts: 15
Default Cached images appears

Hello,

My system;

1. Machine: HP Workstation wx9400 with 8GB RAM
2. OS: openSUSE 11.1
Linux linux-z9sz 2.6.27.25-0.1-default #1 SMP 2009-07-01 15:37:09 +0200 x86_64
x86_64 x86_64 GNU/Linux
3. Desktop: pure enlightenment 1.0.0.001 only
3. Video Card: Quadra FX 570

[Problem]
I'm using NVIDIA-Linux-x86_64-177.82-pkg2.run, at the moment.
When I install the later driver (than 177.82), cached images appears before becoming enlightenment' desktop (just after login on kdm), and before back to kdm after logout
from enlightenment's desktop.

Of course, I googled. But I couldn't get any infomation.

Any idea?

Thanks. in advance.

Last edited by fulwood_jp; 08-20-09 at 07:19 AM. Reason: typo
fulwood_jp is offline   Reply With Quote
Old 08-20-09, 04:08 AM   #2
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Cached images sppears

This is probably a xorg defect, update your sistem.
kriko is offline   Reply With Quote
Old 08-20-09, 06:56 AM   #3
fulwood_jp
Registered User
 
Join Date: Jul 2009
Posts: 15
Default Re: Cached images sppears

Quote:
Originally Posted by kriko View Post
This is probably a xorg defect, update your sistem.
> This is probably a xorg defect, update your sistem.

I did, but I got no change.
fulwood_jp is offline   Reply With Quote
Old 08-20-09, 06:57 AM   #4
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Cached images sppears

What about drivers? 177.x are old
kriko is offline   Reply With Quote
Old 08-20-09, 07:18 AM   #5
fulwood_jp
Registered User
 
Join Date: Jul 2009
Posts: 15
Default Re: Cached images appears

No, this driver is the latest one which doesn't show any cached image of applications on the desktop.
fulwood_jp is offline   Reply With Quote
Old 08-20-09, 07:21 AM   #6
fulwood_jp
Registered User
 
Join Date: Jul 2009
Posts: 15
Default Re: Cached images sppears

Quote:
Originally Posted by kriko View Post
What about drivers? 177.x are old
Ah, you mean, I must try with the latest driver on the latest Xorg.
Of cource, I did it.
fulwood_jp is offline   Reply With Quote
Old 08-20-09, 09:25 AM   #7
fulwood_jp
Registered User
 
Join Date: Jul 2009
Posts: 15
Default Re: Cached images appears

I remembered! I've got Quadra FX 560 for another machine, as well.
I attached it, and tested.
I find, my Qudra FX 570 is a defective card!

I must tell this to HP.

Anyway, sorry fot the noise.
fulwood_jp is offline   Reply With Quote
Old 08-20-09, 02:06 PM   #8
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: Cached images sppears

I see something very similar with KDE4.x (every version I tried in the past months on various distributions) on my 9800GTS 512. I don't see it on log out, but on log in while KDE is loading.
The first monitor is fine, but the second one (with TwinView) shows either some weird colors when that is the first log in after a cold boot, or some old images from video memory (also after a reboot without turning the PC off).

I guess kdm just displays some part of the video memory without writing an image to it first.

Not nice if you log in and anybody watching can see what you did on the PC before.
Lysius is offline   Reply With Quote

Old 08-20-09, 11:57 PM   #9
fulwood_jp
Registered User
 
Join Date: Jul 2009
Posts: 15
Default Re: Cached images sppears

> Not nice if you log in and anybody watching can see what you did on the PC before.

I have never used KDE, at all.

I concluded that my Quadra FX 570 has got a defective with 2 points;

1. with Qudara FX 560, cached images in the video memory don't appear

2. the result of glxgears;

Qadra FX 570 -- about 45,000 frames 9,000 FPS
Qudra FX 560 -- about 77,000 frames, 15,000 FPS

Perhaps, it's a defective GPU, which is very difficult to find out.
fulwood_jp is offline   Reply With Quote
Old 08-21-09, 01:37 AM   #10
wyvern5
Registered User
 
Join Date: Mar 2009
Posts: 1
Default Re: Cached images sppears

I also get that with KDE and Gnome (I have compositing enabled in Gnome). I have an 8800GTX.
wyvern5 is offline   Reply With Quote
Old 08-21-09, 09:46 AM   #11
fulwood_jp
Registered User
 
Join Date: Jul 2009
Posts: 15
Default Re: Cached images appears

Quote:
Originally Posted by wyvern5 View Post
I also get that with KDE and Gnome (I have compositing enabled in Gnome). I have an 8800GTX.
Hum..., it might be a memoy's problem.
Is there any tool which check the video card's memory?

BTW, HP send me a new card (Quadra FX 570) tomorrow.
No defect, I hope.
fulwood_jp is offline   Reply With Quote
Old 08-21-09, 10:03 AM   #12
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: Cached images appears

Quote:
Originally Posted by fulwood_jp View Post
Hum..., it might be a memoy's problem.
Is there any tool which check the video card's memory?
It looks more like a problem with the usage of the memory. It's not initialized before usage and that is more a problem of the software or the driver than a problem of hardware.

And I have done some more testing. My problem seems to be a bug in some of the "Splash Screens" for KDE. I can only see that with the default "Leonidas" splash screen from Fedora 11 and not with the other splash screens (at least with KDE 4.3.0).
It's still a question though, if the nvidia driver should clear the memory before allocating, so that the bug does not become visible.
Lysius is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:21 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.