Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-23-09, 02:29 PM   #1
cleanrock
Registered User
 
Join Date: Feb 2009
Posts: 32
Default "Allow Flipping" 190.25

It seems "Allow Flipping" causes stuttering in 190.25, i did not experience this in 190.18.
The stuttering is visible about once every second in GL apps.

I might be off here but it may also be worth taking a look at it if you did some changes regarding "Flipping" in 190.25.
cleanrock is offline   Reply With Quote
Old 08-23-09, 04:59 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: "Allow Flipping" 190.25

Nothing should have changed fundamentally. Do you have any applications running in the background that use CPU time every second?
AaronP is offline   Reply With Quote
Old 08-24-09, 09:49 AM   #3
cleanrock
Registered User
 
Join Date: Feb 2009
Posts: 32
Default Re: "Allow Flipping" 190.25

Few apps and low load.
Btw, i havent found a good description of what "Allow Flipping" do, do you have a link to a good description ?
cleanrock is offline   Reply With Quote
Old 08-24-09, 12:59 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: "Allow Flipping" 190.25

ftp://download.nvidia.com/XFree86/Li...hapter-20.html
AaronP is offline   Reply With Quote
Old 08-24-09, 03:11 PM   #5
cleanrock
Registered User
 
Join Date: Feb 2009
Posts: 32
Default Re: "Allow Flipping" 190.25

Thanks.
I was actually "off", after some testing the cause seem to be xfwm4 (xfce window manager).
When i test this in kde i do not have this stuttering.
I only have it in xfce when windows are in fullscreen (both real fullscreen and "Alt-F11"), e.g. if i resize glxgears to fullscreen (Alt-F11) the stuttering starts and the stuttering disappears if i restore the window.
I havent found a fix for it yet (except for disabling Allow Flipping), tips from people here are very welcome.
cleanrock is offline   Reply With Quote
Old 08-26-09, 12:26 PM   #6
cleanrock
Registered User
 
Join Date: Feb 2009
Posts: 32
Default Re: "Allow Flipping" 190.25

This seem to be an issue with (graphic?) xfce panel plugins:
http://bugzilla.xfce.org/show_bug.cgi?id=5700
cleanrock is offline   Reply With Quote
Old 09-21-09, 11:28 PM   #7
dflogeras
Registered User
 
Join Date: Sep 2009
Posts: 8
Default Re: "Allow Flipping" 190.25

I think I have a related issue to this:

I have been seeing a graphics glitch ever since starting to use kde 4.x with compositing enabled. It is not the typical complaint with PowerMizer changing speeds (although I have that too, but have disabled it by locking the GPU speeds).

First off some system info:
Dell D820 laptop
NVidia Quadro NVS 110M (or Geforce Go 7300 as reported by lspci) VBIOS reported 5.72.22.21.FE
Gentoo linux
KDE 4.3.1, with composite enabled.
I have tried right up to the latest 190.32 beta drivers. Kernel right up to the 2.6.31, nothing seemed to get rid of my problem without the following workarounds.

Next a description of the problem. Hard to describe... I have tried to capture using 'recordmydesktop' to no avail. It seems to happen less when the system is under load. In any case, I can cause weird redraw glitches by opening firefox for instance, and quickly moving the mouse over various menu items, causing it to redraw the menus quickly. This is not the only time the glitch happens, but it is easy to induce this way. Basically, I can see random flickers all over the screen, and sometimes I can make out blocks of the background graphic used in my login manager (kdm). It must be cached somewhere and getting into the display. The display quickly corrects and draws the proper picture, but its annoying as it flickers.

Now, the workaround. If I turn of compositing, the problem goes away. Obviously just masks the problem. Also, if I use nvidia-settings, and un-check "Allow Flipping", the problem seems to go away as well. I'm not sure what this does entirely, but it seems to alleviate the issue.
dflogeras is offline   Reply With Quote
Old 10-05-09, 05:41 PM   #8
dflogeras
Registered User
 
Join Date: Sep 2009
Posts: 8
Default Re: "Allow Flipping" 190.25

I thought the problem went away with Xorg 1.6, but it did not.

I am now running the 190.42 drivers, still the issue remains.

I can alleviate it by running "nvidia-settings -a AllowFlipping=0" at each login, but this is just a side-step to hide a problem nvidia seems unable to fix.

Last edited by dflogeras; 10-29-09 at 10:20 PM. Reason: Problem really didn't go away
dflogeras is offline   Reply With Quote

Old 01-09-10, 01:04 PM   #9
hamelg
Registered User
 
Join Date: Jun 2008
Posts: 3
Default Re: "Allow Flipping" 190.25

Hello, I had an G92 [GeForce GTS 250] rev 162, and all worked fine.
Now, i replace it with a NV44 [Quadro NVS 285] rev 161 and i notice the same behavior. Disabling AllowFlipping is the workaround.
I am using the X.Org X Server 1.7.3.902 (1.7.4 RC 2) and the driver 190.53.
I remember that driver 185 didn't have this problem.
This issue is related with the hardware, perhaps with Quadro family.
hamelg is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.