Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-28-09, 08:35 AM   #1
lexum
Registered User
 
Join Date: Aug 2009
Posts: 5
Exclamation Fresh Mythbuntu Install, Cannot get Nvidia kernel to load, HDTV

Bare with me, I usually find the solution to my problems and rarely need to post a thread for help.

I am running a fresh install of Mythbuntu 9.04 on a fairly recent computer build. The attached bug report log shows two issues:

1) Disabling IRQ #16

I do not think this is the issue. You can see that the nvidia kernel is not loaded on IRQ #16. If I boot with irqpoll the error does not come up, however, nvidia is still not loaded.

2) Screen(s) found, but none have a usable configuration.

My xorg.conf looks quite vanilla. I wonder if the problem may be with detecting my HDTV on DVI using this xorg.conf. My next troubleshooting step is to hook this system up to a monitor and see if I have better luck.

I would appreciate it if someone with more experienced eyes would lay them on my bug report log.

Any suggestions are welcome.
Attached Files
File Type: log nvidia-bug-report.log (104.6 KB, 75 views)
lexum is offline   Reply With Quote
Old 08-28-09, 10:27 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Fresh Mythbuntu Install, Cannot get Nvidia kernel to load, HDTV

180.44 is pretty old. Does the problem still reproduce with a newer driver?

Also, it appears your nvidia graphics device actually is trying to use IRQ 16, which it's sharing with a couple of other drivers:
Code:
/proc/interrupts
           CPU0       CPU1       
  0:        109          1   IO-APIC-edge      timer
  1:          2          0   IO-APIC-edge      i8042
  8:          1          0   IO-APIC-edge      rtc0
  9:          0          0   IO-APIC-fasteoi   acpi
 12:          3          1   IO-APIC-edge      i8042
 16:     232556     232575   IO-APIC-fasteoi   pata_jmicron, uhci_hcd:usb3
 18:       8616       8640   IO-APIC-fasteoi   ehci_hcd:usb1, uhci_hcd:usb5, uhci_hcd:usb8
 19:      13431      13402   IO-APIC-fasteoi   ata_piix, ata_piix, uhci_hcd:usb7, cx18-0
 21:         34         29   IO-APIC-fasteoi   uhci_hcd:usb4
 22:         94         94   IO-APIC-fasteoi   HDA Intel
 23:         42         40   IO-APIC-fasteoi   ehci_hcd:usb2, uhci_hcd:usb6, ohci1394
2299:          0          0   PCI-MSI-edge      eth0
NMI:          0          0   Non-maskable interrupts
LOC:      17320      23522   Local timer interrupts
RES:       1350       1490   Rescheduling interrupts
CAL:         48         74   Function call interrupts
TLB:       1237       1166   TLB shootdowns
SPU:          0          0   Spurious interrupts
ERR:          0
MIS:          0
Code:
/usr/bin/lspci -d "10de:*" -v -xxx

01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
	Subsystem: Device 196e:0439
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at ea000000 (32-bit, non-prefetchable) [size=16M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Memory at e8000000 (64-bit, non-prefetchable) [size=32M]
	I/O ports at a000 [size=128]
	[virtual] Expansion ROM at eb000000 [disabled] [size=128K]
	Capabilities: [60] Power Management version 2
	Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [100] Virtual Channel <?>
	Capabilities: [128] Power Budgeting <?>
	Capabilities: [600] Vendor Specific Information <?>
	Kernel driver in use: nvidia
	Kernel modules: nvidia, nvidiafb
[...]
My guess is that one of those other driver is misbehaving and getting the interrupt disabled, preventing the NVIDIA driver from initializing the graphics device.
AaronP is offline   Reply With Quote
Old 08-28-09, 12:59 PM   #3
lexum
Registered User
 
Join Date: Aug 2009
Posts: 5
Default Re: Fresh Mythbuntu Install, Cannot get Nvidia kernel to load, HDTV

Correct me if I am wrong, but isn't 180.44 the latest repository release for Ubuntu 9.04?

I tried disabling the usb controller and I still get "Disabling IRQ #16" in the syslog. I cannot disable the sata controller (pata_jmicron) without losing my main hard drive.

Using a computer monitor did not fix the problem.

There is an updated BIOS for my motherboard that I will try this evening.
lexum is offline   Reply With Quote
Old 08-28-09, 04:51 PM   #4
lexum
Registered User
 
Join Date: Aug 2009
Posts: 5
Default Re: Fresh Mythbuntu Install, Cannot get Nvidia kernel to load, HDTV

OK, I updated my MoBo bios to the latest version and the disabling IRQ #16 error is no longer present in syslog.

I have attached my new bug report. The nvidia module is still not loading...

Is my xorg.conf okay?
Attached Files
File Type: log nvidia-bug-report.log (101.8 KB, 64 views)
lexum is offline   Reply With Quote
Old 08-28-09, 07:08 PM   #5
lexum
Registered User
 
Join Date: Aug 2009
Posts: 5
Default Re: Fresh Mythbuntu Install, Cannot get Nvidia kernel to load, HDTV

Just for kicks I uninstalled the restricted-modules nvidia driver that came with Mythbuntu (180.44) and installed the latest driver from nvidia's site. No change. The bug report is attached.
Attached Files
File Type: log nvidia-bug-report.log (101.8 KB, 53 views)
File Type: log nvidia-installer.log (52.3 KB, 75 views)
lexum is offline   Reply With Quote
Old 08-28-09, 07:22 PM   #6
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Fresh Mythbuntu Install, Cannot get Nvidia kernel to load, HDTV

I'm sorry, I didn't notice this error in your earlier log, but it's still there in your latest one:
Code:
[   26.360535] vmap allocation failed: use vmalloc=<size> to increase size.
Your kernel is running out of memory. Please see the README for a discussion of that error and what to do about it.
AaronP is offline   Reply With Quote
Old 08-28-09, 10:00 PM   #7
lexum
Registered User
 
Join Date: Aug 2009
Posts: 5
Default Re: Fresh Mythbuntu Install, Cannot get Nvidia kernel to load, HDTV

Hey! That worked! I added vmalloc=256M to my kernel in menu.lst

I find this solution odd because I am only using one video card. I will search around for the reason later, though. Thanks a bunch!
lexum is offline   Reply With Quote
Old 08-29-09, 10:59 AM   #8
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Fresh Mythbuntu Install, Cannot get Nvidia kernel to load, HDTV

Many things compete for kernel vmap memory, not just graphics cards.
AaronP is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.