Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-08-09, 09:21 AM   #1
mjcoss
Registered User
 
Join Date: Aug 2009
Posts: 3
Default Xserver crashes when using Xen, and latest linux kernel with bad page table

I debated about posting this with the assumption that the response that I'd get would be
"Xen is not supported by the Nvidia drivers", but maybe someone has a suggestion as to where to look for the problem

I'm running 2.6.31 linux kernel modified to support Xen, and the latest Xen hypervisor. I've tried various kernels, and various versions of Xen and every time when the system boots, the X server crashes with the following error

[ 1274.353930] X: Corrupted page table at address b6231000
[ 1274.353935] *pdpt = 0000000026a2b001
[ 1274.353941] Bad pagetable: 000f [#1] SMP
[ 1274.353947] last sysfs file: /sys/devices/pci0000:00/0000:00:1c.5/0000:10:00.0/resource
[ 1274.353951] Modules linked in: nvidia(P) [last unloaded: nvidia]
[ 1274.353960]
[ 1274.353964] Pid: 3998, comm: X Tainted: P (2.6.30-rc3-tip #2) System Product Name
[ 1274.353967] EIP: 0073:[<b62bda45>] EFLAGS: 00210202 CPU: 0
[ 1274.353971] EIP is at 0xb62bda45
[ 1274.353974] EAX: b6231000 EBX: b6610950 ECX: 098b6420 EDX: 00000001
[ 1274.353977] ESI: 00000020 EDI: 098b21f0 EBP: 098b6420 ESP: bfccc688
[ 1274.353980] DS: 007b ES: 007b FS: 0000 GS: 0033 SS: 007b
[ 1274.353984] Process X (pid: 3998, ti=e11ca000 task=e004f750 task.ti=e11ca000)
[ 1274.353987]
[ 1274.353989] EIP: [<b62bda45>] 0xb62bda45 SS:ESP 007b:bfccc688
[ 1274.353999] ---[ end trace 45f053777196423c ]---

I've run strace and what I see is that the X server is executing mmap2 for various regions of the IO memory associated with the card, and apparently one such mmap2 is fatal. There does appear to be a difference in the output of lspci when I boot the Xen hypervisor, verses when I don't.

I've googled around looking for anyone that has seen this kind of error message from the X server and no such luck.

Any thoughts? Sugguestions? (other than not using Xen)

And interesting side note is that the installer script does not detect that the system is running Xen, and so I don't have to use the IGNORE_XEN_PRESENCE workaround.
Attached Files
File Type: gz nvidia-bug-report.log.gz (34.9 KB, 86 views)
mjcoss is offline   Reply With Quote
Old 10-10-09, 01:41 PM   #2
meskalamdug
Registered User
 
Join Date: Apr 2006
Posts: 103
Default Re: Xserver crashes when using Xen, and latest linux kernel with bad page table

I think Nvidia drivers doesn't support Xen
I have the same problem,i've tried beta drivers
190.36 and stable 185.10,same problem.
No way...
meskalamdug is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.