Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-24-03, 11:11 AM   #1
cterp
Registered User
 
Join Date: Jun 2003
Posts: 1
Default Redhat 9 hang at login (now with informations)

Hi

I have updated my linuxbox to redhat 9 and the newest nvidia drivers (with the new installer), but the problem is that computer
hangs when it try to start the login screen.

The only thing which is visible are the hourglass and from there the only thing which takes place are the turning of the hourglass.


I'm using a ASUS AGP-V7100 SDRAM v 12.6 GeForce2 MX

==================================
XF86Config
==================================
# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Mouse1" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
#Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Option "AutoRepeat" "500 5"
# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
#Option "XkbOptions" ""
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc102"
Option "XkbLayout" "dk" #Option "XkbVariant" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
# Modified by mouseconfig
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 150.0
Option "dpms"
EndSection

Section "Device"
# no known options
#BusID
Identifier "NVIDIA GeForce 2 MX (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 2 MX (generic)"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 2 MX (generic)"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
Attached Files
File Type: log xfree86.0.log (24.0 KB, 130 views)
cterp is offline   Reply With Quote
Old 06-24-03, 11:23 AM   #2
Bobmeister
Registered User
 
Join Date: Jun 2003
Location: Mt. Prospect, IL
Posts: 13
Default

Yes, my config file is just about identical and my .log file is the same as well. My problem is similar but slightly different. I never get to the hour glass. But there is a BIG delay from initial boot-up to the log-in screen. I have a black screen for about 3 minutes before the nVidia logo comes up for a second and then the log-in screen which from that point on is normal.

Once in the system, everything is working fine. I have no hangs, not crashes, and AGP 4X support. I have not tried any Open GL stuff yet but am mostly concerned about the big hang at start-up.

I am eager to find out about this as I have several posts in several forums and haven't really heard anything about it yet.

What is it that could be making the system "work" so hard to start up?

Red Hat 9
ASUS A7V8X with KT400
Athlon XP 2600+
GeForce 3 Ti 500
Bobmeister is offline   Reply With Quote
Old 07-03-03, 10:43 PM   #3
syk0sis6
Registered User
 
Join Date: Jul 2003
Posts: 2
Angry Same Problems Please let me know when there is a solution....

I have the same prob... Hour glass no login... No EE in logs. I let it set for an hour and still no action... GF2 MX 400 on a K7N420 Pro....
syk0sis6 is offline   Reply With Quote
Old 07-04-03, 07:45 AM   #4
Bobmeister
Registered User
 
Join Date: Jun 2003
Location: Mt. Prospect, IL
Posts: 13
Default

Well, I found the solution for me...and it's elsewhere on this forum...but I really am sorry for NOT posting it on THIS thread. Seems as if the problem was that the modual by default probes for hardware every time it wants to load. OK...this is probably not much of a problem, but in Red Hat 9 at least, it causes a big hang and the Xserver will not start or will only start after a LONG delay.

The solution was in the Read Me file all along and I'll paste it here. Add the info in the Device section of your XF86Config file...

First, the Read me item:

Option "IgnoreDisplayDevices" "string"
This option tells the NVIDIA kernel module to completely
ignore the indicated classes of display devices when
checking what display devices are connected. You may
specify a comma-separated list containing any of "CRT",
"DFP", and "TV".

For example:

Option "IgnoreDisplayDevices" "DFP, TV"

will cause the NVIDIA driver to not attempt to detect
if any flatpanels or TVs are connected.

So, if you are just using a CRT monitore, add the Option line exactly as the example above and it will skip the probing.

Like this: Option "IgnoreDisplayDevices" "DFP, TV"
Don't forget the quotes.

This solved the problem for me and now the Xserver starts in two seconds with an NVidia splash screen and then login page....works like a champ and the driver is MUCH better than the "canned" "nv" driver....I have had no stability problems at all.....Let me know if you have success!
Bobmeister is offline   Reply With Quote
Old 07-04-03, 12:54 PM   #5
syk0sis6
Registered User
 
Join Date: Jul 2003
Posts: 2
Default

Have tried all of the options settings and all I get is a spinning hour glass in the middle of the screen.. It's as if GDM is not coming all the way up.. The X server starts but thats it.....

I recompiled kernel 2.4.21
and the latest XFree86 (4.3.0) with patch (4.3.0.1)

reinstalled NVIDIA 4363 drivers. Still no go... I also dropped back to using the onboard video (32mb)... still no go...

Getting frustrated...:-(
syk0sis6 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
redhat 8 nforce network success cd21 NVIDIA Linux 2 10-07-02 08:48 PM
Strange RedHat 7.3 issues with A7N266-C nforceuser NVIDIA Linux 8 09-27-02 03:16 PM
RedHAT didn't like nVidia GeForce 4 MX 440 alfa2k1 NVIDIA Linux 13 08-09-02 05:06 PM

All times are GMT -5. The time now is 03:50 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.