Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-16-09, 12:53 PM   #1
edmondt
Registered User
 
Join Date: Sep 2009
Posts: 4
Smile (EE) Failed to initialize GLX extension in GDM, startx loads fine

I have posted this at the ubuntu forum, but didn't get helped... I hope you guys can help me out or else I might have to reinstall :-S

My system is ubuntu 9.04 x64 and this is my error when starting up to gdm:
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

I have done numerous restarts, re-install driver and re-configuration, but I need some advice on how to get into gdm with nvidia

It all worked fine yesterday, but failed to work after a clean restart it fails to boot into gdm. Once I exit gdm, I can startx perfectly with glx loaded etc...
Attached Files
File Type: gz nvidia-bug-report.log.gz (45.1 KB, 105 views)
File Type: gz nvidia-bug-report.log.old.gz (36.8 KB, 111 views)
edmondt is offline   Reply With Quote
Old 09-16-09, 12:55 PM   #2
edmondt
Registered User
 
Join Date: Sep 2009
Posts: 4
Default Re: (EE) Failed to initialize GLX extension in GDM, startx loads fine

Here is my xorg.conf:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Wed Sep  2 03:36:10 PDT 2009

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
#Section "Module"
#    Load           "dbe"
#    Load           "extmod"
#    Load           "type1"
#    Load           "IA"
#    Load           "bitstream"
#    Load           "xtsol"
#    Load           "glx"
#EndSection

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11/lib/X11/rgb"
    FontPath        "/usr/X11/lib/X11/fonts/misc/:unscaled"
    FontPath        "/usr/X11/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/X11/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/X11/lib/X11/fonts/misc/"
    FontPath        "/usr/X11/lib/X11/fonts/Type1/"
    FontPath        "/usr/X11/lib/X11/fonts/100dpi/"
    FontPath        "/usr/X11/lib/X11/fonts/75dpi/"
    FontPath        "/usr/X11/lib/X11/fonts/TrueType/"
    FontPath        "/usr/X11/lib/X11/fonts/Type1/sun/"
    FontPath        "/usr/X11/lib/X11/fonts/F3bitmaps/"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro NVS 140M"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
    Option         "NoLogo" "True"
    Option         "CursorShadow" "true"
    Option         "Coolbits" "true"
    Option         "DPI" "75 x 85"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection
cat /var/log/gdm/\:0.log returns:

Code:
5905 5820
xinit /etc/gdm/failsafeXinit /etc/X11/xorg.conf.failsafe with-gdm -- /usr/bin/X :0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7 -br -once -config /etc/X11/xorg.conf.failsafe -logfile /var/log/Xorg.failsafe.log

X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-15-server x86_64 Ubuntu
Current Operating System: Linux mint-laptop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64
Build Date: 09 April 2009  02:11:54AM
xorg-server 2:1.6.0-0ubuntu14 (buildd@crested.buildd) 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/var/log/Xorg.failsafe.log", Time: Tue Sep 15 13:13:59 2009
(++) Using config file: "/etc/X11/xorg.conf.failsafe"

error setting MTRR (base = 0xd5000000, size = 0x00e00000, type = 1) Invalid argument (22)
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
5905 5820

waiting for X server to shut down  ddxSigGiveUp: Closing log
edmondt is offline   Reply With Quote
Old 09-16-09, 12:56 PM   #3
edmondt
Registered User
 
Join Date: Sep 2009
Posts: 4
Default Re: (EE) Failed to initialize GLX extension in GDM, startx loads fine

cat /var/log/gdm/\:0.log returns:

Code:
5905 5820
xinit /etc/gdm/failsafeXinit /etc/X11/xorg.conf.failsafe with-gdm -- /usr/bin/X :0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7 -br -once -config /etc/X11/xorg.conf.failsafe -logfile /var/log/Xorg.failsafe.log

X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-15-server x86_64 Ubuntu
Current Operating System: Linux mint-laptop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64
Build Date: 09 April 2009  02:11:54AM
xorg-server 2:1.6.0-0ubuntu14 (buildd@crested.buildd) 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/var/log/Xorg.failsafe.log", Time: Tue Sep 15 13:13:59 2009
(++) Using config file: "/etc/X11/xorg.conf.failsafe"

error setting MTRR (base = 0xd5000000, size = 0x00e00000, type = 1) Invalid argument (22)
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
5905 5820

waiting for X server to shut down  ddxSigGiveUp: Closing log
/etc/init.d $ sudo apt-cache policy nvidia-kernel-source
Code:
nvidia-kernel-source:
  Installed: (none)
  Candidate: (none)
  Version table:
/etc/init.d $ apt-cache policy nvidia-glx
Code:
nvidia-glx:
  Installed: (none)
  Candidate: (none)
  Version table:
/etc/init.d $ apt-cache policy nvidia-kernel-common
Code:
nvidia-kernel-common:
  Installed: (none)
  Candidate: 20080825+1ubuntu2
  Version table:
     20080825+1ubuntu2 0
        500 http://ubuntu.mirror.iweb.ca jaunty/restricted Packages
/etc/init.d $ lsmod | grep nvidia
Code:
nvidia               9615272  49 
edmondt@mint-laptop /etc/init.d $ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
edmondt is offline   Reply With Quote
Old 09-16-09, 12:59 PM   #4
edmondt
Registered User
 
Join Date: Sep 2009
Posts: 4
Default Re: (EE) Failed to initialize GLX extension in GDM, startx loads fine

I have ran the following, but still thew same error after...

Code:
sudo apt-get --purge remove nvidia-glx nvidia-glx-legacy nvidia-glx-new nvidia-settings xserver-xorg-video-nv

wget ftp://download.nvidia.com/XFree86/Linux-x86_64/190.32/NVIDIA-Linux-x86_64-190.32-pkg2.run -O NVIDIA-Linux-x86_64-190.32-pkg2.run

sudo install NVIDIA-Linux-x86_64-190.32-pkg2.run /usr/src

sudo ln -fs /usr/src/NVIDIA-Linux-x86_64-190.32-pkg2.run /usr/src/nvidia-driver

sudo sh /usr/src/nvidia-driver
I tried entering my BusID to xorg.conf, but still won't load...

Code:
sudo lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 140M (rev a1)

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro NVS 140M"
    BusID          "PCI:1:0:0"
EndSection
I tried uninstalling and reinstalling many times, I have done the following:

Code:
sudo envyng -t (to uninstall nvidia)
On reboot, exit gdm

Code:
sudo /etc/init.d/gdm stop

sudo apt-get --purge remove nvidia-glx nvidia-glx-legacy nvidia-glx-new nvidia-settings xserver-xorg-video-nv
sudo aptitude purge $(dpkg -l | grep nvidia | awk '{print $2}')
reboot again, exit gdm

Code:
sudo /etc/init.d/gdm stop

wget ftp://download.nvidia.com/XFree86/Linux-x86_64/190.32/NVIDIA-Linux-x86_64-190.32-pkg2.run -O NVIDIA-Linux-x86_64-190.32-pkg2.run
sudo install NVIDIA-Linux-x86_64-190.32-pkg2.run /usr/src
sudo ln -fs /usr/src/NVIDIA-Linux-x86_64-190.32-pkg2.run /usr/src/nvidia-driver

sudo sh /usr/src/nvidia-driver
To install the driver, gdm still fails to load! startx works.

Tried different driver versions, tried

Code:
sudo apt-get install nvidia-kernel-common nvidia-glx-new
Current extensions:

Code:
ls -l /usr/lib/xorg/modules/extensions/
total 2396
-rw-r--r-- 1 root root   18744 2009-04-08 22:16 libdbe.so
-rw-r--r-- 1 root root   10440 2009-04-08 22:16 libdri2.so
-rw-r--r-- 1 root root   43688 2009-04-08 22:16 libdri.so
-rw-r--r-- 1 root root  106016 2009-04-08 22:16 libextmod.so
lrwxrwxrwx 1 root root      16 2009-09-16 11:27 libglx.so -> libglx.so.190.32
-rwxr-xr-x 1 root root 2236336 2009-09-16 11:27 libglx.so.190.32
-rw-r--r-- 1 root root   31144 2009-04-08 22:16 librecord.so
Please advice
edmondt is offline   Reply With Quote
Old 10-08-09, 11:56 AM   #5
JBDynamics
Registered User
 
Join Date: Oct 2009
Posts: 1
Question Re: (EE) Failed to initialize GLX extension in GDM, startx loads fine

I have exactly the same problem. I have tried all the steps listed that edmondt has tried. I have reinstalled Kubuntu 9.04 AMD64 three times, and as soon as I install all my packages (including nvidia 180.44) KDM crashes right after the NVIDIA logo screen upon restart of the system after the updates and package install. Until I followed all of edmondt's steps, startx did not work, X did not work, and xinit did not work. I check the Xorg.0.log and it prints exactly the same errors as edmondt. I configured my xorg.conf to look just like edmondt's but with changes for my system (Asus G71G-Q1 12GB PC2-7500, 512MB GeForce 9800M GS, Intel Core 2 Extreme Quad Mobile 2.53GHz (QX9300).

kdm.log prints out the (EE) Failed to initialize GLX extension.
With a MTRR Error Exiting with status (22) above the (EE) Failed to initialize GLX.

After reconfiguring my xorg.conf, I can use startx and it loads no problem. The thing is, I want KDM and Kubuntu, not Xfce desktop. I am attempting to install the gnome-desktop to check if I have the same problem loading GDM as I do KDM. I will post the results and error logs (if applicable) when it's finished installing.

I have an HP with a GeForce 9600 GT and a Dell with a GeForce 9600M GT and they have exactly the same packages installed as my Asus, and they both boot with no problems.

Somebody please help us!

Thanks in advance for your time, patience, and help.

Update:

I installed ubuntu-desktop meta-package, and it loads with no problems. I am going to reinstall all KDE related packages, and see if it boots up after that. I will update again after install and reboot.

Thanks again everyone willing to help us.
JBDynamics is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.