Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-12-09, 08:05 AM   #1
sergiou87
Registered User
 
Join Date: Oct 2009
Posts: 4
Default Black desktop on KDE4 with OGL composition

Hi!

In my laptop I have a NVIDIA Geforce 6200 Go, Debian SID (100% updated), NVIDIA drivers 185.18.36, kernel 2.6.30-2-686 and I get a black plasma desktop using composition based on OpenGL. In addition some windows appear in black too.

I've been having this problem since kernel 2.6.29 (included). Using Linux 2.6.28, 2.6.27 or 2.6.26 there are no problems. I've also tried every NVIDIA driver released (stable or not) since 2.6.29 was released and my problems began. Of course, I've been updating KDE4 as a new version is released. I also tried all this configurations on ArchLinux, with the same result.

The only ways I found to solve my problem were:
  • Turn back to kernel 2.6.26/27/28: not possible as I need some wifi drivers
  • Deactivate composition: my system turns veeery slow
  • Switch composition to XRender: it works but it's still very slow

This is my xorg.conf:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildd@ninsei)  Fri Sep  5 22:23:08 UTC 2008


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x800"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
I've tried every possible combination of preferences in KDE4, but it didn't result. I've attached 2 screenshots to show my problem.

What can I do?

Thank you in advance
Attached Thumbnails
Click image for larger version

Name:	opengl_composition1.jpg
Views:	135
Size:	77.7 KB
ID:	38411  Click image for larger version

Name:	xrender_composition.jpg
Views:	119
Size:	95.8 KB
ID:	38412  
sergiou87 is offline   Reply With Quote
Old 10-12-09, 10:31 AM   #2
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Black desktop on KDE4 with OGL composition

This is probably an old bug where video memory fills up and then newly opened windows turn black.
Try newer drivers.
kriko is offline   Reply With Quote
Old 10-12-09, 12:34 PM   #3
Dizzle7677
Registered User
 
Dizzle7677's Avatar
 
Join Date: May 2008
Location: Relativity
Posts: 194
Default Re: Black desktop on KDE4 with OGL composition

The problem is WM agnostic it happens in Gnome2.8/xserver1.7.x/nv190.36 with compositing also ...
__________________
Elephants can fly but they have no reason to.
------------------------------------------
Phenom II X3 720 @ 3.5Ghz | Asus M4A785-M | 2 Gig Crucial DDR2 @ 960 Mhz | GeForce GT 440 1024 MB | Linux 3.6.1 / Ubuntu 12.04 / W.I.N.E v1.5.14
Dizzle7677 is offline   Reply With Quote
Old 10-12-09, 04:52 PM   #4
nevion
Registered User
 
Join Date: Dec 2004
Posts: 74
Default Re: Black desktop on KDE4 with OGL composition

As another user suggested - using xrender helps you avoid these types of problems when compositing is enabled. But this is all about picking which 2 sides of the triangle you want, so to speak. For instance, zooming and taskbar window previews suck now, but at least I don't have to restart kwin every 3 hours after a few days of uptime for basic window mangling.
nevion is offline   Reply With Quote
Old 10-13-09, 03:11 AM   #5
sergiou87
Registered User
 
Join Date: Oct 2009
Posts: 4
Default Re: Black desktop on KDE4 with OGL composition

Quote:
Originally Posted by nevion View Post
As another user suggested - using xrender helps you avoid these types of problems when compositing is enabled. But this is all about picking which 2 sides of the triangle you want, so to speak. For instance, zooming and taskbar window previews suck now, but at least I don't have to restart kwin every 3 hours after a few days of uptime for basic window mangling.
The problem I'm suffering isn't fixed restarting Kwin. Actually, it appears since I login into KDE4 :-\

I didn't mention it before, but I've been trying every X.org version since the problem began. Again, the only 3 solutions I wrote are the only ones that worked :-\

Is there any other data I can provide to you in order to diagnosticate my problem? Maybe glxinfo output? Some log?
sergiou87 is offline   Reply With Quote
Old 10-13-09, 09:43 AM   #6
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Black desktop on KDE4 with OGL composition

Logout, move kwin or whole kde4 settings and login again into fresh environment and retest
if the problem persists.
kriko is offline   Reply With Quote
Old 10-13-09, 02:51 PM   #7
tongrider
Registered User
 
Join Date: Sep 2009
Posts: 4
Default Re: Black desktop on KDE4 with OGL composition

Same problem here since kernel 2.6.29. All WM impacted, KDE or Gnome/compiz.
tongrider is offline   Reply With Quote
Old 10-13-09, 07:47 PM   #8
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: Black desktop on KDE4 with OGL composition

Hi,

Please see: http://www.nvnews.net/vbulletin/show...=1#post2103923
Plagman is offline   Reply With Quote

Old 10-14-09, 05:42 AM   #9
sergiou87
Registered User
 
Join Date: Oct 2009
Posts: 4
Default Re: Black desktop on KDE4 with OGL composition

Quote:
Originally Posted by Plagman View Post
Thank you!! I can't wait for its release
sergiou87 is offline   Reply With Quote
Old 10-17-09, 01:42 PM   #10
sergiou87
Registered User
 
Join Date: Oct 2009
Posts: 4
Default Re: Black desktop on KDE4 with OGL composition

It's working fine right now using 190.40 Thank you very much!!!
sergiou87 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:04 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.