Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-15-09, 05:53 AM   #1
chrbecke
Registered User
 
Join Date: Oct 2006
Posts: 4
Default Quadro NVS 150M w/ 185.18.36/190.42 trouble switching to vt/external display

Hi,

I've got a laptop (Toshiba Tecra R10-11Y) with Quadro NVS 150M graphics running 64bit Gentoo.
I'm having trouble switching from X to VTs and switching to a display connected to the vga out. If I switch from X to a VT, the screen is blank. If I then switch to the external display and back using <Fn>+<F5>, the console displays normally. If I switch on the external display from X, the external display shows a garbled screen. Switching back to the internal lcd results in the same garbled screen displayed on the internal lcd.
This happens both with a framebuffer console (using uvesafb) and without (without fb, the display does not become garbled, but turns black instead).
Using the vesa driver, both switching to VTs and to external display work as expected.

After the display got corrupted, I can still ssh into the box. If I try to stop X, it hangs. I can stop X with a SIGKILL. If I then restart X, it reproducibly segfaults (see attached backtraces and nvidia-bug-report.log).

Another thing I noticed is v86d (if fb console is used) uses almost all cpu after trying to restart X (backtrace attached).

As a workaround, I can enable the external display using twinview and nvidia-settings.

Any hints how to get switching to VTs and switching to external display using <Fn>+<F5> to work? What can I do to further debug this?

Thanks,

Chris

The bug occured with the following:
gentoo-sources 2.6.31, 2.6.31-r1 and 2.6.31-r2
xorg-server 1.6.4 and 1.6.5
nvidia-drivers 185.18.36 and 190.36
v86d 0.1.9

Edit:
Bug is still there with:
gentoo-sources 2.6.31-r3
nvidia-drivers 190.42
Attached Files
File Type: gz nvidia-bug-report.log.gz (29.5 KB, 66 views)
File Type: txt bt_Xorg_after_screen_garbled.txt (1.2 KB, 85 views)
File Type: txt bt_Xorg_after_restart_1.txt (1.1 KB, 76 views)
File Type: txt bt_Xorg_after_restart_2.txt (1.1 KB, 83 views)
File Type: txt bt_v86d_high_cpu_1.txt (805 Bytes, 73 views)

Last edited by chrbecke; 10-22-09 at 10:34 AM. Reason: New Beta 190.42 does not work either.
chrbecke is offline   Reply With Quote
Old 10-22-09, 10:38 AM   #2
chrbecke
Registered User
 
Join Date: Oct 2006
Posts: 4
Default Re: Quadro NVS 150M w/ 185.18.36/190.36 trouble switching to vt/external display

Ideas, anyone? What can I do? Or do I have to live with this?
chrbecke is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.