Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-23-08, 07:56 PM   #1
jesper_w
Registered User
 
Join Date: May 2008
Posts: 2
Default Unable to install Nvidia driver on 9500M + Ubuntu

Hi!
I have tried to install the Linux x64 (AMD64/EM64T) Display Driver version 173.08 on the latest Ubuntu (8.04) but it won't work.

I have an Asus laptop (G1SN-AK023C) with a GeForce 9500M GS.

I have followed the instructions in this thread but with no luck. It compiles the driver and then gives the error that it can't load the kernel module nvidia.ko.
In the log it says: "Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko': -1 No such device"

The hardware is 64-bit, and I have tried both 64-bit driver on 64-bit Ubuntu and 32-bit driver on 32-bit Ubuntu with the same result.

Does anyone have any ideas on how to proceed? The older drivers doesn't seem to recognize the card at all so I'm stuck in 800x600 without a proper driver (which really sucks on a 1680x1050 display).
jesper_w is offline   Reply With Quote
Old 05-24-08, 05:09 AM   #2
GPO
Registered User
 
Join Date: May 2008
Location: Finland
Posts: 6
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

I have exactly the same problem with my Asus G1Sn, the 173.08 beta drivers either seem impossible to install or they don't work, and so far I haven't been able to find any solution. I've searched both Nvidia and Ubuntu forums, but to no avail. Searching Google didn't help either, so for the moment I've pretty much given up trying make the 9500 GS work. I'm just waiting for the final drivers to come out, hoping they will solve the problem.
GPO is offline   Reply With Quote
Old 05-24-08, 02:20 PM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Please see the forum sticky posts on how to report a problem, including how to generate an nvidia-bug-report.log.
AaronP is offline   Reply With Quote
Old 05-25-08, 11:07 AM   #4
GPO
Registered User
 
Join Date: May 2008
Location: Finland
Posts: 6
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Here are my log files. Maybe the 'nvidia-installer.log' will explain why I didn't manage to install the drivers, but I myself don't know how to intepret it correctly. Despite using Ubuntu for a while now, I'm still pretty much a newbie when it comes to anything more than basic use. Usually Google helps, but not this time.

Attached also the 'nvidia-bug-report.log', but I don't know how much good it will do. Since the installation of 'NVIDIA-Linux-x86-173.08.pkg1.run' was unsuccesful, the 'nvidia-bug-report.sh' wasn't installed either and I had to install 'nvidia-glx' just to be able to create bug report.
Attached Files
File Type: log nvidia-installer.log (27.0 KB, 316 views)
File Type: bz2 nvidia-bug-report.log.bz2 (31.1 KB, 304 views)
GPO is offline   Reply With Quote
Old 05-25-08, 11:53 AM   #5
evilbunny
Registered User
 
Join Date: May 2008
Posts: 16
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

I'm suffering this problem too:

Quote:
[ 129.030980] warning: process `nvidia-installe' used the deprecated sysctl
system call with 1.23.
[ 129.030993] warning: process `nvidia-installe' used the deprecated sysctl
system call with 1.23.
[ 129.191641] nvidia: module license 'NVIDIA' taints kernel.
[ 129.447212] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) ->
IRQ 16
[ 129.447218] NVRM: This PCI I/O region assigned to your NVIDIA device is
invalid:
[ 129.447219] NVRM: BAR1 is 0M @ 0x00000000 (PCI:0001:00.0)
[ 129.447221] NVRM: The system BIOS may have misconfigured your graphics
card.
[ 129.447225] nvidia: probe of 0000:01:00.0 failed with error -1
[ 129.447236] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 129.447237] NVRM: None of the NVIDIA graphics adapters were initialized!
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
And there is even a bug reported to ubuntu about it:

https://bugs.launchpad.net/ubuntu/+bug/206522

Which led me to try removing ram from my system, low and behold having 2GB of ram everything works. With 2GB of RAM I see the following:

Quote:
[ 50.685221] warning: process `nvidia-installe' used the deprecated sysctl system call with 1.23.
[ 50.685229] warning: process `nvidia-installe' used the deprecated sysctl system call with 1.23.
[ 50.746217] nvidia: module license 'NVIDIA' taints kernel.
[ 50.999350] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
[ 50.999361] PCI: Setting latency timer of device 0000:01:00.0 to 64
[ 50.999497] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 173.08 Wed Apr 2 07:55:48 PST 2008
[ 51.012019] warning: process `nvidia-installe' used the deprecated sysctl system call with 1.23.
[ 61.490069] PCI: Setting latency timer of device 0000:01:00.0 to 64
[ 61.490419] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 173.08 Wed Apr 2 07:55:48 PST 2008
If I have 3GB and try to use a nvidia driver the next thing I see on the laptop isn't the nvidia logo but rather the bios screen and the laptop has rebooted for some reason.

I tried to cheat by specifying mem=2048M in grub, but this wasn't sufficient, I had to physicially remove ram from the system before it would work.

I have a laptop running xubuntu amd64 with a nvidia geforce 9500M GS chipset.
evilbunny is offline   Reply With Quote
Old 05-25-08, 06:15 PM   #6
jesper_w
Registered User
 
Join Date: May 2008
Posts: 2
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

The 3GB RAM seems to be the problem. I removed 1GB and the installer worked.
Once the driver was installed I put back the memory and restarted. Then the driver refused to work and Ubuntu told me that it could not detect my graphics card. It booted with low resolution and I could finally generate the bug report.
I then removed the memory again and it booted without problems.

I have attached both the nvidia-installer.log and the nvidia-bug-report.log.
If I can provide any other info to make this work, please let me know.
Attached Files
File Type: zip nvidia-logs.zip (36.5 KB, 221 views)
jesper_w is offline   Reply With Quote
Old 05-27-08, 12:16 AM   #7
GPO
Registered User
 
Join Date: May 2008
Location: Finland
Posts: 6
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Slightly off topic, but has anyone tried any other Linux distros than Ubuntu? Does the problem occur on other distros as well?
GPO is offline   Reply With Quote
Old 05-27-08, 06:36 AM   #8
evilbunny
Registered User
 
Join Date: May 2008
Posts: 16
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Quote:
Originally Posted by GPO
Slightly off topic, but has anyone tried any other Linux distros than Ubuntu? Does the problem occur on other distros as well?
I wouldn't have thought they would have made that many changes to the kernel, and I removed the nvidia stuff xubuntu installs and I tried both the stable and beta versions from the nvidia site, although the xubuntu packages installs the stable version.
evilbunny is offline   Reply With Quote

Old 05-29-08, 01:05 AM   #9
GPO
Registered User
 
Join Date: May 2008
Location: Finland
Posts: 6
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

I installed the new kernel 2.6.24-17, hoping it would solve the display problem, but no such luck. Has anyone come up with anything new about the problem?

Haven't tried removing the 1GB of RAM myself yet, but might just do so I'll be able to use Ubuntu better. 800x600 resolution just isn't enough with applications these days.

Edit: Ah, just noticed the new 173.14.05 drivers, will try them tonight.
GPO is offline   Reply With Quote
Old 05-29-08, 01:36 PM   #10
Fourmiii
Registered User
 
Join Date: May 2008
Posts: 4
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

I also have a G1Sn and I use the (slow) VESA driver to have full 1680x1050 resolution.
This is done by simply replacing "nv" or "nvidia" to "vesa" in /etc/X11/xorg.conf.

Through various trials of installing the beta 173.08, I found out the best way to have it compiled easily was :
Code:
sudo apt-get install module-assistant
sudo module-assistant prepare
sudo /etc/init.d/gdm stop
and then running the NVIDIA installer script on a console.

This always led me to the error in /var/log/nvidia-installer.log
NVRM: This PCI I/O region assigned to your NVIDIA device ...

Just found out there was a new, non-beta driver in town ... 'lo and behold the 173.14 version is out since yesterday!!

But the sad news is, I get the exact same NVRM error with the new version..

IMHO, if the bios had options for mapping the video memory elsewhere (say beneath the 2Gb limit) this wouldn't be an issue & the driver would load fine. Are there any existing bios updates ?

Let's all hope someone, somewhere fixes this soon...

In the meantime, I'll still try taking out 2Gb from my 4Gb ..
Fourmiii is offline   Reply With Quote
Old 05-29-08, 06:27 PM   #11
evilbunny
Registered User
 
Join Date: May 2008
Posts: 16
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Quote:
Originally Posted by Fourmiii
But the sad news is, I get the exact same NVRM error with the new version..
Thanks for the tip, I won't bother putting the 1G module back in just yet

Yes the vesa module is much slower compared to the nvidia one when its working.

Quote:
IMHO, if the bios had options for mapping the video memory elsewhere (say beneath the 2Gb limit) this wouldn't be an issue & the driver would load fine. Are there any existing bios updates ?
That doesn't make sense, otherwise why would it work under windows? Although I did find it strange that Asus shipped a 32bit version of windows vista, coincidence?
evilbunny is offline   Reply With Quote
Old 05-30-08, 04:36 PM   #12
rlb1961
Registered User
 
Join Date: May 2008
Posts: 2
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

I have been having the exact same problem with my system. I was running 4 GB of RAM in a Core2Duo system and installed Ubuntu 8.04 (64-bit). Originally, I was using the on-board video, which was an nVidia 7100, but it wouldn't allow me to install the drivers using Envy, the restricted divers or to even install the drivers 173.14.05 drivers downloaded from nVidia. I went out and bought a newer card (8600GT PCI-E with 512MB DDR2), but the same issue. I finally noticed the following message in my nvidia-installer.log file:

NVRM: This PCI I/O region assigned to your NVIDIA device is
invalid:
[ 237.519725] NVRM: BAR1 is 256M @ 0x30000000 (PCI:0002:00.0)
[ 237.519727] NVRM: This is a 64-bit BAR mapped above 4GB by the system
BIOS or
[ 237.519728] NVRM: Linux kernel. The NVIDIA Linux graphics driver and
other
[ 237.519729] NVRM: system software do not currently support this
configuration
[ 237.519730] NVRM: reliably.

I uninstalled one stick of RAM, dropping it to 2 GB, and everything worked smoothly. I was able to install the drivers, it saw my monitor correctly, all of the resolutions were supported, etc. So once I ahve everything set up, I shut down, re-installed the additional RAM and rebooted. It sent me right back to the "low-resolution graphics" screen. Once I took the RAM back out, everything worked once again.

It seems to me that we should be able to run 4 GB or more in a 64-bit system without these kind of problems. Is there any way to specify the memory range where the nVidia driver will load?
rlb1961 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT650M not recognized by 295.59 Driver on Ubuntu 12.04 hvontres NVIDIA Linux 13 06-22-12 02:33 PM
Powermizer problem, nvidia 9500m gs ubuntu backtoback NVIDIA Linux 3 05-25-12 01:13 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 06:32 PM

All times are GMT -5. The time now is 04:12 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.