Go Back   nV News Forums > Linux Support Forums > NVIDIA Solaris

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-01-08, 05:40 PM   #1
Triskelios
Registered User
 
Join Date: Aug 2004
Posts: 6
Lightbulb PowerMizer configuration in NVIDIA Unix drivers

"PowerMizer", as you probably know, is NVIDIA's name for the power management features of their hardware, whose primary purpose is adaptive clocking of the core and memory to save power. The current series of NVIDIA drivers for Unix (Solaris, Linux, FreeBSD) drivers enable these features by default.
PowerMizer regulates transitions between multiple "performance levels" which each define a set of clock frequencies It currently has three profiles, "Maximum performance", "Balanced", and "Maximum battery life".

In Windows, the NVIDIA control panel is able to adjust the PowerMizer configuration. In Unix, the bundled nvidia-settings utility displays the current clock frequencies and PowerMizer mode, but it does not allow changes. The PowerMizer policy is stuck in the default, which is usually "maximum performance". This may not be preferable for users wishing to conserve power. In particular, running Compiz can cause the clocks to run at the highest frequencies for extended periods of time, even if there is no noticeable performance degradation from running at a lower performance level.


The interesting thing is that it is evident that the kernel driver in Unix uses an internal Windows registry parser to load settings. The Xorg/XFree86 driver includes the "RegistryDwords" and "RegistryBinary" options. The Linux kernel driver also has similar options (it's unclear if the Solaris kernel driver accepts options). These allow specifying Windows registry key names and values which are loaded by the kernel driver. Posts in nvnews show they're specified as "Key1=value", multiple keys can be separated with semicolons. Hexadecimal values can use the "0x" prefix.

Some Windows registry keys which may affect PowerMizer include:
  • EnableMClkSlowdown
  • EnableCoreSlowdown
  • EnableNVClkSlowdown
  • PerfLevelSrc
  • PowerMizerEnable
  • PowerMizerDefault
  • PowerMizerDefaultAC
  • PowerMizerLevel
  • PowerMizerHardLevel
  • PowerMizerLevelAC
  • PowerMizerHardLevelAC
  • PowerSaverHsyncOn
Judging from the Windows drivers, these are all DWORD (32 bit) values.
The PowerMizer modes are numbered 1, 2, and 3 respectively in the software.
(See http://developer.download.nvidia.com...lPanel_API.pdf )
In Windows, PowerMizerLevel* and PowerMizerDefault* seem to adjust the mode (not sure what the difference is between them), and PerfLevelSrc determines whether adaptive clocking is enabled for battery and AC.

To test if these affected PowerMizer settings in the Unix driver, I added the following to the appropriate Device section of xorg.conf:
Code:
Options "RegistryDwords" "PowerMizerLevel=0x2"
On my laptop, nvidia-settings seems to always report the power source as "battery", so I didn't set PowerMizerLevelAC.

It appears to work. When I am only running Compiz, nvidia-settings shows that only the lower performance levels are being used, although it incorrectly reports the PowerMizer mode as "Maximum performance". The performance in games seems to be the same as before the change.

This was tested on a Solaris Express (snv_81) system. Feedback is appreciated, especially if someone knows a bit more about the meanings of each the registry keys.

-Albert
Triskelios is offline   Reply With Quote
Old 04-10-08, 10:52 AM   #2
Redmumba
Registered User
 
Join Date: Mar 2008
Posts: 4
Default Re: PowerMizer configuration in NVIDIA Unix drivers

This is awesome! I am running the latest beta (171.06) and even though its displaying Maximum Performance, it is correctly underclocking it to the lowest settings.

This is on the NVidia Quadro NVS 140M, on my Thinkpad T61, running Archlinux with a custom 2.6.24 kernel (so not Solaris, but it works!).

Thank you for your tip!
Redmumba is offline   Reply With Quote
Old 06-19-08, 07:09 PM   #3
forrest_brewer
Registered User
 
Join Date: May 2007
Posts: 1
Smile Re: PowerMizer configuration in NVIDIA Unix drivers

I have been fighting this particular issue on my HP tx1000 for 6 months -- I set the power level to
0x3 == 100MHz on this machine (6150 Go) and now the system reports 100MHz GPU Clock,
despite this video and opengl applications run nearly the same -- but the GPU reports 60C versus
idle values of 75-78C before. I have yet to test the battery life, but so far this tip is working perfectly! Thanks!

(Using "stable" 175.14.05)

Forrest
forrest_brewer is offline   Reply With Quote
Old 06-27-08, 06:43 AM   #4
rfr22
Registered User
 
Join Date: May 2008
Posts: 2
Default Re: PowerMizer configuration in NVIDIA Unix drivers

Quote:
Originally Posted by forrest_brewer View Post
I have been fighting this particular issue on my HP tx1000 for 6 months -- I set the power level to
0x3 == 100MHz on this machine (6150 Go) and now the system reports 100MHz GPU Clock,
despite this video and opengl applications run nearly the same -- but the GPU reports 60C versus
idle values of 75-78C before. I have yet to test the battery life, but so far this tip is working perfectly! Thanks!

(Using "stable" 175.14.05)

Forrest
Could you tell me how do you configure your gpu to run at 100MHZ?. I have the same Nvidia 6150 Go and I don't know how to do it.

Thank you,

rfr22
rfr22 is offline   Reply With Quote
Old 10-08-08, 06:04 PM   #5
animesh
Registered User
 
Join Date: Oct 2008
Posts: 2
Default Re: PowerMizer configuration in NVIDIA Unix drivers

No this doesn't work. People have been spreading this wrong solution and it doesn't work for Ge 6150. Ge 6150 does not even support underclocking. I tried enabling Coolbits and it showed me the dummy page to change the settings.

But anyhow you change the setting, it jumps back to default as soon as you click "Apply". Is it sort of dummy page for show off?

Not sure, why Coolbits is enabled for 6150 when it does not work.

Another thing is that powermizer sets performance level to max. Even after the smart approach mentioned above it is not able to change.

My OS -> Kernel version 2.6.26 (Fedora)
Any solutions??

Temperature normally is 90 - 100 C on my system (idle / busy no matter what) but since threshold is 130 C I guess it will hold up for a couple of months before turning to pure ash
animesh is offline   Reply With Quote
Old 10-08-08, 06:15 PM   #6
animesh
Registered User
 
Join Date: Oct 2008
Posts: 2
Default Re: PowerMizer configuration in NVIDIA Unix drivers

Also at least please don't post wrong solutions. Copying and pasting has always been done by many people like this one

"Options". In xorg.conf there is no keyword Options. It's "Option".
If you have tried the solution on your system and it works then only post it. Don't put it by reading it from some other forum and pasting it here, it confuses a lot of people.
animesh is offline   Reply With Quote
Old 08-13-09, 03:30 AM   #7
unrandomsam
Registered User
 
Join Date: Jul 2006
Posts: 3
Default Re: PowerMizer configuration in NVIDIA Unix drivers

In the 190.x drivers there is a choice in nvidia-settings for this

(At least for my quadro 1600m - not sure if its its all cards or not however)
unrandomsam is offline   Reply With Quote
Old 10-28-09, 12:14 PM   #8
ildella
Registered User
 
Join Date: Feb 2008
Posts: 5
Unhappy Re: PowerMizer configuration in NVIDIA Unix drivers

I have a 8600M GT , bios 60.84.5e.00.08, running with latest 190 on ubuntu 9.10
same thing with latest 185. Machine is a Dell XPS M1530.

even if nvidia-settings say that ADaptative Clocking is enabled, the Performance Mode is always stucked to level 2, maximum performance

This means high clock voltage even if computer is doing "nothing" and temperature is always between 95-100 and fan is always making a lot of noise.

Given that adaptative mode is enabled, anyone has idea about why performance level is always 2?
ildella is offline   Reply With Quote

Old 10-28-09, 12:33 PM   #9
ildella
Registered User
 
Join Date: Feb 2008
Posts: 5
Default Re: PowerMizer configuration in NVIDIA Unix drivers

I have tried with options line:
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerDefault=0x2"

but nothing change. Maybe I am making errors with attribute names... this does not explain why adaptative mode run always at maximum level

here is a grep on nvidia-settings -q:

ildella@ildella-laptop:~$ nvidia-settings -q all | grep Perf
Attribute 'GPUCurrentPerfMode' (ildella-laptop:0.0): 1.
'GPUCurrentPerfMode' is an integer attribute.
'GPUCurrentPerfMode' is a read-only attribute.
'GPUCurrentPerfMode' can use the following target types: X Screen, GPU.
Attribute 'GPUCurrentPerfLevel' (ildella-laptop:0.0): 2.
'GPUCurrentPerfLevel' is an integer attribute.
'GPUCurrentPerfLevel' is a read-only attribute.
'GPUCurrentPerfLevel' can use the following target types: X Screen, GPU.
Attribute 'GPUPerfModes' (ildella-laptop:0.0): perf=0, nvclock=169, memclock=100 ; perf=1, nvclock=275, memclock=301 ; perf=2, nvclock=475, memclock=702
ildella@ildella-laptop:~$ nvidia-settings -q all | grep Power
Attribute 'GPUPowerSource' (ildella-laptop:0.0): 0.
'GPUPowerSource' is an integer attribute.
'GPUPowerSource' is a read-only attribute.
'GPUPowerSource' can use the following target types: X Screen, GPU.
ildella is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 01:57 AM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 12:39 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.