Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-20-09, 07:07 PM   #1
arvenil
Registered User
 
Join Date: Nov 2006
Posts: 5
Default vdpau some time ago worked now it doesn't want

I'm trying to make vdpau to work. It worked fine some long time ago (couple months, half year) but after some upgrades it stopped. I doesn't bother because I thought its a temporary problem which will be probably fixed in some new upgrades but it wasn't.

Right now I'm using newest nvidia driver (190.40), newest mplayer (svn29789) and I'm using newest libvdpau libraries (0.2). But I also tried before many different mplayer and nvidia versions also with vdpau included in nvidia packages. And ofcourse movie works with software code ffh264.

So here is an log from mplayer:
http://kamil.klecza.pl/nvidia/mplayer_vdpau.log

And nvidia-bug-report log:
http://kamil.klecza.pl/nvidia/nvidia-bug-report.log.gz

Test movie was from here:
http://www.dvdloc8.com/clip.php?movieid=13006&clipid=1
arvenil is offline   Reply With Quote
Old 10-21-09, 02:58 AM   #2
wantilles
Registered User
 
Join Date: Feb 2009
Posts: 37
Default Re: vdpau some time ago worked now it doesn't want

Quote:
Originally Posted by arvenil View Post
I'm trying to make vdpau to work. It worked fine some long time ago (couple months, half year) but after some upgrades it stopped. I doesn't bother because I thought its a temporary problem which will be probably fixed in some new upgrades but it wasn't.

Right now I'm using newest nvidia driver (190.40), newest mplayer (svn29789) and I'm using newest libvdpau libraries (0.2). But I also tried before many different mplayer and nvidia versions also with vdpau included in nvidia packages. And ofcourse movie works with software code ffh264.

So here is an log from mplayer:
http://kamil.klecza.pl/nvidia/mplayer_vdpau.log

And nvidia-bug-report log:
http://kamil.klecza.pl/nvidia/nvidia-bug-report.log.gz

Test movie was from here:
http://www.dvdloc8.com/clip.php?movieid=13006&clipid=1
It may not be nvidia's fault.

At mplayer svn 29777 they made some radical changes to their VDPAU code.

Try svn 29776.

It works.
wantilles is offline   Reply With Quote
Old 10-21-09, 04:16 AM   #3
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: vdpau some time ago worked now it doesn't want

Quote:
Originally Posted by arvenil View Post
So here is an log from mplayer:
http://kamil.klecza.pl/nvidia/mplayer_vdpau.log
Please test with -noconfig all and/or provide output of -v!
Code:
MPlayer On2-SVN-on2-r29789-4.4.1 (C) 2000-2009 MPlayer Team
Please test an unpatched version of MPlayer svn (and I recommend not to use gcc 4.4.1 although that is probably unrelated).

Your clip plays fine for me, Carl Eugen
cehoyos is offline   Reply With Quote
Old 10-21-09, 04:18 AM   #4
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: vdpau some time ago worked now it doesn't want

Quote:
Originally Posted by wantilles View Post
At mplayer svn 29777 they made some radical changes to their VDPAU code.
Apart from the fact that they were far from radical and do not change playback in 99% of all usage cases (whenever there is no pre-emption): Please report any problems with latest svn here or on mplayer-users!

Carl Eugen
cehoyos is offline   Reply With Quote
Old 10-21-09, 02:52 PM   #5
arvenil
Registered User
 
Join Date: Nov 2006
Posts: 5
Default Re: vdpau some time ago worked now it doesn't want

Quote:
Originally Posted by cehoyos View Post
Please test with -noconfig all and/or provide output of -v!
http://kamil.klecza.pl/nvidia/mplaye...noconfig_v.log

Unpatched version will be later but I remember I already tested with most patches disabled and got same error. But i will try again.
arvenil is offline   Reply With Quote
Old 10-21-09, 03:11 PM   #6
wantilles
Registered User
 
Join Date: Feb 2009
Posts: 37
Default Re: vdpau some time ago worked now it doesn't want

Quote:
Originally Posted by cehoyos View Post
Apart from the fact that they were far from radical and do not change playback in 99% of all usage cases (whenever there is no pre-emption): Please report any problems with latest svn here or on mplayer-users!
Build 29776 builds and works fine.

After that - I have tried builds 29777, 29779, 29786 - all do NOT build with the following error:

Code:
libavcodec/libavcodec.a(dsputil.o): In function `dsputil_init':
dsputil.c:(.text+0x122fc): undefined reference to `ff_lpc_compute_autocorr'
collect2: ld returned 1 exit status
make: *** [mplayer] Error 1
==> ERROR: Build Failed.
    Aborting...
CFLAGS and LDFLAGS are unset.

gcc is 4.4.0.

Distro is Archlinux amd64.



PS: Always using mplayer with smplayer 0.6.8 + latest SVN.
wantilles is offline   Reply With Quote
Old 10-21-09, 03:40 PM   #7
thefirstm
Registered User
 
Join Date: Feb 2009
Posts: 226
Default Re: vdpau some time ago worked now it doesn't want

Quote:
Originally Posted by cehoyos View Post
(and I recommend not to use gcc 4.4.1 although that is probably unrelated).
Just out of curiosity, why not? Which GCC version is recommended?
thefirstm is offline   Reply With Quote
Old 10-21-09, 04:21 PM   #8
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: vdpau some time ago worked now it doesn't want

Quote:
Originally Posted by arvenil View Post
It seems that my original suspicion (an incompatible video filter inserted) was wrong, but:
Quote:
Unpatched version will be later but I remember I already tested with most patches disabled and got same error. But i will try again.
Please understand that I am spending far to much time with MPlayer/FFmpeg. I really cannot understand how your error ("vf_get_image: Tried to allocate a format that can not be allocated!") can be triggered, but I will not investigate further.
Please download (or svn co) the latest version from mplayerhq.hu and configure with "./configure" (most options you use are not doing what you expect them to do). If the problem persists, I will have another look.

Thank you for your understanding, Carl Eugen
cehoyos is offline   Reply With Quote

Old 10-21-09, 04:23 PM   #9
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: vdpau some time ago worked now it doesn't want

Quote:
Originally Posted by wantilles View Post
Build 29776 builds and works fine.

After that - I have tried builds 29777, 29779, 29786 - all do NOT build with the following error:

Code:
libavcodec/libavcodec.a(dsputil.o): In function `dsputil_init':
dsputil.c:(.text+0x122fc): undefined reference to `ff_lpc_compute_autocorr'
collect2: ld returned 1 exit status
make: *** [mplayer] Error 1
==> ERROR: Build Failed.
    Aborting...
Note that the problem has nothing to do with the changes to MPlayer (but with a recent change in FFmpeg). Please do not use --disable-mencoder as a temporal work-around.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 10-21-09, 04:29 PM   #10
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: vdpau some time ago worked now it doesn't want

[about not using gcc 4.4.1]
Quote:
Originally Posted by thefirstm View Post
Just out of curiosity, why not? Which GCC version is recommended?
http://lists.mplayerhq.hu/pipermail/...ly/072707.html
And yes, I agree the reasons do not sound like a scientific proof, but since MPlayer's configure is missing -fno-tree-vectorize, I would at least not recommend gcc 4.4.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 10-21-09, 04:41 PM   #11
wantilles
Registered User
 
Join Date: Feb 2009
Posts: 37
Default Re: vdpau some time ago worked now it doesn't want

Quote:
Originally Posted by cehoyos View Post
Note that the problem has nothing to do with the changes to MPlayer (but with a recent change in FFmpeg). Please do not use --disable-mencoder as a temporal work-around.
Thank you for your input.

I was indeed using --disable-mencoder.

The reason for this was that I wanted to have separate mplayer and mencoder packages.

And to parallelize the building process since mplayer has to be built with make -j1.
wantilles is offline   Reply With Quote
Old 10-21-09, 04:49 PM   #12
arvenil
Registered User
 
Join Date: Nov 2006
Posts: 5
Default Re: vdpau some time ago worked now it doesn't want

Quote:
Originally Posted by cehoyos View Post
Please test an unpatched version of MPlayer svn
I droped all patches, removed all unnecessary configure options and everything else I could and... it works. Thanks for help and sorry for wasting your time:/ When I'll find out what was broken I will post here info but this could take some time.

One more time really thanks for help cehoyos.
arvenil is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:35 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.