Go Back   nV News Forums > Software Forums > General Software

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-24-09, 04:08 AM   #1
RaidenWoW
ಠ_ಠ
 
RaidenWoW's Avatar
 
Join Date: Dec 2007
Posts: 737
Default very weird. Browser going to wrong website.

when I try to go to http://www.facebook.com/ in google chrome and firefox AND internet explorer it takes me to this albania crap....

it's only facebook though, and it's only on this stupid computer.



I use my itouch to browse facebook.com from the same wireless router and it comes up just fine.

I've checked my hosts file and there's nothing there.

this is really confusing me. Anyone know if my computer is hijacked or something?
__________________
ヽ(`Д)ノ
[/eVGA 8800GTS 640mb OC630mhz eVGA 8800GTS G92 eVGA 9800GTX G92] Gigabyte Radeon 6870 | Q6600 @ 2.92ghz Zalman 9700 45c-55c | Crucial M4 64g | eVga 790i Ultra [/Asus Striker Extreme]
RaidenWoW is offline   Reply With Quote
Old 10-24-09, 04:53 AM   #2
MUYA
 
Join Date: Jul 2002
Location: Hong Kong
Posts: 6,794
Send a message via MSN to MUYA
Default Re: very weird. Browser going to wrong website.

oooh very suspicious that mate.

One thing would be to check the local host file usually by typing the following in run and checking etc...

notepad c:\windows\system32\drivers\etc\hosts


Others would be to check for malware etc
__________________
I5-2500k@4.7GHz - MSI Z77A-GD65 - 4GB X2 A-DATA DDR3 1600 - Corsair H100 - Antec Quatro 850W
Gigabyte Windforce X3 GTX 680 OC - Dell 24" IPS
Intel 320 300 GB SSD - 1 TB Hitachi HDD - 2x 250 GB WD HDD
Corsair K90 - Corsair Venegance 2000 Headset - Razer Naga Epic
Corsair 600T Case
MUYA is offline   Reply With Quote
Old 10-24-09, 09:35 AM   #3
ViN86
 
Join Date: Mar 2004
Posts: 15,486
Default Re: very weird. Browser going to wrong website.

Quote:
Originally Posted by RaidenWoW View Post
when I try to go to http://www.facebook.com/ in google chrome and firefox AND internet explorer it takes me to this albania crap....

it's only facebook though, and it's only on this stupid computer.



I use my itouch to browse facebook.com from the same wireless router and it comes up just fine.

I've checked my hosts file and there's nothing there.

this is really confusing me. Anyone know if my computer is hijacked or something?
Two potential problems.

1. Spyware - reads the address and redirects your browser to their site. They probably chose Facebook because it's popular.

2. Your DNS has an incorrect entry and facebook is resolving to the server your visiting.

Since it's only that browser and only that computer, my guess is it's number 1.

Quote:
Originally Posted by MUYA View Post
oooh very suspicious that mate.

One thing would be to check the local host file usually by typing the following in run and checking etc...

notepad c:\windows\system32\drivers\etc\hosts


Others would be to check for malware etc
Yes, as MUYA said, check the hosts file with a text editor and make sure there isn't an entry like "xxx.xxx.xxx.xxx www.facebook.com" where the x's are numbers as in an IP address.

Typically the only entries in your hosts file should be "127.0.0.1 localhost" and "::1 localhost", unless you have other hosts with static IP's you want to access without going through a DNS.
ViN86 is offline   Reply With Quote
Old 10-24-09, 09:59 AM   #4
General Lee
Guest
 
Posts: n/a
Default Re: very weird. Browser going to wrong website.

Yeah, it sounds like the browser is being redirected somehow, probably in the hosts file. I use the hosts file to keep the computer from connecting to sites blacklisted by Spybot.
  Reply With Quote
Old 10-24-09, 10:13 AM   #5
ViN86
 
Join Date: Mar 2004
Posts: 15,486
Default Re: very weird. Browser going to wrong website.

Here's the dig of OpenDNS. Looks like your command prompt is pinging/returning the correct address

Code:
; <<>> DiG 9.6.0 <<>> @208.67.222.222 facebook.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2538
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;facebook.com.			IN	A

;; ANSWER SECTION:
facebook.com.		3475	IN	A	69.63.181.11
facebook.com.		3475	IN	A	69.63.181.12
facebook.com.		3475	IN	A	69.63.187.19
facebook.com.		3475	IN	A	69.63.184.142
facebook.com.		3475	IN	A	69.63.187.17

;; Query time: 22 msec
;; SERVER: 208.67.222.222#53(208.67.222.222)
;; WHEN: Sat Oct 24 11:12:03 2009
;; MSG SIZE  rcvd: 110
Looks like you have spyware. Your DNS appears to be resolving the name just fine. I think this rules out the hosts file as well.
ViN86 is offline   Reply With Quote
Old 10-24-09, 12:36 PM   #6
RaidenWoW
ಠ_ಠ
 
RaidenWoW's Avatar
 
Join Date: Dec 2007
Posts: 737
Default Re: very weird. Browser going to wrong website.

Yeah I checked my hosts file with notepad. Ctl+f'd and no "facebook" found in it anywhere. It's really odd. I scanned with spybot search and destroy and also scanned with AVG free but nothing came up.
__________________
ヽ(`Д)ノ
[/eVGA 8800GTS 640mb OC630mhz eVGA 8800GTS G92 eVGA 9800GTX G92] Gigabyte Radeon 6870 | Q6600 @ 2.92ghz Zalman 9700 45c-55c | Crucial M4 64g | eVga 790i Ultra [/Asus Striker Extreme]
RaidenWoW is offline   Reply With Quote
Old 10-24-09, 02:37 PM   #7
Starscream
Decepticook
 
Starscream's Avatar
 
Join Date: Jul 2002
Location: Cybertron
Posts: 1,005
Default Re: very weird. Browser going to wrong website.

You've basically done nothing then.

At the very least run Malware Bytes anti-malware and smitfraudfix.
__________________
Maybe tomorrow I'll wanna settle down, until tomorrow I'll just keep moving on...
Starscream is offline   Reply With Quote
Old 10-25-09, 10:38 PM   #8
RaidenWoW
ಠ_ಠ
 
RaidenWoW's Avatar
 
Join Date: Dec 2007
Posts: 737
Default Re: very weird. Browser going to wrong website.

None of that was the problem.

I read somewhere to do ipconfig /flushdns

That worked for some reason. Can anyone tell me why? The other day it pointed to propeller.com instead of facebook. Lol.
__________________
ヽ(`Д)ノ
[/eVGA 8800GTS 640mb OC630mhz eVGA 8800GTS G92 eVGA 9800GTX G92] Gigabyte Radeon 6870 | Q6600 @ 2.92ghz Zalman 9700 45c-55c | Crucial M4 64g | eVga 790i Ultra [/Asus Striker Extreme]
RaidenWoW is offline   Reply With Quote

Old 10-26-09, 12:49 AM   #9
t3hl33td4rg0n
Dethklok Returns!
 
t3hl33td4rg0n's Avatar
 
Join Date: Dec 2004
Location: Kent, OH
Posts: 2,142
Send a message via AIM to t3hl33td4rg0n Send a message via MSN to t3hl33td4rg0n Send a message via Yahoo to t3hl33td4rg0n
Default Re: very weird. Browser going to wrong website.

Quote:
Originally Posted by RaidenWoW View Post
None of that was the problem.

I read somewhere to do ipconfig /flushdns

That worked for some reason. Can anyone tell me why? The other day it pointed to propeller.com instead of facebook. Lol.
Your DNS cache probably just got screwed up. I get customers calling in and I just tell them to do that.

Code:
ipconfig /flushdns
ipconfig /registerdns
Problem solved.
__________________


Intel QX9650 @ 3.83GHzXFX 780ieVGA GTX 560Ti8GB GSkill DDR800Creative Sound Blaster X-Fi Titanium PCI-ESeagate 1.5TB . 4x Samsung 2TB

Quote:
Originally Posted by MowTin View Post
....it's so clear how government makes things worse not better...
t3hl33td4rg0n is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.