Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-08-09, 01:31 PM   #1
kmoore134
Kris Moore
 
Join Date: May 2006
Posts: 19
Default Crash with 195.22

[ Solved below]

I'm trying out the latest beta 195.22 driver, and am experiencing an almost immediate hard-lock after bringing up X. This is on a 9800GT, but another of my systems with an older 6800 works fine. This hard-lock occurs anywhere from 1-15 seconds after x starts. I've tried running the nvidia-bug-report.sh script in that time, but something is that script causes it to lock up immediately, and I can't get a saved log file from it. Attached is a log from nvidia-bug-report.sh while using the "nv" driver, hopefully it'll still have enough info for you

BTW Running FreeBSD 8.0-Release, tried this on amd64 and i386 versions, doesn't make a difference. On this system the older drivers worked great on FreeBSD 7.x.
Attached Files
File Type: gz nvidia-bug-report.log.gz (16.7 KB, 117 views)

Last edited by kmoore134; 12-11-09 at 09:31 AM. Reason: [Solved]
kmoore134 is offline   Reply With Quote
Old 12-11-09, 09:30 AM   #2
kmoore134
Kris Moore
 
Join Date: May 2006
Posts: 19
Default Re: Crash with 195.22

Solved it here!

Turns out it the crash was caused by having powerd enabled in rc.conf:

powerd_enable="YES"
powerd_flags="-a adaptive -b adaptive" # set CPU frequency

As soon as I commented out those lines, the driver works like a champ again. Dual-head and everything
kmoore134 is offline   Reply With Quote
Old 12-20-09, 07:30 PM   #3
mlobo
Lobo
 
Join Date: Dec 2009
Location: Brasil
Posts: 10
Default Re: Crash with 195.22

I had an instability problem too.

AMD phenon 955 / FBSD 8-STABLE amd64
Nvidia 9800 GT

Even if I had powerd disabled, the system was still randomly unstable but
I wanted to keep powerd running to keep the CPU cool so I started to dig.

I noticed I had those 3 lines from sysctl:

-dev.cpu.0.freq_levels: 3200/28215 2800/24688 2500/18625 2187/16296 2100/12650
1837/11068 1575/9487 1312/7906
-dev.acpi_throttle.0.freq_settings: 10000/-1 8750/-1 7500/-1 6250/-1 5000/-1
3750/-1 2500/-1 1250/-1
-dev.hwpstate.0.freq_settings: 3200/28215 2500/18625 2100/12650 800/5070

with debug.cpufreq.lowest=1312 in sysctl.conf

The acpi_throttle list seemed weird because it only had weird frequencies.

I wanted to know which frequencies powerd uses. I got a hint from http://wiki.freebsd.org/TuningPowerConsumption on how to disable acpi_throttle (and overall power savers) and get it out of the way of powerd, so I added to loader.conf:

hw.pci.do_power_nodriver="3"
hint.acpi_throttle.0.disabled="1"
hint.pcm.0.buffersize="65536"
hw.snd.latency="7"

Then this showed up:

dev.cpu.0.freq_levels: 3200/28215 2500/18625 2100/12650
dev.hwpstate.0.freq_settings: 3200/28215 2500/18625 2100/12650 800/5070

So I found where powerd (dev.cpu.0) gets its frequency list from! a much more uniform list, so I set debug.cpufreq.lowest=800. Now it shows

dev.cpu.0.freq_levels: 3200/28215 2500/18625 2100/12650 800/5070
dev.hwpstate.0.freq_settings: 3200/28215 2500/18625 2100/12650 800/5070

800 is really low, so, so far I haven't seen the system drop to that but right now, the machine has been on for an hour (KDE4 w/OpenGL composite, e-mail, downloads, 2 VMs) and...

dev.cpu.0.temperature: 45.0C
dev.cpu.1.temperature: 45.0C
dev.cpu.2.temperature: 45.0C
dev.cpu.3.temperature: 45.0C
dev.amdtemp.0.%desc: AMD K8 Thermal Sensors
dev.amdtemp.0.%driver: amdtemp
dev.amdtemp.0.%parent: hostb4

Which is pretty cool for this CPU type. Plus, the lock-ups (openGL+VBox) are gone !
I still have to do the final test, which is to run a VM with 3D acceleration enabled.
This one always froze the machine, no matter what!
mlobo is offline   Reply With Quote
Old 12-21-09, 04:17 AM   #4
miwi
Registered User
 
Join Date: Dec 2009
Location: Germany
Posts: 7
Default Re: Crash with 195.22

Quote:
Originally Posted by mlobo View Post
I had an instability problem too.

AMD phenon 955 / FBSD 8-STABLE amd64
Nvidia 9800 GT

Even if I had powerd disabled, the system was still randomly unstable but
I wanted to keep powerd running to keep the CPU cool so I started to dig.

I noticed I had those 3 lines from sysctl:

-dev.cpu.0.freq_levels: 3200/28215 2800/24688 2500/18625 2187/16296 2100/12650
1837/11068 1575/9487 1312/7906
-dev.acpi_throttle.0.freq_settings: 10000/-1 8750/-1 7500/-1 6250/-1 5000/-1
3750/-1 2500/-1 1250/-1
-dev.hwpstate.0.freq_settings: 3200/28215 2500/18625 2100/12650 800/5070

with debug.cpufreq.lowest=1312 in sysctl.conf

The acpi_throttle list seemed weird because it only had weird frequencies.

I wanted to know which frequencies powerd uses. I got a hint from http://wiki.freebsd.org/TuningPowerConsumption on how to disable acpi_throttle (and overall power savers) and get it out of the way of powerd, so I added to loader.conf:

hw.pci.do_power_nodriver="3"
hint.acpi_throttle.0.disabled="1"
hint.pcm.0.buffersize="65536"
hw.snd.latency="7"

Then this showed up:

dev.cpu.0.freq_levels: 3200/28215 2500/18625 2100/12650
dev.hwpstate.0.freq_settings: 3200/28215 2500/18625 2100/12650 800/5070

So I found where powerd (dev.cpu.0) gets its frequency list from! a much more uniform list, so I set debug.cpufreq.lowest=800. Now it shows

dev.cpu.0.freq_levels: 3200/28215 2500/18625 2100/12650 800/5070
dev.hwpstate.0.freq_settings: 3200/28215 2500/18625 2100/12650 800/5070

800 is really low, so, so far I haven't seen the system drop to that but right now, the machine has been on for an hour (KDE4 w/OpenGL composite, e-mail, downloads, 2 VMs) and...

dev.cpu.0.temperature: 45.0C
dev.cpu.1.temperature: 45.0C
dev.cpu.2.temperature: 45.0C
dev.cpu.3.temperature: 45.0C
dev.amdtemp.0.%desc: AMD K8 Thermal Sensors
dev.amdtemp.0.%driver: amdtemp
dev.amdtemp.0.%parent: hostb4

Which is pretty cool for this CPU type. Plus, the lock-ups (openGL+VBox) are gone !
I still have to do the final test, which is to run a VM with 3D acceleration enabled.
This one always froze the machine, no matter what!
Hi,

I have exactly the same cpu with a ASUS M4a78T-E Board, and run in the same problem,
you need to be make a Bios update that solve the powerd problem. See also here

- Martin
miwi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.