Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-31-09, 09:39 AM   #1
yamane
Registered User
 
Join Date: Oct 2008
Posts: 30
Thumbs down Nvidia Driver - KDE is not smooth

Hi,

I have a NVS140M (Lenovo Thinkpad T61 - Intel Core2Duo T7500 - 2Gb RAM - SSD Intel X25M) running Debian Squeeze with KDE 4.3.1 with last stable driver (190.42)

I have some effects ON, such as "cube", "opaque window not in focus" and "unstable window when resize/move" (I really don't know the correct name in english).

And... KDE is not smooth (never was with nvidia driver).

Until to open K Menu is not smooth. Minimize/Maximize window is too slow, and CPU Load is too higher.

Anyone know what can I do?

# cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Tue Oct 20 21:00:15 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "synaptics"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection
yamane is offline   Reply With Quote
Old 11-01-09, 02:55 AM   #2
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Nvidia Driver - KDE is not smooth

Try to enable direct rendering and disable vsync.
kriko is offline   Reply With Quote
Old 11-01-09, 03:57 AM   #3
davelaser
Registered User
 
Join Date: Oct 2008
Posts: 86
Default Re: Nvidia Driver - KDE is not smooth

A problem that I had that might help:

The nvidia driver exports my refresh rate wrongly to xrandr, it reports a refresh rate of 50hz instead of 60hz. I'm not sure if this is a bug or just because nvidia only supports xrandr 1.1. This makes a lot of applications that autodetect the refresh rate in order to apply vsync or internal throttling quite jerky, including compiz. You can make compiz use a different frame rate by disabling detect refresh rate in general settings. Also enable vsync and set the refresh rate manually to exactly or twice your actual refresh rate.

HTH
Sam
davelaser is offline   Reply With Quote
Old 11-01-09, 07:15 AM   #4
wantilles
Registered User
 
Join Date: Feb 2009
Posts: 37
Default Re: Nvidia Driver - KDE is not smooth

You need a proper xorg.conf:

Code:
Section "ServerFlags"
	Option 		"AutoAddDevices" 		"False"
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"			"xorg"
	Option		"XkbModel"			"pc105"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"			"/dev/input/mice"
	Option		"Protocol"			"ExplorerPS/2"
	Option		"ZAxisMapping"			"4 5"
	Option		"Emulate3Buttons"		"true"
EndSection

Section "Monitor"
	Identifier	"My Monitor"
	Option		"DPMS" 				"True"
	Option 		"DPI"   			"96 x 96"
EndSection

Section "Device"
	Identifier	"My Graphics Card"
	Driver		"nvidia"
	VendorName	"NVIDIA Corporation"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"My Graphics Card"
	Monitor		"My Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		24
		Modes		"1280x1024"
		Viewport	0 0
	EndSubSection
	Option 		"DPI"   			"96 x 96"
	Option		"AddARGBGLXVisuals"		"true"
	Option 		"TripleBuffer" 			"true"
EndSection

Section "Extensions"
        Option      	"Composite"   			"enable"
EndSection
wantilles is offline   Reply With Quote
Old 11-01-09, 09:30 AM   #5
yamane
Registered User
 
Join Date: Oct 2008
Posts: 30
Thumbs down Re: Nvidia Driver - KDE is not smooth

Quote:
Originally Posted by kriko View Post
Try to enable direct rendering and disable vsync.
How can I do this?

I checked that Direct Rendering is already enabled:

$ glxinfo | grep -i rendering
direct rendering: Yes

I did some changes on my xorg.conf as wantilles tell (after enable "triple buffer" the performance improved a litle bit:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Tue Oct 20 21:00:15 PDT 2009


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"    
EndSection                                   

Section "Files"
EndSection     

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0" 
    Driver         "synaptics"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"  
EndSection                               

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"      
EndSection                    

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown" 
    ModelName      "Unknown" 
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"      
EndSection                     

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia" 
    VendorName     "NVIDIA Corporation"
EndSection                             

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "RenderAccel" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "TripleBuffer" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
yamane is offline   Reply With Quote
Old 11-01-09, 11:27 AM   #6
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Nvidia Driver - KDE is not smooth

No, those options inside systemsettings -> desktop -> desktop effects | advanced
kriko is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.