Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-30-07, 11:26 PM   #1
FuturePilot
Registered User
 
Join Date: Aug 2007
Posts: 35
Default Lots of video tearing

If anything fast moves on the screen such as a fast screensaver or something, I get lots of tearing and it looks really bad. Using the 100.14.11 driver with a GeForce 8400 GS. I have Sync to VBlank enabled for both OpenGL and XVideo but it doesn't seem to help any. Any ideas?
FuturePilot is offline   Reply With Quote
Old 09-01-07, 09:13 AM   #2
nordle
Registered User
 
nordle's Avatar
 
Join Date: Aug 2007
Posts: 3
Default Re: Lots of video tearing

FuturePilot:

I'm using a 6200 to run a 37" lcd via DVI-->HDMI on Slackware running mythtv on 2.6.22.5 with NVIDIA-Linux-x86-100.14.11

I have the same problem as you.

I've managed to improve things slightly, I think, by changing xorg.conf and changing the command I use to view a dvd.

Also, if you can get a copy, I found that Pixars Cars was absolutely perfect. I have yet to figure out if this is because its CGI and not a movie with people, or the type of dvd etc

Anyway:

Section "Module"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "type1"
Load "freetype"
Load "glx"
Load "i2c"
Load "int10"
Load "vbe"
Load "ddc"
EndSection


Section "Device"
Identifier "Device_TV"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "NvAGP" "1"
Option "NoLogo" "true"
Option "RenderAccel" "true"
Option "UseEDID" "true"
Option "UseEdidFreqs" "true"
Option "MultisampleCompatibility" "true"
Option "NoPowerConnectorCheck" "true"
Option "Coolbits" "1"
Option "TripleBuffer" "true"
Option "FlatPanelProperties" "Scaling = Scaled"
Option "BackingStore" "true"
Option "DamageEvents" "true"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Screen"
Identifier "Screen_TV"
Device "Device_TV"
Monitor "Monitor_TV"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "FlatPanelProperties" "Scaling = Scaled"
SubSection "Display"
Depth 24
Modes "1360x768" "1280x1024" "1280x720" "1024x768"
EndSubSection
EndSection



And the command I use to view a dvd is:

mplayer -dvd-device /dev/hdc -dvd-speed 8 -cache 8192 -alang en -vo xv -autoq 100 -fs -zoom -ontop -noborder -vf pp=ha:64:19/va:64:19/al,eq2=1:1.1:0:1:1:1:1:0,hue=0:1.3,pullup,crop=720 :432:0:72,dsize=720:400 dvd://what_ever_track_number_is_the_film

The eq2, hue, crop and dsize are probably not needed but I prefer the picture.
eq2 = contrast, brightness etc, hue=hue, crop/dsize ensure it fills the screen for me.

I have these nvidia-settings


#
# Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
# Generated on Fri Aug 31 00:10:14 2007
#

# ConfigProperties:

RcFileLocale = C
ToolTips = Yes
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = No
ShowQuitDialog = Yes

# Attributes:

0/DigitalVibrance[DFP-0]=7
0/ImageSharpening[DFP-0]=2
0/SyncToVBlank=1
0/AllowFlipping=0
0/LogAniso=0
0/FSAA=0
0/TextureSharpen=0
0/ForceGenericCpu=0
0/GammaCorrectedAALines=0
0/CursorShadow=0
0/CursorShadowXOffset=4
0/CursorShadowYOffset=2
0/CursorShadowAlpha=64
0/CursorShadowRed=0
0/CursorShadowGreen=0
0/CursorShadowBlue=0
0/FSAAAppControlled=1
0/LogAnisoAppControlled=1
0/GPUScaling[DFP-0]=65537
0/RedBrightness=-0.020029
0/GreenBrightness=-0.020029
0/BlueBrightness=-0.020029
0/RedContrast=-0.100000
0/GreenContrast=-0.100000
0/BlueContrast=-0.100000
0/RedGamma=0.920800
0/GreenGamma=0.920800
0/BlueGamma=0.920800
0/OpenGLImageSettings=0
0/XVideoTextureSyncToVBlank=1
0/XVideoBlitterSyncToVBlank=0
0/XVideoSyncToDisplay=65536
nordle is offline   Reply With Quote
Old 09-18-07, 04:16 AM   #3
lessthanjake
Registered User
 
Join Date: Aug 2007
Posts: 6
Default Re: Lots of video tearing

I have exactly tha same issue (with all video not just DVD)! The problem dissapears entirely if I turn of the Composite Extensions. But I would like to us it, and I would like to continue using Totem for all my video viewing, including DVDs.

Is this a known bug and is there a fix on it's way? Or is there a fully working workaround?

My card is a 7600GS and I'm using driver version 100.14.11 and Arch GNU/Linux.
lessthanjake is offline   Reply With Quote
Old 09-18-07, 09:03 AM   #4
theDOC
Registered User
 
Join Date: Jan 2004
Posts: 21
Default Re: Lots of video tearing

README
Quote:
The Composite extension also causes problems with other driver components:
...
On X.Org 7.1 and higher, the driver will properly redirect video into offscreen pixmaps. Note that the Xv adaptors will ignore the sync-to-vblank option when drawing into a redirected window.
Would be nice if this gets fixed someday...
theDOC is offline   Reply With Quote
Old 09-18-07, 11:29 AM   #5
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Lots of video tearing

Quote:
Would be nice if this gets fixed someday...
This needs to get fixed in the composite manager. Syncing to vblank when drawing into an offscreen buffer makes no sense. (This is what the driver did at first and it caused even worse tearing).
AaronP is offline   Reply With Quote
Old 09-18-07, 05:06 PM   #6
Tronic
Registered User
 
Join Date: Jul 2004
Posts: 35
Default Re: Lots of video tearing

I am getting this as well. If XVideo Sync to VBlank is enabled, the CPU usage of X goes to 100 % and everything (moving windows, writing this text, etc) gets very slow. Disabling the Sync to VBlank while the video is playing seems to be one way to make the X CPU usage drop to 6-15 % and enabling it again makes the CPU usage climb back to 100 %, but disabling it before starting MPlayer has no such effect (does MPlayer force that setting on, on startup?).

MPlayer's usage is always around 10 % (when watching 720p).

I had similar symptoms on this same system earlier, using a buggy motherboard BIOS version that would often run the graphics card at PCI-E 1x instead of 16x. In that situation nvidia-settings would show 1x and a reboot would fix the issue (then nvidia-settings displayed 16x). However, now only video (not OpenGL texture loading) is slow and nvidia-settings always displays PCI-E 16x.

http://delenn.homelinux.net/nvidia-bug-report.log
Tronic is offline   Reply With Quote
Old 09-25-07, 06:30 AM   #7
lessthanjake
Registered User
 
Join Date: Aug 2007
Posts: 6
Default Re: Lots of video tearing

Quote:
Originally Posted by AaronP
This needs to get fixed in the composite manager. Syncing to vblank when drawing into an offscreen buffer makes no sense. (This is what the driver did at first and it caused even worse tearing).
So, what you are saying is that this is an issue with all cards regardless of vendor and driver as long as the composite extension is enabled?

No matter where the fault is, this is a major bug rendering the composite extension completly useless.
lessthanjake is offline   Reply With Quote
Old 12-11-07, 09:22 AM   #8
gavro
Registered User
 
Join Date: Jan 2006
Posts: 3
Default Re: Lots of video tearing

*kick*

Is there already a fix for this problem? I have a Geforce 6800 (asus v9999), and only swithing off composite seems to fix the video tearing here.... And I would really want to make use of AIGLX in combination with compiz-fusion (and in the future perhaps KDE4)...

I've seem some replies on the board that some people get smooth playback with composite on... Is it possible and what do I have to do to get things working properly?? (I've already tried everything with [v]sync...)
gavro is offline   Reply With Quote

Old 12-16-07, 06:16 PM   #9
Melipone
Registered User
 
Join Date: Oct 2007
Posts: 4
Default Re: Lots of video tearing

I'm also experiencing some tearing when running Quake Wars at 60Hz with my 2x7900GTs in SLI...is the issue mentioned in this thread likely to be the cause? If so is there a workaround that is known?

Here is a link to a post of my problem, c+p below

http://community.enemyterritory.com/...ad.php?t=19405

================================================== =====

When running ETQW in Ubuntu, I get a horizontal line "ripple" effect which moves up the screen. This only occurs while I'm in motion/mouselooking, and only when at 60fps - which unfortunately is the refresh rate I get the optimum performance at! It still occurs even when I turn all graphical settings (in the settings section of the GUI) down to minimum, so I think it's a configuration issue rather than lack of graphical capability. I have tried enabling VSync in the game settings, and also turning on "Sync to VBlank" in OpenGL Settings in nvidia-settings but neither fixes the issue. My monitor runs at 60Hz.

When I set com_unlock_timingMethod=2, the problem doesn't occur at com_unlock_maxFPS = 30 or 90 (which I can manage comfortably, when at mimimum settings), but only at 60! My preferred setting is to have VSync on as it cuts down tearing. I have ETQW in Windows XP on this same machine with VSync on and that runs at decent graphics settings without a problem.

I did all my testing in offline games vs the computer with no bots. Can anyone think of any way to remove this? I'm stuck, and would rather be playing a penguin friendly version of the game

Ubuntu 7.10 64 bit - kernel 2.6.22-14-rt
Opteron 185 @ 3.12 GHz (dual core)
2GB Ram
2x7900GT in SLI
1680x1050 @ 65.1Hz/59.8Hz (according to my monitor's diagnostic - set to 60Hz in nvidia-settings)
Video Drivers: 100.14.11 (current)
Run with desktop effects switched off.
Melipone is offline   Reply With Quote
Old 04-08-08, 06:37 PM   #10
nordle
Registered User
 
nordle's Avatar
 
Join Date: Aug 2007
Posts: 3
Default Re: Lots of video tearing

Hellooo, me again. Managed to completely remove the tearing issue by dropping the lcd refresh rate incrementally from 60Hz, got down to 54Hz and during the fast action there is no no tearing at all.

Removing any vblank sync on nvidia driver completely removed the jerky video too. No tears, smooth video playback. Brilliant.

It doesn't officially class as HD, the standard being 60Hz, but so far this has not stopped any content being played....ie thinking of issue over hdcp etc

But running Linux means unlikely to be able to run BluRay anyway given drm issues etc.

xorg.conf:

EDIT: scrap that previous version, 1920x1080@54 offers much better picture for SD on this LCD than 1360x768@54



Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen_TV" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/misc/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
EndSection

Section "Module"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "type1"
Load "freetype"
Load "glx"
Load "i2c"
Load "vbe"
Load "ddc"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc104"
Option "XkbLayout" "gb"
EndSection

Section "Monitor"
Identifier "Monitor_TV"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 80.0
VertRefresh 50.0 - 75.0
Modeline "1920x1080@50" 142.52 1920 1952 2472 2504 1080 1103 1111 1135
Modeline "1360x768@54" 73.98 1360 1392 1664 1696 768 784 791 807
Modeline "1280x720@54" 64.73 1280 1312 1544 1576 720 735 741 757
EndSection

Section "Device"
Identifier "Device_TV"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "NvAGP" "1"
Option "NoLogo" "true"
Option "RenderAccel" "true"
Option "XvmcUsesTextures" "true"
Option "MultisampleCompatibility" "true"
Option "NoPowerConnectorCheck" "true"
Option "Coolbits" "1"
Option "DamageEvents" "true"
Option "IgnoreDisplayDevices" "CRT, TV"
Option "ConnectedMonitor" "DFP"
Option "AllowDDCCI" "false"
Option "FlatPanelProperties" "Scaling = Native"
Option "UseEvents" "true"
Option "ExactModeTimingsDVI" "true"
Option "ModeValidation" "AllowNon60HzDFPModes, NoVesaModes, NoPredefinedModes, NoDFPNativeResolutionCheck, NoVertRefreshCheck, NoHorizSyncCheck, NoVertRefreshCheck, NoEdidModes, NoXServerModes, AllowInterlacedModes"
Option "ConnectToAcpid" "false"
Option "UseEDID" "false"
Option "DPI" "62 x 62"
EndSection

Section "Screen"
Identifier "Screen_TV"
Device "Device_TV"
Monitor "Monitor_TV"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1920x1080@50"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection





# /home/mythtv/.nvidia-settings-rc
#
# Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
# Generated on Tue Apr 8 23:25:30 2008
#

# ConfigProperties:

RcFileLocale = C
ToolTips = Yes
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = No
ShowQuitDialog = Yes
Timer = PowerMizer_Monitor_(GPU_0),Yes,1000
Timer = Thermal_Monitor_(GPU_0),Yes,1000

# Attributes:

0/DigitalVibrance[DFP-0]=7
0/ImageSharpening[DFP-0]=3
0/SyncToVBlank=0
0/AllowFlipping=0
0/LogAniso=0
0/FSAA=0
0/TextureSharpen=0
0/ForceGenericCpu=0
0/GammaCorrectedAALines=0
0/CursorShadow=0
0/CursorShadowXOffset=4
0/CursorShadowYOffset=2
0/CursorShadowAlpha=64
0/CursorShadowRed=0
0/CursorShadowGreen=0
0/CursorShadowBlue=0
0/FSAAAppControlled=1
0/LogAnisoAppControlled=1
0/GPUScaling[DFP-0]=65537
0/RedBrightness=-0.001111
0/GreenBrightness=-0.001111
0/BlueBrightness=-0.001111
0/RedContrast=0.304000
0/GreenContrast=0.304000
0/BlueContrast=0.304000
0/RedGamma=0.915378
0/GreenGamma=0.915378
0/BlueGamma=0.915378
0/OpenGLImageSettings=0
0/XVideoOverlaySaturation=4810
0/XVideoOverlayContrast=3815
0/XVideoOverlayBrightness=-4
0/XVideoOverlayHue=1
0/XVideoTextureSyncToVBlank=0
0/XVideoBlitterSyncToVBlank=0
0/XVideoSyncToDisplay=65536




xine called via another script:
#!/bin/sh
/usr/bin/nvidia-settings -l && \
/usr/local/bin/xine \
-V xv \
-A alsa \
-G 1920x1080 \
-pfhq \
-l=repeat \
--no-splash \
--no-logo \
--post eq2=1.0:1.0:0.0:1.0:1.0:1.0:1.0:1.0 \
-r anamorphic \
dvd://


ditto with mplayer:
#!/bin/sh
/usr/bin/nvidia-settings -l && \
/usr/local/bin/mplayer \
-dvd-device /dev/hdc \
-dvd-speed 12 \
-cache 8192 \
-cache-min 15 \
-alang en \
-fs \
-zoom \
-x 1920 \
-y 1080 \
-ontop \
-vsync \
-vo xv \
-vf \
eq2=1.0:1.0:0.0:1.0:1.0:1.0:1.0:1.0,\
hue=-10.0:0.9 \
dvd://`/home/mythtv/.bin/./longest_dvd_track.sh`



longest_dvd_track.sh is:

#!/bin/sh
lsdvd /dev/hdc | grep Longest | while read L; do L2=${L#'Longest track: '} && echo $L2; done

Last edited by nordle; 04-09-08 at 07:23 PM.
nordle is offline   Reply With Quote
Old 08-02-08, 07:45 AM   #11
lfsrteixeira
Registered User
 
Join Date: Mar 2007
Posts: 1
Default Re: Lots of video tearing

My solution to the problem:

1) install compizconfig-settings-manager (using apt, synaptic, anything you like...)

2) Run CompizConfig Settings Manager (it should be installed in the System > Preferences menu)

3) Select "General Options", then tab "Display Settings".

4) Make sure "Sync to VBlank" is checked.

5) If you have made any changes in "NVIDIA X Server Settings" regarding "Sync to VBlank", I think these can be undone.

I'm using ubuntu 8.04.
lfsrteixeira is offline   Reply With Quote
Old 02-07-11, 01:20 PM   #12
qrystalballer
Registered User
 
Join Date: Feb 2011
Posts: 1
Smile Re: Lots of video tearing

I know this post is 4 years old, but I just had to create a user account to thank to **lfsrteixeira** for the tip on sync to vblank in compizconfig-settings-manager (on both of my displays).

For any others interested, my setup is ubuntu 10.10, running on an intel classic series motherboard (DP965LT) and a Core 2 Duo 3.16 GHz dual core processor. The graphics card is a nVidia 8600GTS running dual output (separte Xscreens) to a LG Flatron W2052TQ (via DVI) and a Sony Bravia 32" 720 LCD TV (via DVI to HDMI).
qrystalballer is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
IOGEAR 3D Complete+ 4-Port HDMI Switcher with 2D/3D Video Processor News Archived News Items 0 06-28-12 06:40 PM
Video: Towards Energy Efficiency Exascale Computing News Archived News Items 0 06-25-12 08:20 AM
Vivid Sydney in 3D, 2012 ' High Definition 3D Timelapse Video News Archived News Items 1 06-23-12 01:47 PM
GoPro 3D HERO System: Mounting Tips Official GoPro Video News Archived News Items 0 05-13-12 06:20 PM
Best video card for running dual displays? nutsnbolts NVIDIA GeForce 7, 8, And 9 Series 10 09-03-02 03:02 PM

All times are GMT -5. The time now is 10:56 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.