Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-30-09, 10:03 AM   #13
Benni1233444
Registered User
 
Join Date: Oct 2009
Posts: 17
Default Re: error with vdpau and svn-mplayer

With smplayer, I still can't view the film. When viewing it with smplayer, the screen still flickers and then freezes.

If I want to view the film with smplayer, I have to disable compositing. Then I can watch. And even with debug variables on, I don't see any kind of errors.

So it seems that this is a problem with vdpau, glx and compositing.
Benni1233444 is offline   Reply With Quote
Old 11-30-09, 11:57 AM   #14
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: error with vdpau and svn-mplayer

a) Can you please produce a debug log with just VDPAU_NVIDIA_DEBUG=3 set; please don't set VDPAU_TRACE.

b) I think you said this happens on just a single H.264 video, and not all videos? If so, please can you upload that video to our file drop (see VDPAU sticky post in this forum). I see you were going to do this but didn't know how to shorten the file. The following command should do it:

dd if=your_video_file of=your_video_file_short_version bs=1024000 count=100

That should produce a 100M file.
Stephen Warren is offline   Reply With Quote
Old 11-30-09, 12:00 PM   #15
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: error with vdpau and svn-mplayer

Could you please also try 195.22. Thanks.
Stephen Warren is offline   Reply With Quote
Old 11-30-09, 12:26 PM   #16
Benni1233444
Registered User
 
Join Date: Oct 2009
Posts: 17
Default Re: error with vdpau and svn-mplayer

With compositing disabled in kde and the new driver 195.22, I'm getting just:

Quote:
VDPAU_NVIDIA_DEBUG=3
Laptop ~ # mplayer -vo vdpau -vc ffh264 /Files/Filme/2001-Space_Odyssey.mkv
MPlayer 29972-4.3.4 (C) 2000-2009 MPlayer Team

Spiele /Files/Filme/2001-Space_Odyssey.mkv.
[mkv] Track-ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track-ID 2: audio (A_AC3) "DD 5.1/384Kbps", -aid 0, -alang ger
[mkv] Track-ID 3: audio (A_AC3) "DD 5.1/384Kbps", -aid 1, -alang eng
[mkv] Track-ID 4: subtitles (S_TEXT/UTF8), -sid 0, -slang eng
[mkv] Track-ID 5: subtitles (S_TEXT/UTF8), -sid 1, -slang dut
[mkv] Werde Video-Track 1 abspielen.
Matroska-Dateiformat erkannt!
VIDEO: [avc1] 1920x864 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
================================================== ========================
Erzwungener Videocodec: ffh264
Öffne Videodecoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat -1
Ausgewählter Videocodec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
================================================== ========================
================================================== ========================
Öffne Audiodecoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Ausgewählter Audiocodec: [a52] afm: liba52 (AC3-liba52)
================================================== ========================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starte Wiedergabe...
Film-Aspekt ist 2.22:1 - Vorskalierung zur Korrektur der Seitenverhältnisse.
VO: [vdpau] 1920x864 => 1920x864 Planar YV12
A: 213.6 V: 213.6 A-V: -0.003 ct: -0.205 0/ 0 53% 11% 1.9% 0 0
Beenden... (Ende)
And I even can watch the film in smplayer without any errors.

When I enable compositing, I also can watch the film with the same errors by starting mplayer directly. Yet when I want to use smplayer, which starts mplayer with the following options:

Quote:
-noquiet -nofs -nomouseinput -vc ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau, -lavdopts threads=2 -sub-fuzziness 1 -identify -msglevel demux=6 -slave -vo vdpau -ao alsa -nokeepaspect -dr -double -input conf=/usr/share/smplayer/input.conf -stop-xscreensaver -wid 4194319 -monitorpixelaspect 1 -noass -subfont-autoscale 1 -subfont-text-scale 5 -subcp enca:de:ISO-8859-15 -subcc -vid 0 -aid 0 -subpos 100 -cache 10000 -ss 721 -vf-add screenshot -vf-clr -noslices -channels 2 -nojoystick /Files/Filme/2001-Space_Odyssey.mkv
the screen flickers and freezes. Unfortunately, I can't provide a log for this.

This happens only when compositing is enabled in KDE-4.3.
Benni1233444 is offline   Reply With Quote
Old 11-30-09, 12:36 PM   #17
Benni1233444
Registered User
 
Join Date: Oct 2009
Posts: 17
Default Re: error with vdpau and svn-mplayer

I have uploaded it. The name is shortversion.mkv.
Since I see that the upload was fast, I think I can even send you the entire film if you want. Since in mplayer, the short version flickers somwhat because of the cut.
Benni1233444 is offline   Reply With Quote
Old 11-30-09, 01:20 PM   #18
Benni1233444
Registered User
 
Join Date: Oct 2009
Posts: 17
Default Re: error with vdpau and svn-mplayer

Dear Nvidia developers,
I now have uploaded the entire 8GB film to your ftp, since the short version had image problems.
To see the bug, get a Thinkpad T61 or a Thinkpad with a Quadro NVS 140M graphics card. Enable composite in Xorg and in Kde-4.3. Use the most recent nvidia-195.22 driver and the svn version of mplayer.

Then watch the film with the vdpau driver in an mplayer gui called smplayer http://smplayer.sourceforge.net/ .

The gui smplayer will start mplayer with the necessary options that will make the nvidia-driver crash.

After some flickering, the screen will freeze immediately. If one tries to capture some logs, they will be replaced by just random files from your harddrive after restart.

Thank you for interest in that bug. I hope you at nvidia will fix it some time.

With Best wishes

Last edited by Benni1233444; 11-30-09 at 01:21 PM. Reason: spelling corrections
Benni1233444 is offline   Reply With Quote
Old 12-01-09, 01:48 PM   #19
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: error with vdpau and svn-mplayer

How far into the film does the problem occur; within seconds of starting playback, some longer time, or some random time?

I attempted a repro using a desktop system with very similar graphics card, but could not.

Do you have the ability to set up a serial console or network console to capture any kernel messages when the hang occurs?
Stephen Warren is offline   Reply With Quote
Old 12-01-09, 02:51 PM   #20
Benni1233444
Registered User
 
Join Date: Oct 2009
Posts: 17
Default Re: error with vdpau and svn-mplayer

The errors start immediately when I open the film.


The problem is, that when I try to capture the console output with some program, e.g with tee, after the restart, the logfile will only contain some random bits from my harddrive and not the console output.

The screen freezes completely after the film was opened. I can not even use the mouse or the keyboard. The entire system does not react. Only restarting with the power-off button helps.

At the moment, I'm compiling Kde-4.3.4 on my gentoo system. Kde4.3.4 should fix some graphics bugs from 4.3.3.
I will test if I can render the film with compositing on in Kde-4.3.4.

Last edited by Benni1233444; 12-01-09 at 02:56 PM. Reason: Add some text
Benni1233444 is offline   Reply With Quote

Old 12-01-09, 08:04 PM   #21
Benni1233444
Registered User
 
Join Date: Oct 2009
Posts: 17
Default Re: error with vdpau and svn-mplayer

Attached to this post is a Kernel-log from syslogd. It begins with the startup of my laptop. During operation, I started smplayer with composite on and tried to watch the film under KDE-4.3.4. The screen flickered, became green, and then It was frozen. The log ends with the message that the computer is restarted.

However, nothing about the bug and the graphics card problems seem to be written in the kernel log itself.

What I could do:
If you want, I could photograph the screen with my digital camera when it gets frozen. Then I could attach the photo to an nvnews forum post. However, I do not see what could be learned from the photo of a laptop that shows erratic green colors all over its display...
Attached Files
File Type: txt kernellog.txt (74.3 KB, 122 views)
Benni1233444 is offline   Reply With Quote
Old 01-02-10, 10:47 AM   #22
Benni1233444
Registered User
 
Join Date: Oct 2009
Posts: 17
Default Re: error with vdpau and svn-mplayer

Dear nvidia developers, thank you for considering this bug.

With the new driver 195.30 I can watch the film in smplayer with composite enabled in KDE-4.3.

However, the bug still seems not to be completely fixed.

Since when I try to resize the smplayer window (even if it is resized only a little bit, e.g. five millimeters or so), the screen still gets completely locked. The only action that is then possible is to restart the computer. It won't react to any other user input.

With compositing disabled in KDE, I can view the film and resize the smplayer window without any problems.


The system and the settings are the same as above (Thinkpad T61, Quadro NVS 140M, 512 MB Video Ram, 2GB swap space, 2GB Ram, Gentoo Linux 64 bit), the smplayer settings are also the same.
Just the driver version has changed to 195.30.

Well, I think one can say that at least some progress has been made. When the smplayer window is not resized, the film can be displayed.
Benni1233444 is offline   Reply With Quote
Old 03-30-10, 01:37 PM   #23
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: error with vdpau and svn-mplayer

Benni1233444, are you still seeing this problem? I'm afraid that we haven't been able to reproduce the problem at all, despite trying a variety of configurations very similar to yours.

If you're still having the problem, could you try the latest driver (195.36.15) Whilst there have been no specific fixes for your issue, it's possible that some other fix solved your issue.

Thanks.
Stephen Warren is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.