Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-30-09, 04:46 PM   #1
dillzz
Registered User
 
Join Date: Dec 2008
Posts: 55
Default vdpau issues (Canon HF20)

Hoping someone can shed some light.

I just bought a Canon HF20 this weekend which shoots tremendous looking video. The format is the AVCHD with MXP 24mbps. I can stream straight to PS3 via mediatomb and it looks great. I cannot however for the life of me get this to view in linux. I have tried mplayer, vlc, etc. The below command runs, but things are horribly choppy and cpu gets crushed.

mplayer -fps 60 -ao sdl -vo vdpau -demuxer lavf -ni -vc ffh264vdpau /media/data/Incoming/Canon\ Test/00000.mt

Not starting a war here, but I dual boot win 7 x86_64 and I rebooted and the videos run great with no hit to CPU. What am I doing wrong and can someone shed some light on what I may be missing. . . Thank you


SPECS:
Ubuntu 9.10 x86_64
Intel q9450
8gig ram
nvidia 9600gt
matrox triple head to go with (3) dell 2408wfp 24"
nvidia-glx-190
nvidia-190-libvdpau
Driver rev: 190.42
dillzz is offline   Reply With Quote
Old 11-30-09, 05:35 PM   #2
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: vdpau issues (Canon HF20)

Quote:
Originally Posted by dillzz View Post
mplayer -fps 60 -ao sdl -vo vdpau -demuxer lavf -ni -vc ffh264vdpau /media/data/Incoming/Canon\ Test/00000.mt

Not starting a war here, but I dual boot win 7 x86_64 and I rebooted and the videos run great with no hit to CPU. What am I doing wrong and can someone shed some light on what I may be missing
Very difficult without:
An explanation what goes wrong (At least I - not being a native speaker - don't understand "CPU gets crushed")
A sample
Complete, uncut output of your MPlayer call (fps and ni have no effect in your command line, ao sdl is not recommended)

If your sample is really 1920p60, it will not play with current VDPAU hardware (without -lavdopts skipframe=nonref), if it is a PAFF sample, you need -nocorrect-pts (and possibly -delay -0.3 or similar).

Carl Eugen
cehoyos is offline   Reply With Quote
Old 11-30-09, 05:43 PM   #3
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: vdpau issues (Canon HF20)

Quote:
Originally Posted by cehoyos View Post
Very difficult without:
An explanation what goes wrong (At least I - not being a native speaker - don't understand "CPU gets crushed")
A sample
Complete, uncut output of your MPlayer call (fps and ni have no effect in your command line, ao sdl is not recommended)

If your sample is really 1920p60, it will not play with current VDPAU hardware (without -lavdopts skipframe=nonref), if it is a PAFF sample, you need -nocorrect-pts (and possibly -delay -0.3 or similar).
The HF20 records at 60i not 60p.

The term "CPU gets crushed" means he sees high CPU usage.
mooninite is offline   Reply With Quote
Old 11-30-09, 06:21 PM   #4
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: vdpau issues (Canon HF20)

Quote:
Originally Posted by mooninite View Post
The HF20 records at 60i not 60p.
Then all (?) Nvidia VDPAU cards are able to decode it with minimal CPU usage.
Quote:
The term "CPU gets crushed" means he sees high CPU usage.
Yes, I get that, but it still is not a helpful description of what does not work.

Carl Eugen

Last edited by cehoyos; 12-01-09 at 03:35 AM. Reason: Fix typos
cehoyos is offline   Reply With Quote
Old 11-30-09, 08:25 PM   #5
dillzz
Registered User
 
Join Date: Dec 2008
Posts: 55
Default Re: vdpau issues (Canon HF20)

Sorry if I was unclear earlier. By CPU getting crushed, I mean - viewing a video jumps one of my cores to nearly 100 percent, should not be happening. I added the following to ~/.mplayer/config

# Write your default config options here!
vc=ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpa u,coreavc,dummy,
#vo=vdpau
vo=vdpau:deint=2,gl:yuv=2:force-pbo,xv,
fps=60
ao=alsa
#framedrop=1

The audio setting to alsa seemed to help a lot. Still this seems archaic for having to view a video. Audio/video still seem to be out of sync and picture is not as clear as native PS3/Windows viewing. . .

Any ideas on if we can edit this without having to decode it to something less compressed. I did read about kdenlive and vdpau to support editing avchd, didn't know if there was any progress. . .

Thank you for the responses.
dillzz is offline   Reply With Quote
Old 11-30-09, 09:08 PM   #6
uau
Registered User
 
Join Date: Sep 2009
Posts: 45
Default Re: vdpau issues (Canon HF20)

Where are you getting all those random command line and config file options from? Many of the ones mentioned in this thread make very little sense.

First, when testing don't use the lists of fallback options - it's better to test one thing at a time and possible fallback to something else only confuses matters.

Having "fps=60" in the config file by default, affecting all videos, makes no sense at all. It's rarely useful for any single video either. Specifying "vo=vdpau:deint=2" also activates deinterlacing by default - not a good idea if you also play progressive videos (maybe it'd be worth changing MPlayer to add syntax to specify the default deinterlace mode without activating it).

The sdl audio output is little used or tested, so it may have problems. Where did you get that from too?

If your content uses PAFF (at least some other avchd samples I've seen do) then you should try compiling MPlayer from the git repo (easiest done using 'git clone git://repo.or.cz/mplayer-build.git', then follow the README). The current git version has better timing code that should handle PAFF videos correctly if you use -demuxer lavf, and it also has an improved VDPAU driver. I think your 9600 GT should be able to handle deinterlacing modes higher than 2; with the git VDPAU driver I can use deint=4 without problems on my 9500 GT.
uau is offline   Reply With Quote
Old 12-01-09, 03:30 AM   #7
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: vdpau issues (Canon HF20)

Quote:
Originally Posted by dillzz View Post
I added the following to ~/.mplayer/config
Please try
rm ~/.mplayer/config
mplayer -demuxer lavf -nocorrect-pts -vo vdpau -vc ffh264vdpau

If it does not work as expected, please post full, uncut output here and upload the sample to ftp://ffmpeg.org/MPlayer/incoming (write-only, don't forget to post the filename here).

Carl Eugen
cehoyos is offline   Reply With Quote
Old 12-03-09, 04:49 PM   #8
dillzz
Registered User
 
Join Date: Dec 2008
Posts: 55
Default Re: vdpau issues (Canon HF20)

cehoyos,

Thanks for the information. That seemed to work, I still had to add the -ao alsa in order to get sound. It still looks grainy. I tried to set it to -vo vdpau:deint 4 and slows things down again.

CPU doesn't go above 8% so that is good. Any other tips?
dillzz is offline   Reply With Quote

Old 12-03-09, 07:48 PM   #9
uau
Registered User
 
Join Date: Sep 2009
Posts: 45
Default Re: vdpau issues (Canon HF20)

Which MPlayer version are you using? Try compiling the latest code from git as described above if you didn't already. It should work without using -nocorrect-pts (that workaround is a hack which never gives quite correct results) and has significantly better performance with deint=4.
uau is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.