Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-06-09, 02:05 PM   #1
Mad Merlin
Registered User
 
Join Date: Dec 2009
Posts: 3
Default Frequent X crashes with 190.* and 185.*

I've been using KDE 4 for awhile now, but initially with 180.60, and that was quite stable, I didn't experience any crashes with that setup. I was using KDE 3 before that, and never had any crashes there, but I don't recall if I ever used drivers newer than 180.60 there, so it's of little relevance here.

Anyways, at one point I tried upgrading to 185.18.36, and that was crashing very frequently for me, often several times a day. In those cases, normally I'd switch window focus with alt-tab or by clicking, and then X would just suddenly crash and bring me back to kdm. Beyond that there did not seem to be anything in common between crashes, it didn't matter what windows/applications were involved. Quickly tiring of the crashes, I went back to 180.60 and all was stable again.

More recently, I've started using 190.42, and the crashes are back, although they're not quite the same as they were with 185.18.36. In this latest case, I was browsing a web page with Konqueror, and then I opened up kwrite and all of the sudden both displays started flickering off and then back on every few seconds. After flickering about a dozen times, I started moving my mouse around to see if X was completely wedged or if it was still usable (it did not seem usable, the cursor moved but did not change as it moused over different things), almost immediately afterwards X crashed and brought me back to kdm. The flickering screens before crashing thus far is unique to 190.42 and was not present in the 185.18.36 crashes, and all of the crashes I've seen with 190.42 have involved said flickering screens. Again, the particular user actions which provoke the crash do not seem to have much in common.

Unfortunately, I do not have a deterministic way to reproduce this, but I'm pretty much guaranteed to see a crash at least a few times a week with either 185.* or 190.*. It's worth mentioning again that my system was completely stable with 180.60 (but it doesn't support newer kernels, or, IIRC xorg-server 1.7).

My hardware details appear to be present in quite gory detail in the attachment, so I won't bother reiterating them here.
Attached Files
File Type: gz nvidia-bug-report.log.gz (45.0 KB, 80 views)
Mad Merlin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:44 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.