Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-03-09, 05:13 AM   #1
Sirsurthur
Registered User
 
Join Date: Oct 2009
Posts: 6
Default Geforce 6800 LE / nvidia 185.18.36-1 and artefacts - need help

Hello everybody,

First exuse me if that point was already solved in a topic I didn't found yet. Few points of my configuration :
- Geforce 6800 LE
- Kernel 2.6.30 on Archlinux
- Nvidia drivers 185.18.36
- Xorg-server 1.6.3.901
- Xorg 7.4

My graphic card was well supported before but since I updated to the new drivers I have huge artefacts on screen and unstability (flickers a lot on demanding apps). A picture is better than a thousand words so see here : http://tinypic.com/r/2nk8jl3/4
My xorg didn't changed but you can also see it here : http://shorttext.com/08fhr78el
I also tried with nvidia-beta drivers (190.) but results is currently the same.

I really need help because I didn't find any solution yet or even the causes to these artefacts. All advices are consequently welcome. Let me know if you need some more informations on my configuration.

Thanks a lot for your help,

Sirsurthur
Sirsurthur is offline   Reply With Quote
Old 10-05-09, 11:16 AM   #2
Sirsurthur
Registered User
 
Join Date: Oct 2009
Posts: 6
Default Re: Geforce 6800 LE / nvidia 185.18.36-1 and artefacts - need help

For information this problem does not occur with "nv driver".

Sirsurthur
Sirsurthur is offline   Reply With Quote
Old 10-31-09, 01:52 PM   #3
Sirsurthur
Registered User
 
Join Date: Oct 2009
Posts: 6
Default Re: Geforce 6800 LE / nvidia 185.18.36-1 and artefacts - need help

This problem still occurs with :
Geforce 6800 LE
xorg-server 1.7
nvidia 190.42
xorg 7.6

Nvidia developpers, any comments on this issue ?
Thanks for your help,
Sirsurthur
Sirsurthur is offline   Reply With Quote
Old 11-01-09, 01:23 AM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Geforce 6800 LE / nvidia 185.18.36-1 and artefacts - need help

This looks a lot like your graphics card is malfunctioning. Do you have a different card you can try?
AaronP is offline   Reply With Quote
Old 11-01-09, 05:56 AM   #5
Sirsurthur
Registered User
 
Join Date: Oct 2009
Posts: 6
Default Re: Geforce 6800 LE / nvidia 185.18.36-1 and artefacts - need help

No sadly I do not have any other card to try. I am just a little bit surprised because this old card still works well with nv or nouveau drivers. I first saw that behaviour with the nvidia 180.* drivers. Before that update, nvidia drivers worked just perfectly on my old card. Is there still a possibility that this behaviour comes from something new (since the 180.* drivers) in the nvidia driver or do you think it has to be a malfunctioning ? Is there a way I could provide you some log files to help answering that question ?

Thanks a lot for having answered to my previous post.

Sirsurthur
Sirsurthur is offline   Reply With Quote
Old 11-01-09, 04:59 PM   #6
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Geforce 6800 LE / nvidia 185.18.36-1 and artefacts - need help

Does downgrading to an older driver resolve the problem? The nv and nouveau drivers do not use the card to its full potential, so it's possible that they aren't exercising the part of the chip that's not working correctly.
AaronP is offline   Reply With Quote
Old 12-12-09, 07:46 AM   #7
Sirsurthur
Registered User
 
Join Date: Oct 2009
Posts: 6
Default Re: Geforce 6800 LE / nvidia 185.18.36-1 and artefacts - need help

Hello,

Same problem here with nvidia 195.22 and kernel 2.6.31. Attached to this post, you will find nvidia-bug-report.log.gz file.

let me know AaronP if you see something interesting or if my chip is definately broken.

Thanks a lot,

Sirsurthur
Attached Files
File Type: gz nvidia-bug-report.log.gz (35.7 KB, 91 views)
Sirsurthur is offline   Reply With Quote
Old 12-12-09, 06:39 PM   #8
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Geforce 6800 LE / nvidia 185.18.36-1 and artefacts - need help

Not really... it still looks like your card just stops responding after a while.

You *are* using the agpgart driver, which has been a source of problems in the past. You could try switching to nvagp instead (there should be a HOWTO for your distribution floating around somewhere). Also, try disabling side-band addressing: SBA and Fast Writes have been a common source of instability with AGP.
AaronP is offline   Reply With Quote

Old 12-13-09, 08:25 AM   #9
Sirsurthur
Registered User
 
Join Date: Oct 2009
Posts: 6
Default Re: Geforce 6800 LE / nvidia 185.18.36-1 and artefacts - need help

Hi,

I switched to Nvagp and turned off fast writes (sba could not be switched off in my bios ?) but the glitches are still there.

Have they been modification in the agp part of the nvidia driver between 180. series to new ones ?

I will try to test with an other card too in the future.

Thanks for your help AaronP. Don't hesitate to let me know if you come with an another idea I could test.

Sirsurthur
Sirsurthur is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:22 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.