Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-12-09, 07:25 PM   #1
packetwhacker
Registered User
 
Join Date: Dec 2009
Posts: 2
Unhappy Display quality problem on Ubuntu Karmic 9.10 64-bit with GTX 260

Hi all,

I've been having an issue ever since I've installed a fresh copy of Ubuntu 9.10 x64 on my system here. Prior to installing the NVIDIA drivers for GL support (etc.), the display looks just fine.

After installing however, desktop fonts, images, and programs that use GL look awful. Forgive me, but I'm not sure if it's the right term to describe what I'm seeing, but it would seem that something is very wrong with anti-aliasing. All the fonts look blurred, frequently characters such as "H" seem to have different widths for the left part versus the right part of it (vague I know), and images seem to have a single pixel wide shadow on them (same for fonts). It's usable, but, visually unappealing and quite agitating to look at.

I should note that I have tried multiple resolutions and refresh rates, fidgeted with the anti-aliasing and anisotropic filtering, as well as tried version 185 (installed via Ubuntu's restricted drivers), 190.42, 190.53, and the beta 195.22. The latter three I used the NVIDIA installer to compile and install them.

I have verified that the module has loaded in each case, and that my xorg.conf references "nvidia" as the driver.

I know that I don't have a hardware problem since the computer in question dual-boots Win7 and the graphics look fine on it.

I am only using the first output on the card going via a DVI-HDMI cable to a ViewSonic VX2835wm monitor. One other odd thing I should note: Only when the NVIDIA driver is loaded, the monitor (which has inbuilt speakers), frequently output a brief burst of static.

Below is my 'xorg.conf'.
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Wed Dec  9 16:34:26 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "ViewSonic VX2835wm"
    HorizSync       30.0 - 82.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 260"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
I'm no slouch when it comes to Linux, but this really has me stumped. Please tell me someone knows to to relieve my pain.
Attached Files
File Type: gz nvidia-bug-report.log.gz (36.0 KB, 81 views)

Last edited by packetwhacker; 12-12-09 at 07:45 PM. Reason: Attach bug report.
packetwhacker is offline   Reply With Quote
Old 12-22-09, 12:26 PM   #2
packetwhacker
Registered User
 
Join Date: Dec 2009
Posts: 2
Default Re: Display quality problem on Ubuntu Karmic 9.10 64-bit with GTX 260

I hate to bump, but I still can't get it working right... does *anyone* have any ideas?
packetwhacker is offline   Reply With Quote
Old 12-22-09, 12:30 PM   #3
cajual
Registered User
 
Join Date: Dec 2009
Posts: 10
Default Re: Display quality problem on Ubuntu Karmic 9.10 64-bit with GTX 260

Force the EDID to your monitor. It seems your xorg.conf hor/vert rates are a little awry. There are a few tutorials how to do that on this site, or look up SoftMCCS for windows.
cajual is offline   Reply With Quote
Old 12-23-09, 12:53 PM   #4
Alex_T
Registered User
 
Join Date: Jun 2009
Posts: 3
Default Re: Display quality problem on Ubuntu Karmic 9.10 64-bit with GTX 260

If I understood you correctly, your screen looks like as if it were on a TV. I had the same problem with my vx2435wm. The problem is that the monitor's EDID contains an extended list of TV modes, e.g. 1080p, 1200p. It seems that the extended modes takes priority over the "computer" ones in the driver. The problem may be fixed by providing a custom EDID with the extensions stripped down. Here is the step-by-step instruction.

Disclaimer: Do the following at your own risk!
Warning: Using a wrong EDID can damage your monitor!

1. Get the EDID from your monitor

Run nvidia-settings, select a line for your monitor in the left column (DFP-0 or so) and click "Acquire EDID" on the right panel. Save it to a file, e.g. /etc/X11/vx2835wm.edid. Check the length of the file. If it's more than 128 bytes long (256 in my case), you may proceed. Otherwise, this is not the case.

2. Remove extended info block(s) from the file.

Download this utility, compile and run it as root:
Code:
# cd /etc/X11
# <path_to>/edid_disable_exts vx2835wm.edid vx2835wm-noext.edid
If the program issues error messages, something goes wrong -- do not proceed!

If everything is OK, you'll get the new file vx2835wm-noext.edid that is exactly 128 bytes long.

3. Change the xorg.conf

Add the "CustomEDID" option to the "Screen" section:
Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option       "CustomEDID" "DFP-0:/etc/X11/vx2835wm-noext.edid"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
See README for details.

4. Restart X

Hope this will help.

Sources:
http://www.nvnews.net/vbulletin/showthread.php?t=132268
http://analogbit.com/node/23
Alex_T is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:44 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.