Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-14-09, 08:35 AM   #1
gastverh
Registered User
 
Join Date: Apr 2006
Posts: 36
Default FC12 tv-out problem

Hello,
I work with FC12 and a nVidia GeForce FX5200 graphical card.
With an upgrade to FC12, I cannot get tv-out any more.
The last problem "xorg.conf tv-out" was with FC8 and is solved in this Forum on 11-14-08.
Running following command gives the NVIDIA X Server Settings window:
Code:
[root@d51520994 gastonv]# nvidia-settings
And then I see:
Code:
Unable to load X Server Display Configuration page:
Failed to query NoScanout for screen 0.
My /etc/X11/xorg.conf:
Code:
[gastonv@d51520994 ~]$ cat /etc/X11/xorg.conf
# Xorg configuration created by livna-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib/xorg/modules/driversť"
	ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
	Option	    "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "Emulate3Buttons" "no"
	Option	    "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "be"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Unknown"
	ModelName    "BenQ E900W"
	HorizSync    31.0 - 83.0
	VertRefresh  55.0 - 76.0
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "NVIDIA Corporation"
	BoardName   "GeForce FX 5200"
	Option	    "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	Option	    "Composite" "Enable"
	Option	    "TwinView" "1"
	Option	    "TwinViewXineramaInfoOrder" "CRT-0"
	Option	    "metamodes" "CRT-0: nvidia-auto-select 1280x800 +0+0 TV: nvidia-auto-select 1024x768 +0+0"
	Option	    "NvAGP" "1"
	Option	    "RenderAccel" "True"
	Option	    "AddARGBGLXVisuals" "True"
	Option	    "TwinViewOrientation" "Clone"
	Option	    "ConnectedMonitor" "CRT-0, TV"
	Option	    "TVStandard" "PAL"
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection
My nvidia drivers:
Code:
[gastonv@d51520994 ~]$ yum list installed | grep nvidia
kmod-nvidia-173xx.i686
kmod-nvidia-173xx-2.6.31.6-166.fc12.i686.i686
nvidia-settings.i686
nvidia-xconfig.i686 1.0-1.fc12      @rpmfusion-nonfree-updates                  
xorg-x11-drv-nvidia-173xx.i686
xorg-x11-drv-nvidia-173xx-libs.i686
Perhaps I have to configure or change something?
Many thanks in advance for helping.
Greetings,
Gaston Verhulst.
gastverh is offline   Reply With Quote
Old 12-14-09, 02:56 PM   #2
kwizart
Registered User
 
Join Date: Feb 2005
Location: Paris, France
Posts: 129
Default Re: FC12 tv-out problem

where does ModulePath "/usr/lib/xorg/modules/driversť" come from ?
kwizart is offline   Reply With Quote
Old 12-15-09, 01:46 AM   #3
gastverh
Registered User
 
Join Date: Apr 2006
Posts: 36
Default Re: FC12 tv-out problem

Hello,
Thanks for your remark.
I have checked and changed it immediately.
Code:
[gastonv@d51520994 ~]$ ls /usr/lib/xorg/modules
drivers     libexa.so    libshadowfb.so  libvgahw.so  linux
extensions  libfb.so     libshadow.so    libwfb.so    multimedia
input       libint10.so  libvbe.so       libxaa.so
[gastonv@d51520994 ~]$ ls /usr/lib/xorg/modules/extensions
libdbe.so  libdri2.so  libdri.so  libextmod.so  libglx.so  librecord.so  nvidia
Code:
Section "Files"
	ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib/xorg/modules/drivers"
	ModulePath   "/usr/lib/xorg/modules"
EndSection
But after rebooting the system I do not have tv-out and I see the same message:
Code:
Unable to load X Server Display Configuration page:
Failed to query NoScanout for screen 0.
Greetings
Gaston Verhulst.
gastverh is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:31 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.