Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-02-03, 02:53 PM   #1
jim64
Registered User
 
Join Date: Jul 2003
Posts: 13
Default nForce2 audio on slackware 9.0?

I have an Fic au13 mobo with the nforce2 chipset. I can't get the audio to work. I am trying to use the on board audio.
What i have tried.
-I have downloaded and installed the source drivers from nvidia.com. no luck.
-I have tried sndconfig. no luck

Basically i am starting over and have reinstalled slackware 9.0. I used mandrake for a wile and audio worked but i decided to get rid of it bc i like slack better.
Ask me any thing that you like and i will post the info. Also i have made a post on linuxquestions.org where many ppl seem to have the same problem but no one has a solution. I am running kernel 2.4.20 and i heard that in later kernels support for nforce2 is built in. Is that true?
Feel free to im me on my aim screen name. p2prat
jim64 is offline   Reply With Quote
Old 07-02-03, 03:34 PM   #2
connyosis
Eggplant
 
connyosis's Avatar
 
Join Date: May 2003
Location: Sweden
Posts: 86
Send a message via ICQ to connyosis
Default Re: nForce2 audio on slackware 9.0?

Quote:
Originally posted by jim64
I have an Fic au13 mobo with the nforce2 chipset. I can't get the audio to work. I am trying to use the on board audio.
What i have tried.
-I have downloaded and installed the source drivers from nvidia.com. no luck.
-I have tried sndconfig. no luck

Basically i am starting over and have reinstalled slackware 9.0. I used mandrake for a wile and audio worked but i decided to get rid of it bc i like slack better.
Ask me any thing that you like and i will post the info. Also i have made a post on linuxquestions.org where many ppl seem to have the same problem but no one has a solution. I am running kernel 2.4.20 and i heard that in later kernels support for nforce2 is built in. Is that true?
Feel free to im me on my aim screen name. p2prat
What have you tried? I got it to work in Slack9 with some effort.
First of all upgrade to kernel 2.4.21, and remember to enable AMD Viper support in IDE settings so you'll have DMA support.
As for sound, I had to enable sound support (Of course) and also support for Ensoniq 1370 cards. (Yes, even though you won't use it) If I didnt enable the 1370 card I got unresolved symbols when trying to insert the nvidia sound module.
Now, recompile the kernel and reboot with that, then just compile the nvnet and nvaudio modules, install them and load them with modprobe nvnet and modprobe nvaudio, and everything should work fine.
__________________
"Never bump a baby carriage out of a crosswalk unless the kid's really asking for it."
connyosis is offline   Reply With Quote
Old 07-02-03, 04:04 PM   #3
jim64
Registered User
 
Join Date: Jul 2003
Posts: 13
Default

Um ya about that i am not sure how to do all of that. I have only used linux for about a year so i am kinda new to this sort of stuff. Could you please help me out. I know its alot to ask but maybe step me through it. I know just a bit about recompiling the kernel and have been reading about it for a wile but i always run into errors and nothing ever works. Thanks so much for your reply.
jim64 is offline   Reply With Quote
Old 07-02-03, 05:03 PM   #4
connyosis
Eggplant
 
connyosis's Avatar
 
Join Date: May 2003
Location: Sweden
Posts: 86
Send a message via ICQ to connyosis
Default

Ok, first download the 2.4.21 kernel from kernel.org and unpack it into /usr/src
(Remove any previous kernel sources before doing this.)
This will create the directory /usr/src/linux-2.4.21. Then create a link called linux with "ln -s linux-2.4.21 linux"
I'm not sure if that step is needed any more, but just incase :-)

Now, in /usr/src/linux as root run "make menuconfig". This will take you into the kernel configurator. First of all enable "Prompt for development and/or .." in Code Maturity, and then go through the kernel options and set it up so it suits your system. Be sure (As previously stated) to enable AMD Viper support in IDE settings, and to also enable sound support and Ensonic 1370 support. (Might work with other cards, but I used this and it works fine for me)

Now when you have done this, exit and save, and then run "make dep bzImage modules modules_install"
This will take some time, and when its done you'll have a new compiled kernel image located at /usr/src/linux/arch/i386/boot called bzImage.
Move this kernel image to /boot and name it something like "linux2421" or "kickass_kernel_from_connyosis". You pick. :-)

If you are using LILO as boot loader, edit your /etc/lilo.conf so it finds your new kernel , save it and run /sbin/lilo. Then reboot and pick your new kernel.
If you are using grub as bootloader edit your /boot/grub/grub.conf (Or /boot/grub/menu.lst if you are using an older version) and add the correct info.

After you have booted into your new kernel, compile the nvnet and nvaudio modules, install them and run modprobe nvnet and modprobe nvaudio. Now everything should work fine. (You need to reinstall these modules every time you compile a new kernel. Same goes for the nvidia graphics driver)

Good luck
__________________
"Never bump a baby carriage out of a crosswalk unless the kid's really asking for it."
connyosis is offline   Reply With Quote
Old 07-02-03, 05:45 PM   #5
jim64
Registered User
 
Join Date: Jul 2003
Posts: 13
Default

Thanks so much for you instructions. I have a couple questions. What directory do i have to be in when i make that link with "ln -s linux-2.4.21 linux" or does it even mater. Also ,i am new to compiling the kernel so this may be a dumb question, but isn't stuff stuff like bttv or hardware support compiled into the kernel? What happens to that stuff when i recompile. Doesn't it have to be in that directory with the kernel source?
Thanks a bunch
jim64 is offline   Reply With Quote
Old 07-02-03, 06:06 PM   #6
connyosis
Eggplant
 
connyosis's Avatar
 
Join Date: May 2003
Location: Sweden
Posts: 86
Send a message via ICQ to connyosis
Default

Quote:
Originally posted by jim64
Thanks so much for you instructions. I have a couple questions. What directory do i have to be in when i make that link with "ln -s linux-2.4.21 linux" or does it even mater. Also ,i am new to compiling the kernel so this may be a dumb question, but isn't stuff stuff like bttv or hardware support compiled into the kernel? What happens to that stuff when i recompile. Doesn't it have to be in that directory with the kernel source?
Thanks a bunch
You have to be in /usr/src when creating the link, since the directory linux-2.4.21 is in that directory. (ln -s dir1 dir2 means that you create a symbolic link from dir1 to dir2. Sort of like shortcuts in windows...)
I dont know about bttv since I have never used it, but you yourself compile in the hardware support in the kernel. If you look around in the kernel confir you will see a lot of different options. If you do not have a specific hardware, you can disable support for it to save memory.
__________________
"Never bump a baby carriage out of a crosswalk unless the kid's really asking for it."
connyosis is offline   Reply With Quote
Old 07-02-03, 06:12 PM   #7
jim64
Registered User
 
Join Date: Jul 2003
Posts: 13
Default

A couple more questions and i answered that question about creating the link. Yes i needed to be in "/usr/src/". I know that you said i need to enable "AMD viper support" but there is also "AMD viper ATA-66 Override". I have an ata-66 hd do ti need to enable "AMD viper ATA-66 Override".
What else should i enable for every thing to keep working?
I have an AMD Athlon in a FIC AU13 mobo with the nForce2 chipset.
I also have :
-ATI Radion 7000 gfx card
-Hauppauge wintv sterio dbx fm (bt878 chipset)
-Lynksys network card using tulip driver configured with dhcp.
If you know any thing about what i should enable to keep that stuff working please tell me. I actually do not have bttv installed yet. Thats my next project.
Thanks i will wait to hear b4 i proceed. (i am currently running make menuconfig thingey).
jim64 is offline   Reply With Quote
Old 07-02-03, 06:42 PM   #8
connyosis
Eggplant
 
connyosis's Avatar
 
Join Date: May 2003
Location: Sweden
Posts: 86
Send a message via ICQ to connyosis
Default

No, dont enable that ATA-66 override, its not needed.
To get your Radeon to work you need the nVidia AGPGART patch. I dont use it since I have a GF4 card, but look through this forum and I bet you can get info on how to get it to work.
If you do a "cat /proc/pci" you can see what chipset your network card is using. Note it down and enable support for it in the kernel network config.
__________________
"Never bump a baby carriage out of a crosswalk unless the kid's really asking for it."
connyosis is offline   Reply With Quote

Old 07-02-03, 07:02 PM   #9
jim64
Registered User
 
Join Date: Jul 2003
Posts: 13
Default

Sorry to ask so many questions but i typed "cat /proc/pci and it only told me what i already know which is that i have a Linksys Network Everywhere Fast Ethernet 10/100 model N. I know what driver it used bc when i installed slackware it told me that it found one that used the tulip.o driver. I cant find any thing even close to tulip or lynksys in the kernel config. How do i enable other drivers that are not listed in the kernel config.
Sorry i know that this post has kinda changed from fixing audio to how to compile a kernel and have every thing work. I just want to keep the stuff thats working... working.
Thanks again
jim64 is offline   Reply With Quote
Old 07-02-03, 07:09 PM   #10
connyosis
Eggplant
 
connyosis's Avatar
 
Join Date: May 2003
Location: Sweden
Posts: 86
Send a message via ICQ to connyosis
Default

Well....why do you need that driver? The nForce2 board already had a network card integrated right? to get that working compile the nvnet driver after you have compiled your new kernel.
If you still for some reason want your tulip card to work I suggest you ask in #linuxhelp on irc.freenode.net
__________________
"Never bump a baby carriage out of a crosswalk unless the kid's really asking for it."
connyosis is offline   Reply With Quote
Old 07-02-03, 11:11 PM   #11
jim64
Registered User
 
Join Date: Jul 2003
Posts: 13
Default

Ok i did it. I recompiled the kernel and edited the lilo.conf file. I then ran /sbin/lilo -v no errors. Now when i boot there is a kernel panic and it stops booting.
It says:
ds: no socket drivers loaded!
Kernel panic: VFS: Unable to mount root fs on 03:01
I think my comp hates me. Good thing i also made the lilo.conf file so that i could boot my old kernel. So i can boot my old kernel but if i do that then i have no sound. What should i do now?
jim64 is offline   Reply With Quote
Old 07-03-03, 07:24 AM   #12
connyosis
Eggplant
 
connyosis's Avatar
 
Join Date: May 2003
Location: Sweden
Posts: 86
Send a message via ICQ to connyosis
Default

It seems like you didnt enable support for the filesystem you are using. Make sure to enable support for extended filesystem 2, maybe reiserfs and ext3.
And it is a good thing to take your time when compiling a kernel. Go through the options one by one (You can ignore the ones you know you dont need, like firewire and hotplug devices) and view the help for each one of them. Yes, its gonna take some time but it will be worth it...
__________________
"Never bump a baby carriage out of a crosswalk unless the kid's really asking for it."
connyosis is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 04:55 AM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 11:13 PM
nforce2 question. Nutty CPUs, Motherboards And Memory 3 10-05-02 12:52 PM
Nvidia Problems in Slackware 8.1 xtreme NVIDIA Linux 3 10-01-02 01:03 PM
nvidia drivers and slackware 9.0 pbrennen NVIDIA Linux 5 09-16-02 07:57 AM

All times are GMT -5. The time now is 10:38 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.