Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-15-09, 09:24 AM   #1
DeiF
Registered User
 
Join Date: Oct 2008
Posts: 114
Default NVRM: failed to enable MSI

Using 195.22 (also happens with 190.42), openSUSE 11.2 desktop kernel (2.6.31.5-0.1-desktop).
I appended "NVreg_EnableMSI=1" to one of the files in "/etc/modrpobe.d" which already contains "options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=33 NVreg_DeviceFileMode=0660".

The following warning appears in dmesg:
Code:
NVRM: failed to enable MSI,
using PCI-E virtual-wire interrupts!
Is this expected behavior?
Maybe MSI feature is disabled in these drivers (like UseEvents)?
Attached Files
File Type: gz nvidia-bug-report.log.gz (44.9 KB, 90 views)
DeiF is offline   Reply With Quote
Old 12-15-09, 01:56 PM   #2
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: NVRM: failed to enable MSI

Code:
[    0.365815] pci 0000:00:00.0: MSI quirk detected; MSI disabled
The kernel is disabling MSI for your hardware because it is known not to work on it.
Dragoran is offline   Reply With Quote
Old 12-15-09, 09:22 PM   #3
robhancock
Registered User
 
Join Date: Dec 2004
Posts: 31
Default Re: NVRM: failed to enable MSI

Specifically, MSI is disabled on your particular VIA chipset since it's believed not to work properly on it.
robhancock is offline   Reply With Quote
Old 12-16-09, 04:37 PM   #4
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: NVRM: failed to enable MSI

You probably do not loose anything by not enabling MSI on your Geforce 8400m. I have Geforce 8200 and enabling MSI causes serious hangs and thanks to this errors on disk because of not clean system shutdown. However there are 2 reports that MSI works perfect on quadro nvs140m and GTX 285:
http://www.nvnews.net/vbulletin/showthread.php?t=141668
So MSI only works well with few GPUs.
zbiggy is offline   Reply With Quote
Old 12-17-09, 06:04 AM   #5
DeiF
Registered User
 
Join Date: Oct 2008
Posts: 114
Default Re: NVRM: failed to enable MSI

Well, I remember having MSI successfully enabled in the past, but the recent experiment caused me a lot of troubles (e.g. could not play large videos).

Anyway, I don't know if this is related, but my graphics card permanently broke .
I'm seeing these symptoms again: http://www.nvnews.net/vbulletin/showthread.php?t=130082
This time, however, the laptop is out of warranty. The repair would cost half of the laptop's initial price.
Seems that every year my laptop's graphic card breaks .
DeiF is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:10 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.