Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-02-03, 11:19 PM   #1
akorvemaker
Registered User
 
Join Date: Jul 2003
Posts: 2
Default Unable to install 1.0-4363 in Knoppix

Hi. i just installed Knoppix to my hard drive. When I attempt to install the NV video drivers I get the error message that says my kernel was compiled with a different version than I am using to compile the drivers. I've attached the nvidia.installer.log file.

I typed "cat /proc/version" and the result was "Linux version 2.4.20-xfs (root@Knoppix) (gcc version 2.95.4 20011002 (Debian prerelease)) #1 SMP Mit M?r 26 15:37:36 CET 2003". I typed "gcc -v" and the result was (among some other stuff) "gcc version 3.2.3 (Debian)".

I tried setting the CC environment variable by typing "export CC=/usr/bin/gcc-2.95.4". I read that in the knoppix forum. Did I do this correctly?

I tried installing the drivers again, and it gave the same message.

What am I doing wrong? What do I need to change to get this to compile?
akorvemaker is offline   Reply With Quote
Old 10-20-03, 05:23 PM   #2
lunarg
Registered User
 
Join Date: Oct 2003
Posts: 4
Default

Use the following command:

env IGNORE_CC_MISMATCH=1 ./nvidia-installer

(when you have unpacked the package)

This worked for me
lunarg is offline   Reply With Quote
Old 10-20-03, 08:19 PM   #3
akorvemaker
Registered User
 
Join Date: Jul 2003
Posts: 2
Default

Thanks! I'd forgotten I posted this.

I got it working with something similar. I used:
Code:
IGNORE_CC_MISMATCH=1
export IGNORE_CC_MISMATCH
./nvidia-installer...
I think we pretty much did the same thing in two different ways. Anyway, I'm happy. It works :-)
akorvemaker is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 09:27 AM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 03:20 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 06:32 PM

All times are GMT -5. The time now is 01:24 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.