Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-24-09, 06:28 PM   #1
alzen
Registered User
 
Join Date: Sep 2008
Posts: 4
Default Weird mouse behaviour in OpenGL applications (pointer jumping)

I have a problem that may be connected with NVidia drivers. I just switched from Logitech M-BT58 optical mouse to A4Tech XL-750BF / X-750 (laser mouse). Everything works fine until I run some OpenGL apps. There pressing any of the buttons causes pointer in game to jump far to the right instantly. Of course playing games isn't possible with something like that.

Here are some software / hardware info:

Distribution: Debian testing
Kernel: 2.6.32 (installed it from Debian SID after trying 2.6.30 from testing)
Graphic Card: GF7800GT PCI-E
Driver: 190.53 (tested 185.36 as well)

What did I try:
- several window managers (metacity, compiz - I don't normally use it, openbox)
- xorg.conf created by NVidia drivers installer
- full system update (finished like 30 mins ago)
- extra kernel update (from sid, normally I use testing)

Nothing helped. Although some games work ok in some situations. Here're my observations:

- Prey - window ok, fullscreen problems
- Freedoom - window and fullscreen problems
- UT2004 - window and fullscreen problems
- Neverball - window ok, fullscreen problems
- Blob Wars II: Blob And Conquer - window (ok if "grab mouse" option turned off), fullscreen problems

I observed that games that capture mouse in the game window causes problems both in window and fullscreen. Games like Prey, Neverball and optionaly Blob Wars II that doesn't capture mouse works ok so problem is somewhere with mouse capture situation.

Please reply if it's connected with NVidia drivers or if you know any possible solution to this problem. It's werid that Compiz that is hardware accelerated itself works ok as window manager in GNOME. Would like to fix it because I just got a new mouse and cannot play games which is simply frustrating.
alzen is offline   Reply With Quote
Old 12-25-09, 06:41 AM   #2
alzen
Registered User
 
Join Date: Sep 2008
Posts: 4
Default Re: Weird mouse behaviour in OpenGL applications (pointer jumping)

I've tried the beta NVidia drivers -195.30, the problems is still there, no difference.
alzen is offline   Reply With Quote
Old 12-26-09, 05:20 PM   #3
alzen
Registered User
 
Join Date: Sep 2008
Posts: 4
Default Re: Weird mouse behaviour in OpenGL applications (pointer jumping)

Here's the solution. Guess it wasn't related to NVidia drivers.
alzen is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:36 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.