Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-29-09, 03:13 PM   #1
KWagner
Registered User
 
KWagner's Avatar
 
Join Date: Dec 2009
Posts: 1
Unhappy Fedora 12 and current Driver

I wish to use to official NVIDIA driver.

I keep getting a compile error. My problem is that none of the fixes I have found on the 'net were for the official driver.

Attached is the install log

(Please help!)
Attached Files
File Type: log nvidia-installer.log (74.4 KB, 112 views)

Last edited by KWagner; 12-29-09 at 03:18 PM. Reason: typo
KWagner is offline   Reply With Quote
Old 12-29-09, 03:46 PM   #2
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: Fedora 12 and current Driver

Doesn't look like a compile error:

Quote:
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most
frequently when this kernel module was built against the wrong or
improperly configured kernel sources, with a version of gcc that differs
from the one used to build the target kernel, or if a driver such as
rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
obtaining ownership of the NVIDIA graphics device(s), or NVIDIA GPU
installed in this system is not supported by this NVIDIA Linux graphics
driver release.
Did you check that?
ledoc is offline   Reply With Quote
Old 12-29-09, 05:18 PM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Fedora 12 and current Driver

Quote:
NVRM: The NVIDIA probe routine was not called for 1 device(s).
NVRM: This can occur when a driver such as rivafb, nvidiafb or
NVRM: rivatv was loaded and obtained ownership of the NVIDIA
NVRM: device(s).
NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel module
NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
NVRM: support), then try loading the NVIDIA kernel module again.
NVRM: No NVIDIA graphics adapter probed!
This typically happens when you have another driver, such as nouveau, loaded. Please check if the nouveau module is enabled (which it is by default in Fedora 12) and see the Fedora documentation on how to disable it.
AaronP is offline   Reply With Quote
Old 12-29-09, 11:53 PM   #4
mx_
Registered User
 
Join Date: Dec 2009
Posts: 8
Default Re: Fedora 12 and current Driver

Hi !

echo "blacklist nouveau" > /etc/modprobe.d/blacklist-nouveau.conf
and
reboot

P.S.
It is probably necessary to add :
sed -i '/root=/s|$| rdblacklist=nouveau|' /boot/grub/grub.conf
mx_ is offline   Reply With Quote
Old 12-30-09, 01:51 AM   #5
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: Fedora 12 and current Driver

Yeah or just try nouveau and use it if it's good enough.
ledoc is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.