Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-01-10, 01:52 PM   #1
Zaptor
Registered User
 
Join Date: Jan 2010
Posts: 6
Default NVIDIA(0): Option "DigitalVibrance" is not used

Trying to set my /etc/X11/xorg.conf options like this in my minimal XBMC Karmic.

Quote:
Option "DigitalVibrance" "63"
Without any success, seems that inputing that into the xorg file have no effect, also trying to run nvidia-settings result in

Quote:
xbmc@htpc:~$ sudo nvidia-settings
nvidia-settings: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
DigiVibrance is a great way to enhance your picture so any help would be nice.

Full xorg.log here: http://pastebin.com/m467b0550
Zaptor is offline   Reply With Quote
Old 01-01-10, 02:39 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

The Digital Vibrance option is only available through nvidia-settings. You'll need to figure out which package to install from your distribution to get the GTK+ libraries.

By the way, you don't need to run nvidia-settings as root.
AaronP is offline   Reply With Quote
Old 01-01-10, 03:51 PM   #3
Zaptor
Registered User
 
Join Date: Jan 2010
Posts: 6
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

Quote:
Originally Posted by AaronP View Post
The Digital Vibrance option is only available through nvidia-settings. You'll need to figure out which package to install from your distribution to get the GTK+ libraries.

By the way, you don't need to run nvidia-settings as root.
Being a bit of a Linux novice, how do i figure out wich GTK+ libraries i need?
Zaptor is offline   Reply With Quote
Old 01-01-10, 05:05 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

You need libgtk-x11-2.0.so.0, which is provided by a package in your distribution. For Ubuntu,
Quote:
$ apt-file find libgtk-x11-2.0.so.0
libgtk2.0-0: /usr/lib/libgtk-x11-2.0.so.0
libgtk2.0-0: /usr/lib/libgtk-x11-2.0.so.0.1800.3
libgtk2.0-0-dbg: /usr/lib/debug/usr/lib/libgtk-x11-2.0.so.0.1800.3
so you could install that with "sudo apt-get install libgtk2.0-0".

Last edited by AaronP; 01-02-10 at 12:19 AM. Reason: It's "lib", not "ilb"
AaronP is offline   Reply With Quote
Old 01-01-10, 06:54 PM   #5
Zaptor
Registered User
 
Join Date: Jan 2010
Posts: 6
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

Can't seem to find that package.

Quote:
xbmc@htpc:~$ apt-file find libgtk-x11-2.0.so.0
-bash: apt-file: command not found
xbmc@htpc:~$

Quote:
xbmc@htpc:~$ sudo apt-get install ilbgtk2.0-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package ilbgtk2.0-0
xbmc@htpc:~$
Zaptor is offline   Reply With Quote
Old 01-02-10, 12:02 AM   #6
mlampard
Registered User
 
Join Date: Apr 2006
Location: South Australia
Posts: 30
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

Quote:
Originally Posted by Zaptor View Post
Can't seem to find that package.
You typed 'ilbgtk2.0-0' rather than libgtk2.0-0 .. try again

... and happy new year ...
mlampard is offline   Reply With Quote
Old 01-02-10, 12:19 AM   #7
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

Quote:
Originally Posted by mlampard View Post
You typed 'ilbgtk2.0-0' rather than libgtk2.0-0 .. try again

... and happy new year ...
Oops, my fault, sorry. I'll correct my earlier post.

and I agree, happy new year!
AaronP is offline   Reply With Quote
Old 01-02-10, 07:16 AM   #8
Zaptor
Registered User
 
Join Date: Jan 2010
Posts: 6
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

Happy New Year!

That worked much better, i should have spotted the typo myself

Now im gettingsomewhere but it seems i have no display defined?

Quote:
xbmc@htpc:~$ nvidia-settings -a localhost:0.0/DigitalVibrance[DFP-0]=63

ERROR: The control display is undefined; please run `nvidia-settings --help`
for usage information.

xbmc@htpc:~$
Zaptor is offline   Reply With Quote

Old 01-02-10, 01:19 PM   #9
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

Hmm, that could be a bug in nvidia-settings: it requires a control display even if the display is specified in the -a argument. You should be able to do this instead:
Quote:
nvidia-settings -c localhost:0.0 -a DigitalVibrance[DFP-0]=63
Use "-c :0.0" instead of "-c localhost:0.0" if your server is running with TCP connections disabled, which it normally is.
AaronP is offline   Reply With Quote
Old 01-02-10, 01:28 PM   #10
Zaptor
Registered User
 
Join Date: Jan 2010
Posts: 6
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

Quote:
Originally Posted by AaronP View Post
Hmm, that could be a bug in nvidia-settings: it requires a control display even if the display is specified in the -a argument. You should be able to do this instead:

Use "-c :0.0" instead of "-c localhost:0.0" if your server is running with TCP connections disabled, which it normally is.
Yes that seems to do the trick, with or without localhost, however i see NO change in XBMC.
Code:
xbmc@htpc:~$ nvidia-settings -c localhost:0.0 -a DigitalVibrance[DFP-0]=63

  Attribute 'DigitalVibrance' (localhost:0.0, display device: DFP-0) assigned value 63.

xbmc@htpc:~$ nvidia-settings -c :0.0 -a DigitalVibrance[DFP-0]=63

  Attribute 'DigitalVibrance' (htpc:0.0, display device: DFP-0) assigned value 63
Does this action require a reboot to see the changes and if so is this a permanent change or do i need to input it to some config file?
Zaptor is offline   Reply With Quote
Old 01-02-10, 04:26 PM   #11
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

Are you restarting X before starting XBMC? The option is not saved across X server resets.
AaronP is offline   Reply With Quote
Old 01-02-10, 04:35 PM   #12
Zaptor
Registered User
 
Join Date: Jan 2010
Posts: 6
Default Re: NVIDIA(0): Option "DigitalVibrance" is not used

Quote:
Originally Posted by AaronP View Post
Are you restarting X before starting XBMC? The option is not saved across X server resets.
I'm running these commands through SSH.

Is there a way to set this command prior to the start of X and XBMC in the system?
Zaptor is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.