Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-16-09, 04:40 AM   #1
hansseins
Registered User
 
Join Date: Jan 2009
Posts: 5
Default NVIDIA 8400M G black screen

NVIDIA 8400M G, ASUS A7S, Core 2 Duo, Kubuntu 8.10

I successfully intalled 180.22 with
sh NVIDIA-....run -k $(uname r)

But, when i make a restart it quites with BLACK screen saying s.th. like:
Checking ... state ...

I switched to ctr + alt + F1, stop kdm

/>/etc/X11/kdm stop
/>edit xorg.conf

change in "Device" section "nvidia" to "vesa" i am able to restart kdm
and have kdm working. So, what does i forget to configure? You can see below my log and xorg.conf files.

/>modprobe nvidia
tell me -> "No such device" ...

(17" laptop screen (normal resolution is 1440 x 900))

t. i. a.

hans
Attached Files
File Type: log nvidia-installer.log (42.4 KB, 116 views)
File Type: txt xorg.conf.txt (1.9 KB, 118 views)
File Type: gz nvidia-bug-report.log.gz (34.6 KB, 103 views)

Last edited by hansseins; 01-19-09 at 05:36 AM.
hansseins is offline   Reply With Quote
Old 01-10-10, 04:47 PM   #2
pamram
Registered User
 
Join Date: May 2007
Posts: 3
Default Re: NVIDIA 8400M G installation fails

I just ran into a similar scenario with an Nvidia GeForce 7000m for my Acer aspire 5520 laptop. The sh command finally got the installation going without errors, but X won't load upon init 5 or system reboot.

It stays blinking over and over trying to load the graphics driver but then it stays blank.

My system is Fedora 12 i386. It seems to come preloaded with some nouveau or nouveaufb video driver which even disables the default vesa and takes over.

Somehow it keeps interfering i guess with the nvidia driver and won't let it load.

Nvidia, any chance for an updated driver with new gcc and stuff so we don't run into trouble?

any ideas anybody? Thank you.
pamram is offline   Reply With Quote
Old 01-10-10, 05:10 PM   #3
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Default Re: NVIDIA 8400M G installation fails

This seems like a BIOS issue, ther'a a lot of this:

Jan 16 15:45:15 tiescha-laptop kernel: [ 1933.589062] NVRM: BAR1 is 0M @ 0x00000000 (PCI:0001:00.0)
Jan 16 15:45:15 tiescha-laptop kernel: [ 1933.589068] NVRM: The system BIOS may have misconfigured your graphics card.

in your logs. Try looking for an update at Asus' website.

Oh! How much RAM (like physically) does you laptop have?
OK, I got it from your dmesg, and it's 3GB, right? If so, then could you please try removing one of the sticks? Down to say 2GB, and retrying to start X?
piotrq__ is offline   Reply With Quote
Old 01-10-10, 05:13 PM   #4
jumjum77
Registered User
 
Join Date: Mar 2009
Posts: 13
Default Re: NVIDIA 8400M G installation fails

[ 257.644701] NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:
[ 257.644703] NVRM: BAR1 is 0M @ 0x00000000 (PCI:0001:00.0)
[ 257.644709] NVRM: The system BIOS may have misconfigured your graphics card.
[ 257.647107] nvidia: probe of 0000:01:00.0 failed with error -1
[ 257.647822] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 257.647826] NVRM: None of the NVIDIA graphics adapters were initialized!

First of all I'd try with the newest available driver to see it works as expected.
If that doesnt work, I'd try changing some BIOS settings, and as a last resort I'd check for a BIOS update.
jumjum77 is offline   Reply With Quote
Old 01-10-10, 08:17 PM   #5
pamram
Registered User
 
Join Date: May 2007
Posts: 3
Default Re: NVIDIA 8400M G installation fails

Guys, the answer seems a lot simpler than we though, at least for my case.

Apparently there is a compatibility issue between the nvidia drivers and the default nouveau driver used by the fbcon on Fedora 12 and others similar, preventing the Nvidia proprietary driver to work even after it is properly installed with the -k $(uname -r).

There are 2 ways of dealing with it:

1. change the default initrd:

su -
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)

2. keep the original initrd, but disable the nouveau driver:

edit /etc/grub.conf and add the following to the end of the line(s) starting with 'kernel':
rdblacklist=nouveau

#2 worked flawlessly for me, the complete reference can be found on the following links:

- http://rpmfusion.org/Howto/nVidia

- http://www.linuxquestions.org/questi...lution-771248/

Good luck !
pamram is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Driver Installation flores.facundo NVIDIA Linux 2 06-24-12 09:37 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 05:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM

All times are GMT -5. The time now is 11:35 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.