Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-26-10, 06:48 PM   #25
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Hi,
When I add "disable snd_hda_intel" in blacklist.conf, alsa says there is no sound device. My onboard audio uses intel audio which also uses snd_hda_intel.

I see this note in the wiki

Quote:
I have to make a BIG NOTE that I don't have another Nvidia sound card on the motherboard, and that's why the above works for me. It won't work if you have an integrated nvidia sound AND a GT220.
Can someone suggest any specific changes that I may need to apply?

Not successful in disabling on-board audio using BIOS. "DEL" key doesn't work, it is a powerspec N101 PC. Is it possible it was locked by my system integrator?
rp_linux is offline   Reply With Quote
Old 02-27-10, 12:01 AM   #26
paoleary
Registered User
 
Join Date: Feb 2010
Posts: 37
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by rp_linux View Post
Hi,
When I add "disable snd_hda_intel" in blacklist.conf, alsa says there is no sound device. My onboard audio uses intel audio which also uses snd_hda_intel.
You definitely don't want to blacklist snd_hda_intel; it's a required module which provides the base HD audio functionality.

Quote:
Originally Posted by rp_linux View Post
I see this note in the wiki



Can someone suggest any specific changes that I may need to apply?

Not successful in disabling on-board audio using BIOS. "DEL" key doesn't work, it is a powerspec N101 PC. Is it possible it was locked by my system integrator?
Did you have problems with the basic sound.conf configuration? I have not disabled onboard audio, so the wiki instructions are set up for that (since I wrote them ).
paoleary is offline   Reply With Quote
Old 02-27-10, 12:46 PM   #27
Juppers
Registered User
 
Join Date: Feb 2010
Posts: 3
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by rp_linux View Post
Hi Dave,
This is the video card I have, PNY GeForce 210 512MB DDR2 PCIe 2.0 x16 Graphics Card.

http://www.microcenter.com/single_pr...uct_id=0320940

Thanks, will try your suggestions also - remove the "enable_msi", disable the on board audio.
I have a very similar PNY card. Here is what I needed to do to make audio work out the HDMI.

options snd-hda-intel enable_msi=0 probe_mask=4

To get audio out the DVI I needed

options snd-hda-intel enable_msi=0

Both required the patched alsa from the wiki post.
Juppers is offline   Reply With Quote
Old 02-27-10, 10:49 PM   #28
neosmatrix
Registered User
 
Join Date: Sep 2004
Posts: 60
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

I now managed to get my HDMI working. I have an Zotac GT220 1GB Passiv and I modified and attached the Patch. I appreciate if someone could look over the changes I made.

alsa-info.sh: http://www.alsa-project.org/db/?f=b8...46880e1d5da173
Attached Files
File Type: bz2 hda-intel.patch.tar.bz2 (7.2 KB, 185 views)
neosmatrix is offline   Reply With Quote
Old 02-28-10, 11:05 AM   #29
paoleary
Registered User
 
Join Date: Feb 2010
Posts: 37
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by neosmatrix View Post
I now managed to get my HDMI working. I have an Zotac GT220 1GB Passiv and I modified and attached the Patch. I appreciate if someone could look over the changes I made.

alsa-info.sh: http://www.alsa-project.org/db/?f=b8...46880e1d5da173
Your changes to patch_nvhdmi.c don't actually do anything, as you've not introduced any new execution paths, except for selecting the enum. Since the enum is only used in choosing the four execution paths where you added the new member, it doesn't do anything.

That leaves the modifications to hda_intel.c, which were in my original patch until I realized that they too did nothing, since the previous member of the array will hit all nVidia products.

So as far as I can tell, your modifications aren't doing anything new beyond the latest version of the patch from my repository. Back up what you've done, start from a clean pull of ALSA, and try again with the patch mentioned in the wiki. There's no reason that it shouldn't work if your mods do, and if for some reason there is a difference, it would help to figure out why.

Thanks for the effort!
paoleary is offline   Reply With Quote
Old 02-28-10, 12:02 PM   #30
neosmatrix
Registered User
 
Join Date: Sep 2004
Posts: 60
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
So as far as I can tell, your modifications aren't doing anything new beyond the latest version of the patch from my repository. Back up what you've done, start from a clean pull of ALSA, and try again with the patch mentioned in the wiki.
After all this patches I think I used the wrong one, I saw in your patch the codec 0x10de000a is already there.

Regards Sascha

EDIT: I now used your patch and sound works but dmesg showed this error messages:
Code:
HDA Intel 0000:01:00.1: PCI INT A -> GSI 16 (level, low) -> IRQ 16
HDA Intel 0000:01:00.1: setting latency timer to 64
ALSA hda_intel.c:1971: Invalid PCM device number 8
hda_codec: cannot attach PCM stream 8 for codec #2
ALSA hda_intel.c:1971: Invalid PCM device number 9
hda_codec: cannot attach PCM stream 9 for codec #3
I think I could ignore them?
neosmatrix is offline   Reply With Quote
Old 02-28-10, 03:20 PM   #31
paoleary
Registered User
 
Join Date: Feb 2010
Posts: 37
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by neosmatrix View Post
After all this patches I think I used the wrong one, I saw in your patch the codec 0x10de000a is already there.

Regards Sascha

EDIT: I now used your patch and sound works but dmesg showed this error messages:
Code:
HDA Intel 0000:01:00.1: PCI INT A -> GSI 16 (level, low) -> IRQ 16
HDA Intel 0000:01:00.1: setting latency timer to 64
ALSA hda_intel.c:1971: Invalid PCM device number 8
hda_codec: cannot attach PCM stream 8 for codec #2
ALSA hda_intel.c:1971: Invalid PCM device number 9
hda_codec: cannot attach PCM stream 9 for codec #3
I think I could ignore them?
If sound works, I would for now, but thanks for reporting them. When I get back to actively working on this, it might help.
paoleary is offline   Reply With Quote
Old 03-01-10, 11:32 PM   #32
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Added the line as per Jupper's suggestion but still no audio on hdmi on my TV. I do use the patch described in the wiki.

$ cat /etc/modprobe.d/sound.conf
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=0 probe_mask=4

Alsa does seem to recognize the nvidia hdmi.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

This is how I tried to check if alsa works.

My onboard sound card with stereo output works with this command.
$aplay -D plughw:0,0 /usr/share/sounds/alsa/Front_Center.wav

But no sound on my TV when I try to check hdmi audio output.
$ aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav
Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

Any ideas/suggestions? Should I try a different probe_mask in my sound.conf?

Thanks.
rp_linux is offline   Reply With Quote

Old 03-02-10, 12:51 AM   #33
paoleary
Registered User
 
Join Date: Feb 2010
Posts: 37
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by rp_linux View Post
Any ideas/suggestions? Should I try a different probe_mask in my sound.conf?
You really should be down to a single nVidia device in `aplay -l' with that probe_mask (4d=0000 0100b => probe slot 3 only). Did you try playing from device 7? Might be worth a shot.
paoleary is offline   Reply With Quote
Old 03-02-10, 01:22 PM   #34
Juppers
Registered User
 
Join Date: Feb 2010
Posts: 3
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Where you have 2 sound cards, you may need to try
options snd-hda-intel enable_msi=0 probe_mask=-1,4

Quote:
Originally Posted by rp_linux View Post
Added the line as per Jupper's suggestion but still no audio on hdmi on my TV. I do use the patch described in the wiki.

$ cat /etc/modprobe.d/sound.conf
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=0 probe_mask=4

Alsa does seem to recognize the nvidia hdmi.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

This is how I tried to check if alsa works.

My onboard sound card with stereo output works with this command.
$aplay -D plughw:0,0 /usr/share/sounds/alsa/Front_Center.wav

But no sound on my TV when I try to check hdmi audio output.
$ aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav
Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

Any ideas/suggestions? Should I try a different probe_mask in my sound.conf?

Thanks.
Juppers is offline   Reply With Quote
Old 03-02-10, 06:49 PM   #35
paoleary
Registered User
 
Join Date: Feb 2010
Posts: 37
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by Juppers View Post
Where you have 2 sound cards, you may need to try
options snd-hda-intel enable_msi=0 probe_mask=-1,4
Oh, duh, what he said. You've got to skip past that first card. Though again, shouldn't the probe_mask screw up the first card to only show device 3?
paoleary is offline   Reply With Quote
Old 03-03-10, 11:21 AM   #36
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Hi Juppers, Paoleary - That was it! Now I can hear audio over hdmi. Tried both stereo and 5.1, both worked.

Thanks a bunch for all your help!

For my learning sake, can you clarify what exactly probe_mask does and why it helped here.

A few lines in Paoleary's well written wiki may benefit several others who refer it.

Thanks.
rp_linux is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:41 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.