Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-01-10, 11:29 AM   #1
rnejdl
Registered User
 
Join Date: Nov 2007
Location: Dallas, TX
Posts: 96
Default Random System Freezes in AMD64.

I have found a random but reproducible system freezes using the AMD64 195.22 driver. I had reverted my system to an older card and that resolved my kernel panic on logging out of X. However, I have had 3 system freezes where the system completely freezes and plays a buzzing sound in the speakers.

In 2 of the cases I was using VirtualBox with at least 2 vm's running. I am not sure but believe it is possibly related to turning on 3d acceleration. In the other, I wasn't using any vm's at all but streaming pandora using the flash plugin.

Not sure if this is an NVIDIA issue or not but I have seen enough reports in this area I had to check.

Rusty Nejdl
rnejdl is offline   Reply With Quote
Old 02-01-10, 05:12 PM   #2
mgmartin
Registered User
 
Join Date: Feb 2010
Posts: 3
Default Re: Random System Freezes in AMD64.

Hey rnejdl,

I encountered two types of hangs with the beta NVidia x86_64 driver. One of my regular hangs was fixed by disabling powerd from running. This definitely fixed a very repeatable kernel lock.

My other hang, like you, happened when I ran VirtualBox. I read somewhere that disabling Linux ABI compatibility in the NVidia driver solved this for someone. I re-installed the NVidia driver removing Linux ABI support ( see Chapter 5 in the NVIDIA-FreeBSD-x86_64-195.22/doc/README ). I ran VirtualBox for over an hour the other day with no hangs. Prior to removing Linux ABI, VirtualBox would hard lock the system within a few minutes, so I think that fixed my VirtualBox hang issue.

Worth a shot of you haven't tried either/both methods.
mgmartin is offline   Reply With Quote
Old 02-01-10, 07:47 PM   #3
rnejdl
Registered User
 
Join Date: Nov 2007
Location: Dallas, TX
Posts: 96
Default Re: Random System Freezes in AMD64.

That almost makes sense since the other freeze was using linux emulation for the flash 10 player on Pandora radio. I just wish I could get something more out of it but with the system completely frozen I couldn't break into anything to get any sort of info on where it froze.

Rusty Nejdl
http://networking.ringofsaturn.com
rnejdl is offline   Reply With Quote
Old 02-02-10, 07:03 PM   #4
mgmartin
Registered User
 
Join Date: Feb 2010
Posts: 3
Default Re: Random System Freezes in AMD64.

So much for the VirtualBox/No Linux ABI theory. My system just froze after a few minutes of running a Windows guest inside VirtualBox.
mgmartin is offline   Reply With Quote
Old 02-02-10, 07:41 PM   #5
rnejdl
Registered User
 
Join Date: Nov 2007
Location: Dallas, TX
Posts: 96
Default Re: Random System Freezes in AMD64.

Yes, had the same thing. I caused mine to happen by enabling 3D acceleration and then resizing the window. I need to validate that disabling 3d acceleration will fix it.

Rusty Nejdl
http://networking.ringofsaturn.com
rnejdl is offline   Reply With Quote
Old 02-02-10, 11:20 PM   #6
mgmartin
Registered User
 
Join Date: Feb 2010
Posts: 3
Default Re: Random System Freezes in AMD64.

I didn't have 3d enabled, so no help there on my end.
mgmartin is offline   Reply With Quote
Old 02-11-10, 09:47 AM   #7
rnejdl
Registered User
 
Join Date: Nov 2007
Location: Dallas, TX
Posts: 96
Default Re: Random System Freezes in AMD64.

I confirmed this behavior this morning. Running an Ubuntu virtual box with the virtual box additions froze my system completely within 5 minutes. I didn't even have it on the screen I was working on. Not 100% convinced this is an NVidia issue but the only way I can think of confirming is by running nouveau driver.

Rusty Nejdl
http://networking.ringofsaturn.com
rnejdl is offline   Reply With Quote
Old 02-20-10, 02:54 PM   #8
mlobo
Lobo
 
Join Date: Dec 2009
Location: Brasil
Posts: 10
Default Re: Random System Freezes in AMD64.

I am inclined to think that IT IS an nvidia issue because I have 2 machines, both with:

- FBSD 8 revision (FreeBSD 8.0-STABLE #0 r204106M: Sat Feb 20 03:29:09 UTC 2010) svned and compiled on the same day on both machines.

- KDE 4.3.5 with openGL, composite and direct rendering enabled on both.

- Vbox 3.1.4 (plus the same version guest additions on each guests i.e. XP, Win7 and Fedora).

- Both machines run the SAME 3 vdi guest files.

One has an Nvidia 9800 GT and the other an GM45 intel.

Only the Nvidia machine always freezes with virtual box
mlobo is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:41 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.