Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-23-10, 05:31 PM   #1
odror
Registered User
 
Join Date: Dec 2006
Posts: 17
Default disable composite on one monitor in a two monitor system

I have persistent video tearing my second monitor (Mitsubushi HDTV). I have tried everything that was suggested with some improvement. Now the tearing is limited to the upper portion of the screen. I have no issue with tearing if I add the following to my xorg.conf

Quote:

Section "Extensions"
Option "Composite" "Disable"
EndSection
Is it possible to disable composite for one monitor only and keep it for the other. Or at lease is it possible to have compiz for one monitor only and disable it for the other.

I have ubuntu 9.10 x86_64
nvidia driver 185.18.36
video card GTS 240

-Thanks.
odror is offline   Reply With Quote
Old 02-24-10, 03:34 AM   #2
packermann
Registered User
 
Join Date: Mar 2009
Posts: 47
Default Re: disable composite on one monitor in a two monitor system

Use Xinenerama instead of TwinView. Or seperate X-Screens.
packermann is offline   Reply With Quote
Old 02-24-10, 11:15 AM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: disable composite on one monitor in a two monitor system

You can't disable Composite on a single X screen because it's a server-wide option. You ought to be able to run Compiz on just one screen, but I haven't tried so I don't know for sure. Please see the Compiz documentation or contact the Compiz support community.
AaronP is offline   Reply With Quote
Old 02-25-10, 05:39 AM   #4
packermann
Registered User
 
Join Date: Mar 2009
Posts: 47
Default Re: disable composite on one monitor in a two monitor system

When using Xinerama, composite is only enabled on one screen.
packermann is offline   Reply With Quote
Old 02-25-10, 08:33 AM   #5
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: disable composite on one monitor in a two monitor system

Quote:
Originally Posted by AaronP View Post
You can't disable Composite on a single X screen because it's a server-wide option. You ought to be able to run Compiz on just one screen, but I haven't tried so I don't know for sure. Please see the Compiz documentation or contact the Compiz support community.
When using separate screens, compiz can be run on only one screen with the --only-current-screen option.

Adam
adamk75 is offline   Reply With Quote
Old 02-25-10, 10:51 PM   #6
odror
Registered User
 
Join Date: Dec 2006
Posts: 17
Default Re: disable composite on one monitor in a two monitor system

Thank you! --only-current-screen works .

I am confused I thought that Xinerama and compiz are not compatible.
When I try both I get the following error:
Quote:
$ compiz --replace
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: not present.
aborting and using fallback: /usr/bin/metacity
Xlib: extension "RANDR" missing on display ":0.0".
odror is offline   Reply With Quote
Old 02-25-10, 11:32 PM   #7
odror
Registered User
 
Join Date: Dec 2006
Posts: 17
Default Re: disable composite on one monitor in a two monitor system

There is a problem even with the --only-current-screen option.

I loose the window manager on the second screen.
odror is offline   Reply With Quote
Old 02-26-10, 02:35 AM   #8
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: disable composite on one monitor in a two monitor system

Compiz serves as a window manager. You need to run a different window manager on the other screen. The window manager you choose needs to support an option like Compiz's --only-current-screen option for that to work. WindowMaker, for example, allows you to specify a single screen with the -display option.
AaronP is offline   Reply With Quote

Old 02-27-10, 11:42 AM   #9
odror
Registered User
 
Join Date: Dec 2006
Posts: 17
Default Re: disable composite on one monitor in a two monitor system

When I try the following on the second screen I get
Quote:
$ wmaker -display :0.1
/usr/lib/WindowMaker/WindowMaker fatal error: it seems that there is already a window manager running
But there is actually no window manager on the second screen.
odror is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.