Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-02-10, 06:31 AM   #13
janvlug
Registered User
 
Join Date: May 2010
Posts: 3
Default Re: Strange problem after hardware upgrade

I submitted this bug report to Fedora:
https://bugzilla.redhat.com/show_bug.cgi?id=588036
janvlug is offline   Reply With Quote
Old 05-14-10, 10:20 AM   #14
bandicoottjo
Registered User
 
Join Date: May 2010
Posts: 2
Default Re: Strange problem after hardware upgrade

I would like to thank Conky for his options on the msi, those did the trick for me as well.

I would like to tell my story, so your story may be similar.

I bought a few new things like a case with a front panel and a sata hotswap hd-bay. The bay wrecked two new hd's. I got new parts under warrenty and in getting everything to work again i came across the message that fc11 stopped being supported. In my case this was very stable with NVIDIA proprietary drivers.

I did an upgrade from fc11 to fc12 with the preupgrade and (next to some problems on /boot diskspace which i had to mess around with by moving files back and forth during the install from a console window) i had problems booting it into X.

As soon as the login-screen should have shown up it dropped to the black screen with a blinking cursor. I found out it was due to the nouveau driver and i could not get this one to work.

Also my system had trouble during boot and got stuck at "Starting udev.....".

I installed the Nvidia propriety drivers again and after some struggle to disable nouveau at boot i got that to run.

To be able to see things happen in the above problems i change a line in /etc/grub/grub.conf from:
kernel /vmlinuz-2.6.32.11-99.fc12.x86_64 ro root=/dev/mapper/VolGroup00-lv_root rhgb quiet SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us
To:
kernel /vmlinuz-2.6.32.11-99.fc12.x86_64 ro root=/dev/mapper/VolGroup00-lv_root rdblacklist=nouveau nomodeset udevtimeout=5

This displayed the boot messages instead of the graphic boot, and udev did not wait to long anymore. I also uninstalled everything (kmod stuff) related to qemu and virtualbox (some googling indicated problems in this area).

Now the system was freezing very soon after login. The timing was not always the same, but within the first 10 minutes.

I played around with the iommu=off and iommu=soft and could not get much out of that, it still frooze.

After adding the options Corky suggested on the msi for nvidia.ko options and the snd-hda-intel everything is working already for 1.5 hour.

I keep you posted if things go wrong again.

Oops on getting the boot time and the current time the system frooze again, any suggestions?

The network is not available anymore either, so no ssh-ing into it is possible anymore, just a hard reset will do the trich again.

I am running on kernel-2.6.32.11-99.fc12.x86_64 and NVIDIA-Linux-x86_64-195.36.24-pkg2.run

Thanks,
Jo
bandicoottjo is offline   Reply With Quote
Old 05-14-10, 11:36 AM   #15
bandicoottjo
Registered User
 
Join Date: May 2010
Posts: 2
Default Re: Strange problem after hardware upgrade

Some things to add to my story.

I have tried and tried booting it and using it and sometimes - depending on how long i waited to hard eset the box - the box rebooted with a bios cmos problem and i had to restore an old config from the list of cmos-settings.

Imoo this could be related to problems i found in other googles on interrupt vector problems. I can imagine that if a program jumps to the wrong spot in mem it cold easily damage cmos values.

I keep you posted.
bandicoottjo is offline   Reply With Quote
Old 06-02-10, 04:51 PM   #16
janvlug
Registered User
 
Join Date: May 2010
Posts: 3
Default Re: Strange problem after hardware upgrade

I still have system crashes, usually when I connect several devices via USB.
I uninstalled all nvidia drivers, and I'm using nouveau now.
Is it possible to use MSI for the USB driver modules as well?
janvlug is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:08 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.