Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-24-10, 01:13 PM   #1
gratefuldad88
Registered User
 
Join Date: Mar 2010
Posts: 4
Default Driver install crashed kernel (Linux 32-bit)

I am attempting to install the driver for a Quadro NVS420 video card on a Fedora 12, 32-bit Linux OS. When I tried to run the executable to install the driver, I got the following error:

"Unable to load the kernel module 'nvidia.ko'. This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources., with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb/nvidiafb is present and prevents the NVIDIA kernel module from obtaining ownership of the Nvidia graphics device(s), or NVIDIA GPU installed in this system is not supported by this NVIDIA Linux graphics driver release.

Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more info"

Even worse, whatever happened when I tried the install crashed the kernel. I cannot even boot up from this kernel now, and just get a big screen dump with memory addresses and it just hangs. I can still go in to my grub screen and boot up another kernel, but I get a popup that says I had a kernel crash. Also, I get the same error when trying to install the driver. I ran 'yum update' to make sure everything was up to speed before I tried the driver installation. I am really stuck now, and not sure how to fix the error, or how to handle the kernel crash. Please help!
gratefuldad88 is offline   Reply With Quote
Old 03-25-10, 08:35 AM   #2
gratefuldad88
Registered User
 
Join Date: Mar 2010
Posts: 4
Default Re: Driver install crashed kernel (Linux 32-bit)

I am starting to think that my problem is that I am running a PAE kernel.

There are specific drivers on rpmfusion for PAE kernels, but they do not support the Quadro series. Is there a driver available for the Quadro series that is specifically for a PAE kernel?
gratefuldad88 is offline   Reply With Quote
Old 03-25-10, 04:17 PM   #3
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: Driver install crashed kernel (Linux 32-bit)

Quote:
Originally Posted by gratefuldad88 View Post
I am starting to think that my problem is that I am running a PAE kernel.

There are specific drivers on rpmfusion for PAE kernels, but they do not support the Quadro series. Is there a driver available for the Quadro series that is specifically for a PAE kernel?
Fedora 12 ships with nouveau as the default driver for NVIDIA GPUs. If you don't disable nouveau before installing NVIDIA, you won't be able to load the kernel module. This is more likely the problem. Did you disable nouveau first?
danix is offline   Reply With Quote
Old 03-26-10, 07:35 AM   #4
gratefuldad88
Registered User
 
Join Date: Mar 2010
Posts: 4
Default Re: Driver install crashed kernel (Linux 32-bit)

I did not disable nouveau. My xorg.conf reads "vesa", so I did not realize that there was a conflict. How do I disable nouveau?
gratefuldad88 is offline   Reply With Quote
Old 03-26-10, 10:48 AM   #5
puntarenas
Registered User
 
Join Date: Mar 2010
Posts: 9
Default Re: Driver install crashed kernel (Linux 32-bit)

RPM Fusion nVidia HowTo

I prefer blacklisting Nouveau, but rebuilding the initramfs via dracut worked for me as well.

As a quick solution, this will blacklist Nouveau in /etc/grub/grub.conf as described in the Nvidia guide for F13 Development:
Code:
sed -i '/root=/s|$| rdblacklist=nouveau|' /boot/grub/grub.conf

Last edited by puntarenas; 03-26-10 at 10:53 AM. Reason: quick solution
puntarenas is offline   Reply With Quote
Old 03-29-10, 09:29 AM   #6
gratefuldad88
Registered User
 
Join Date: Mar 2010
Posts: 4
Default Re: Driver install crashed kernel (Linux 32-bit)

Thank you for the help, guys!

I had to do a couple of things to get it to all work correctly.

1. I had to set SELinux to permissive
2. I had to disable the Nouveau driver
3. I had to set the screen resolution in grub.conf also (vga=792)

Thanks again!
gratefuldad88 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.