Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-08-03, 11:38 PM   #1
BarefootClown
Registered User
 
Join Date: Jul 2003
Posts: 1
Question Unresolved symbols in nvaudio and nvnet

Greetings, all. Just got myself a new toy (Shuttle SN41G2), and immediately dropped Debian on it. I rapidly discovered, much to my chagrin, that getting the audio and network drivers to work on the thing was going to be a challenge. (Got video working with a minimum of problems, fortunately. Nothing like a good .deb package.) I've followed the directions included with the drivers (as near as I can tell), but I keep getting unresolved symbols.

nvnet reports:
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol alloc_skb_Rffc2b156
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol unregister_netdev_R8d471709
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol skb_over_panic_R87afec27
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_free_consistent_Rd23139f1
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_find_capability_R27d20cd3
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_read_config_word_R013f4ee4
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol __kfree_skb_R97c3ea10
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_alloc_consistent_R1f6a8dc8
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol eth_type_trans_Rb70955be
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol __netdev_watchdog_up_R22a24147
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol alloc_etherdev_R32617cd4
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol netif_rx_R6a05d4d1
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_write_config_word_Rc7c3e0a9
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_enable_device_R944b5e42
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol softnet_data_R0094de62
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol register_netdev_R1efdd094
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_disable_device_R096b99a6
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_set_master_R87a01918
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_register_driver_R465aa46c
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_unregister_driver_R26713b86
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_set_dma_mask_R0f4a2604
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o:

nvaudio reports:
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol alloc_skb_Rffc2b156
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol unregister_netdev_R8d471709
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol skb_over_panic_R87afec27
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_free_consistent_Rd23139f1
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_find_capability_R27d20cd3
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_read_config_word_R013f4ee4
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol __kfree_skb_R97c3ea10
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_alloc_consistent_R1f6a8dc8
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol eth_type_trans_Rb70955be
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol __netdev_watchdog_up_R22a24147
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol alloc_etherdev_R32617cd4
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol netif_rx_R6a05d4d1
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_write_config_word_Rc7c3e0a9
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_enable_device_R944b5e42
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol softnet_data_R0094de62
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol register_netdev_R1efdd094
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_disable_device_R096b99a6
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_set_master_R87a01918
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_register_driver_R465aa46c
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_unregister_driver_R26713b86
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o: unresolved symbol pci_set_dma_mask_R0f4a2604
/lib/modules/2.4.20-dave-with-810-1/kernel/drivers/net/nvnet.o:

I've tried compiling a 2.4.20 kernel (and 2.4.18, and 2.4.21), and I did include the i810 audio drivers. Anybody have any thoughts?
BarefootClown is offline   Reply With Quote
Old 07-11-03, 07:13 AM   #2
thorgau
Registered User
 
Join Date: Jul 2003
Posts: 2
Default

About these unsolved symbols:
In the readme of nv-nforce drivers theres something written about it.

I think you dont have the matching sources corresponding to your kernel version.
Try to install the "right" version and it should work.
thorgau is offline   Reply With Quote
Old 07-19-03, 03:09 AM   #3
vitex
Registered User
 
Join Date: Jul 2003
Location: Prague
Posts: 2
Send a message via ICQ to vitex
Thumbs down Mandrake 9.1

Unresoved symbols problem is very common in new versions of mandrake kernel. In 2.4.21-13mdk I cant add-compile even the nForce drivers and Aurela Vortex sound card module. In both cases i get the many unresolved symbols and waring about the bad version of GCC
__________________
Hare Linux! Make Love, not War!
vitex is offline   Reply With Quote
Old 07-19-03, 11:18 AM   #4
connyosis
Eggplant
 
connyosis's Avatar
 
Join Date: May 2003
Location: Sweden
Posts: 86
Send a message via ICQ to connyosis
Default

In the kernel source tree, do a make mrproper. This will delete all old files from a previous kernel that might cause this problem. Then configure, build and install your new kernel, try to recompile the nvidia drivers and it should work fine.
__________________
"Never bump a baby carriage out of a crosswalk unless the kid's really asking for it."
connyosis is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing nForce drivers on Debian 3.0 Doink NVIDIA Linux 4 09-14-02 09:34 PM
Cannot load nvaudio driver (NVidia nforce) thahn01 NVIDIA Linux 4 09-13-02 02:28 AM

All times are GMT -5. The time now is 06:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.