Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-01-10, 02:12 AM   #1
jkohen
Registered User
 
Join Date: Apr 2010
Posts: 4
Default Switching between applications slows down after suspend

On a fresh boot everything works fine, but after suspend, I've noticed some strange behavior that's 100% reproducible. When transferring focus from one X application to another, the system becomes unresponsive for a couple seconds. This only happens when certain conditions are met:
  1. Switching from one Gnome/Gtk+ application to another does not show this issue.
  2. Switching from one Gnome/Gtk+ application to a Wine windows shows this issue. It suffices to launch winecfg or regedit, but every Wine application I've tried triggers this behavior.
  3. Opening a dialog or pop-up menu inside a Wine application often shows this issue.
  4. Switching from one Gnome/Gtk+ application to a Qt application (e.g. Keepass/X) sometimes shows this issue.
  5. Opening a dialog or pop-up menu inside a Qt application often shows this issue.

I think this might be accompanied by a slight drop in frame rate in some games, but I haven't investigated this in depth.

I know this problem exists with driver 190.53 and 195.36.15. Exiting X/GDM, removing the nvidia kernel module, installing it back and restarting X/GDM doesn't solve the issue. Only rebooting the machine seems to get me out of this situation. This triggers every time after the first suspend cycle.

My desktop environment is GNOME with the Gnome Shell window and composite manager.

I'm attaching the nvidia bug report log after one suspend cycle, where the issue appears, and also a -pre file from the fresh boot right before suspending, where I've confirmed this behavior doesn't happen.
Attached Files
File Type: gz nvidia-bug-report.log.gz (61.8 KB, 55 views)
File Type: gz nvidia-bug-report-pre.log.gz (74.9 KB, 57 views)
jkohen is offline   Reply With Quote
Old 04-01-10, 09:49 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Switching between applications slows down after suspend

Do you also see a similar slowdown if you drag the color correction sliders in nvidia-settings? If so, I've also run into this problem and hope to look into it soon.
AaronP is offline   Reply With Quote
Old 04-01-10, 02:03 PM   #3
_john_i_
gtx260/8200M G/DIY Linux
 
Join Date: Aug 2004
Location: Austin, TX USA
Posts: 137
Default Re: Switching between applications slows down after suspend

I've noticed the same thing lately. I am in kde 4.4.1, and as you describe, switching applications after a resume from suspend will cause everything to be unresponsive for a second or two. I mainly notice it if I switch between firefox (gtk), and konsole (qt4).

For me though, once it has happened a few times the problem seems to go away until the next suspend/resume.

I am using kwin with compose enabled for effects.
_john_i_ is offline   Reply With Quote
Old 04-01-10, 03:17 PM   #4
jkohen
Registered User
 
Join Date: Apr 2010
Posts: 4
Default Re: Switching between applications slows down after suspend

Quote:
Originally Posted by AaronP View Post
Do you also see a similar slowdown if you drag the color correction sliders in nvidia-settings? If so, I've also run into this problem and hope to look into it soon.
Actually, yes, I see a similar slowdown when doing what you describe. It's great to know the issue will be finally getting some attention!
jkohen is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.