Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-12-10, 04:38 AM   #1
trapanator
Registered User
 
Join Date: Sep 2007
Posts: 5
Talking [SOLVED] Nvidia 195.36 on amd64: Segmentation fault

My PC is running on Q9550 and Nvidia 9500GT.

Installing 195.36 results a segmentation fault, as following X.org.log:

Code:
X.Org X Server 1.7.5
Release Date: 2010-02-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-ARCH x86_64 
Current Operating System: Linux stazione2 2.6.32-ARCH #1 SMP PREEMPT Tue Feb 23 19:43:46 CET 2010 x86_64
Kernel command line: root=/dev/sda5 ro checkdisk quiet vga=795
Build Date: 17 February 2010  07:57:38PM
 
Current version of pixman: 0.16.6
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar  1 10:54:51 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(**) FontPath set to:
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1,
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x7c0fa0
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
(--) using VT number 7

(--) PCI:*(0:0:5:0) 10de:0240:1043:81cd nVidia Corporation C51PV [GeForce 6150] rev 162, Mem @ 0xfc000000/16777216, 0xd0000000/268435456, 0xfb000000/16777216, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded by default.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Server Extension
(II) NVIDIA GLX Module  195.36.08  Thu Feb 25 04:50:39 PST 2010
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  195.36.08  Thu Feb 25 04:18:36 PST 2010
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 00@00:05:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) Mar 01 10:54:51 NVIDIA(0): Enabling RENDER acceleration
(II) Mar 01 10:54:51 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Mar 01 10:54:51 NVIDIA(0):     enabled.
(II) Mar 01 10:54:52 NVIDIA(0): NVIDIA GPU GeForce 6150 (C51) at PCI:0:5:0 (GPU-0)
(--) Mar 01 10:54:52 NVIDIA(0): Memory: 524288 kBytes
(--) Mar 01 10:54:52 NVIDIA(0): VideoBIOS: 05.51.22.33.07
(--) Mar 01 10:54:52 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Mar 01 10:54:52 NVIDIA(0): Connected display device(s) on GeForce 6150 at PCI:0:5:0:
(--) Mar 01 10:54:52 NVIDIA(0):     ACI ASUS VK193 (CRT-0)
(--) Mar 01 10:54:52 NVIDIA(0): ACI ASUS VK193 (CRT-0): 350.0 MHz maximum pixel clock
(II) Mar 01 10:54:52 NVIDIA(0): Assigned Display Device: CRT-0
(==) Mar 01 10:54:52 NVIDIA(0): 
(==) Mar 01 10:54:52 NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) Mar 01 10:54:52 NVIDIA(0):     will be used as the requested mode.
(==) Mar 01 10:54:52 NVIDIA(0): 
(II) Mar 01 10:54:52 NVIDIA(0): Validated modes:
(II) Mar 01 10:54:52 NVIDIA(0):     "nvidia-auto-select"
(II) Mar 01 10:54:52 NVIDIA(0): Virtual screen size determined to be 1440 x 900
(--) Mar 01 10:54:52 NVIDIA(0): DPI set to (89, 87); computed from "UseEdidDpi" X config
(--) Mar 01 10:54:52 NVIDIA(0):     option
(==) Mar 01 10:54:52 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) Mar 01 10:54:52 NVIDIA(0): Initialized GPU GART.
(II) Mar 01 10:54:52 NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) Mar 01 10:54:52 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Mar 01 10:54:52 NVIDIA(0): Initialized X Rendering Acceleration
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(==) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x45a8d8]
1: /usr/bin/X (0x400000+0x61a19) [0x461a19]
2: /lib/libpthread.so.0 (0x7fb3ef762000+0xee80) [0x7fb3ef770e80]
3: /lib/libc.so.6 (_IO_vfprintf+0x409e) [0x7fb3eea34cae]
4: /lib/libc.so.6 (vsnprintf+0xa2) [0x7fb3eea5a572]
5: /usr/bin/X (LogVWrite+0x7f) [0x456b8f]
6: /usr/bin/X (LogVMessageVerb+0x64) [0x4571e4]
7: /usr/bin/X (xf86Msg+0x97) [0x4f3107]
8: /usr/lib/xorg/modules/extensions/libglx.so (0x7fb3ed1fd000+0x288b6f) [0x7fb3ed485b6f]
Segmentation fault at address 0x1

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
Reverting to 190 fixes this issue.

Any hint?

There are another people that have this issue, as described here:

http://bbs.archlinux.org/viewtopic.php?id=92254

Last edited by trapanator; 04-16-10 at 08:29 AM. Reason: Solved the problem!
trapanator is offline   Reply With Quote
Old 04-12-10, 09:25 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Nvidia 195.36 on amd64: Segmentation fault

Do you have X server debugging symbols on Arch Linux? If so, could you please run X from an SSH session with "gdb --args X -dumbSched -keeptty", put a breakpoint on LogVWrite, and then continue until it crashes? You should be able to do it like this:
Code:
b LogVWrite
commands 1
backtrace
continue
end
set height 0
run
I'd like to know what it's trying to print when it crashes.
AaronP is offline   Reply With Quote
Old 04-12-10, 05:11 PM   #3
infallible
Registered User
 
Join Date: Apr 2010
Posts: 3
Default Re: Nvidia 195.36 on amd64: Segmentation fault

I've heard of a bug involving nvidia drivers and input specifications in xorg.conf, though i'm not sure as to the details or scope.

Try commenting out your input device sections of xorg.conf (or moving it to force the system to generate a new one) and see if the bug applies.
infallible is offline   Reply With Quote
Old 04-16-10, 08:29 AM   #4
trapanator
Registered User
 
Join Date: Sep 2007
Posts: 5
Default Re: Nvidia 195.36 on amd64: Segmentation fault

I solved this bug thanks. See the post #12 on:

http://bbs.archlinux.org/viewtopic.p...743130#p743130
trapanator is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:21 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.